Join 3,572 readers in helping fund MetaFilter (Hide)


Help me with my internet annoyance.
March 26, 2009 3:37 PM   Subscribe

I sometimes have trouble with downloading via torrent: surfing becomes a slow crawl/not an option.

I have a broadband DSL connection and I'll often download torrents via Transmission on my iMac.

The problem is with torrents: with either Transmission, or uTorrent I can go for several days, even longer than a week, but then suddenly surfing pages on a browser will slow to a crawl and then stop. Torrent downloading may or may not stop at that point, but eventually it stops too.

When this happens I unplug my DSL modem, plug it back in, wait a minute or two, and then I'm firing on all cylinders, torrent downloading and surfing are good for another week or so.

So how can I avoid this step? Settings in Transmission? Hack the modem?
posted by zardoz to Computers & Internet (18 answers total) 5 users marked this as a favorite
 
Not sure about Transmission, but in uTorrent sometimes the client is set to delay uploading until the torrent is complete. Thus you download your torrent, then a few days later it suddenly hits your upstream bandwidth (always less than your down with DSL) and it can really suck away performance.

Not sure why it would happen on a week-to-week basis though.

Check your up and down stream configurations.
posted by wfrgms at 3:41 PM on March 26, 2009


Do you have a router between your computer and the DSL modem? I have ran in to problems with running out of memory on some of the cheaper routers.
posted by Climber at 3:45 PM on March 26, 2009


Have you tried limiting your upload and download speeds? Especially your upload speed. I had this problem with Azureus, and limiting the upload speed to something like 45kb/s fixed it.
posted by spikeleemajortomdickandharryconnickjrmints at 3:53 PM on March 26, 2009


wfrgms--I don't think uploading is an issue, but I'll keep an eye out for that.

climber--no, no modem
posted by zardoz at 3:54 PM on March 26, 2009


yeah, my upload speed is 50kb/s, but the lag will happen eventually.

I should clarify, this browser crawl/shutdown happens more like every two or three days, though the time varies.
posted by zardoz at 4:01 PM on March 26, 2009


Depending on the model you might have to adjust some internal networking settings. DSL modems are basically mini-computers and can be fiddled with via telnet (haven't seen DIP switches in awhile, thank goodness!)

This thread covers configuring the Actiontec GT701. Try searching for your model number + 'telnet' for instructions.
posted by llin at 4:02 PM on March 26, 2009


I've found that if I max out my upload speed with torrents for a while, the same thing happens (using uTorrent and WinXP behind a router), and I've always attributed it to my service provider (Charter Cable in California). I thought that unplugging your modem will probably re-set your IP (assuming it's dynamic), so you start over for whatever magical tally the ISP is keeping on you.

I no longer keep torrents uploading for very long, though I can still keep a 1:1 or better ratio because I'm downloading that I used to. I know this isn't a solution, but it could be an option.
posted by filthy light thief at 4:03 PM on March 26, 2009


Climber has it. This is your problem (although you may not have the same kind of modem). Your modem/router is keeping a table of active and previously active NAT connections. BitTorrent likes to establish a lot of connections, and it cheap routers can't handle it.
posted by qxntpqbbbqxl at 4:04 PM on March 26, 2009


Oh yeah, search for discussions on your ISP on forums like DSLreport and other ISP discussion forums. There might be some insight there.
posted by filthy light thief at 4:05 PM on March 26, 2009


I had the same problem, and Climber and qxn.... whatever ... have it right--it's the NAT table. The giveaway is that when you unplug the router and plug it back in again (which clears the table) everything becomes hunky and also dory. I fixed the problem by upgrading my router. Note that I'm not techie enough to know if the table is maintained in your DSL modem or router, assuming they aren't the same box. I'm sure someone here can tell you.
posted by The Bellman at 4:16 PM on March 26, 2009


climber, qxn, bellman--so if it's the number of connections ("gobal maximum connections" and "maximum connections for new transfers" on Transmission), then what would be a good number? Now I have it set as 100 for both, should I halve that? Less?
posted by zardoz at 4:32 PM on March 26, 2009



Halve it until the problem goes away.

You might also be able to shorten the time your router keeps connection info in the NAT table. See llin's post.
posted by qxntpqbbbqxl at 5:32 PM on March 26, 2009


First guess: upstream bandwidth, you're saturating your link. uTorrent lets you throttle it. Second guess: router state tables. If you tell us what router you have we could maybe help in more detail. Honestly the simplest thing is to either replace the router or reset it every few days if you're constantly running bittorrent.
posted by Nelson at 6:07 PM on March 26, 2009


Reduce the maximum amount of connections allowed globally in your client, I find that even 100 connections can make my internet painfully hard to use. Start at a low number and increase until you start seeing slowdowns, then move it down a notch.

However, not sure if that setting exists in transmission - it does in utorrent.
posted by Sonic_Molson at 6:42 PM on March 26, 2009


When files are downloaded using the tcp protocol, the downloading computer has to send tcp acknowledgements (ACK packets) to the sending computer. Basically a way of saying "hey i got the information, keep sending it".

When your upstream is saturated by torrent uploading, your provider/cable modem/router either drops or doesn't send the ACK packets fast enough, which affects your download performance.

Some routers have ACK packet prioritization options, you might google around for your model and "ack priority". This page shows how to prioritize on openbsd, and has a great graph of how download performance is affected by upload.
posted by zentrification at 8:57 PM on March 26, 2009


Nthing the upload speed. It needs to be lower than you think, without some router-fu.
posted by JauntyFedora at 1:16 AM on March 27, 2009


I don't know if there is a Mac equivalent but Windows XP limits the number of TCP connections you can have active at any given time to 10 by default. Apparently they do this so that if your machine ever falls victim to self-propagating malware you won't distribute it to other machines at super high volumes. The downside to this is that if your torrenting client is set too high you jam up your machine's internet flowage. In uTorrent this setting is in the advanced section, the variable being called net.max_halfopen.

At one point I increased net.max_halfopen without changing Window's max TCP connections and suffered the same performance issues you describe. I originally thought that my router was limiting the traffic. After some research I used a utility to increase my maximum TCP connections to 100 and set my net.max_halfopen to 80. I now get unhindered web surfing and faster download speeds than I ever had previously.

I'm sorry for my lack of input regarding the Mac equivalents, but maybe this will get you moving in the right direction.
posted by Gainesvillain at 8:07 AM on March 27, 2009


Gainesvillian, I hate to say you are not correct. XP limits new connections per second to 10, not just 10 connections.
posted by dozo at 7:28 PM on March 28, 2009


« Older I'm looking for americana musi...   |  Moving to Seattle! I am about ... Newer »
This thread is closed to new comments.