A grave error.
June 20, 2008 8:31 AM   Subscribe

Itès a mystery. I was typing comments into the MeFi text box, when all of a sudden every apostrophe turned into the letter e with a grave accent. What gives?

It didnèt happen in Word or Notepad. Just MeFi and Google text boxes. Ièm reproducing it here for illustration only, since I fixed it with system restore, but what would cause this to happen spontaneously? Stuck keys? Spider walking on my circuit boards? That French visitor I had last week?
posted by weapons-grade pandemonium to Computers & Internet (9 answers total) 2 users marked this as a favorite
 
That's how the setting input locale French works out in Windows. Apparently your browser had a setting for preferred input locale French.
posted by jouke at 8:41 AM on June 20, 2008


That French visitor I had last week?

I strongly suspect this is the reason, because it's a huge coincidence otherwise. Could your visitor have switched your default keyboard settings using these instructions, then forgotten to switch them back?
posted by cerebus19 at 8:43 AM on June 20, 2008


Oh, except that would affect your entire system, not just your browser. jouke's got it, I think.
posted by cerebus19 at 8:43 AM on June 20, 2008


I'm runnig Vista and Firefox 3. Thing is, everything was working perfectly normally before this happened. I was entering text in the same text boxes without error. It only went French on me for a few minutes, and I fixed it with Restore. I didn't change any keyboard settings. Visitor was gone a week ago.
posted by weapons-grade pandemonium at 8:51 AM on June 20, 2008


The French visitor added the French keyboard layout to your international settings so that he/she could use your keyboard. The visitor probably switched the layout back to English, but didn't remove the layout as an option. Therefore, some keypress (I forgot exactly what it is, something like ctrl+shift) will swap back and forth between the two layouts. You probably pressed that key combination by accident.

For future reference, you can add/remove keyboard layouts using Control Panel -> Regional and Language Options -> Languages -> details.
posted by helios at 8:53 AM on June 20, 2008 [3 favorites]


I think you have it, helios. Thanks.
posted by weapons-grade pandemonium at 8:58 AM on June 20, 2008


nice post title.
posted by iamkimiam at 8:58 AM on June 20, 2008


Control + Shift once gives me the grave accent.
Control + Shift twice gives me the è.
Control + Shift thrice sets it back to normal.

Bingo.
posted by weapons-grade pandemonium at 9:01 AM on June 20, 2008


This is interesting. I have had the same problem for a long time and it if frickin' annoying. For me, one program suddenly gets switched to it for no reason. MSN Messenger, or Outlook, or sometimes Firefox. I close the program and go back in and it is usually gone. However, I have had no French visitors - it's a personal computer at work that nobody else uses. And I did already check the Regional and Language Options stuff... and nothing helped. There were no french inputs selected in the first place. I will try the control shift thing though, this is the first time I've heard of that.

I don't see how the regional settings just automagically futz up for me like that.... unless I'm accidentally hitting control shift! Hmm...
posted by Jupiter Jones at 8:52 PM on June 20, 2008


« Older How do I straighten a length of plastic tubing?   |   Driving off a Swarm Newer »
This thread is closed to new comments.