Standby and hibernation issues
March 29, 2008 7:58 AM   Subscribe

How can I fix my restless computer? (standby/hibernate problems)

Computer: Dell E1705 laptop, Core 2 Duo 2.0ghz, 2GB ram, updated drivers, Vista Ultimate SP1 32-bit

Lately I have noticed weird happenings with my computer. First of all, standby just doesn't work any more. I'll press the button, the screen will fade to black as usual, and it pretends like it's sleeping - but after waiting, the power never goes out, and I move the mouse and the screen comes back on, to show the locked computer screen. Sometimes, after a fresh restart, it will work, but it's very seldom.

Hibernate, however, seems to work ok. I press the hibernate button, the screen fades, and then about a minute later (after full harddrive activity - how long does it take to dump 2gb??) the computer shuts off.

But there is something weird going on. I will tell it to hibernate, it will go off, and I'll put it in my backpack, and then somehow I believe it turns itself on. I have not fully caught it in the act yet, so that's my next priority, but I discover it later with practically dead battery life, running very hot, inside my backpack. I'm pretty doggone sure I hibernated it and waited til I saw it shut off, but that's the problem - there's always that element of doubt, because I'd like to think the computer can not possibly turn itself on spontaneously. It has happened twice now, both times in my same backpack, both times after using it (plugged in) for a while and then hibernating (I think). For the purposes of this question, assume it is as I think - that I do successfully hibernate it to the point where it's off, then I unplug the outlet and put it in my bag, and then somehow it turns on.

So this is a two-part question:
How do I find whatever is stopping the computer from standby? Do you think it's a piece of software, or maybe a service? How can I diagnose it?; and
How is it possible that the computer turns itself back on? How can I prevent this?

These things never used to happen to me - I think they started around the time I upgraded to SP1. While I'd like to think SP1 is not the cause of them, I just can't be sure. Maybe it was one of the Windows Updates? Bottom line is, if none of your suggestions help then I guess I'll be backing up, reformatting, and then installing things one-by-one and testing standby and hibernate after each one.
posted by Ricket to Computers & Internet (8 answers total)
 
I would start by taking a look at the Windows event log for the time period between hibernation and finding it switched on. There may be some warnings or errors there that give you a clue as to the cause.

On my laptop, if you set it to Standby, it will 'wake up' 20 minutes later and sit on the 'Computer Locked' screen. This is because it automatically tries to hibernate after 20 minutes of being on standby, and Windows reports that there's not enough disk space to dump all 2Gb of memory to disk. This error causes the computer to come on again, rather than stay on standby. Something similar may be causing your problems.
posted by matthewr at 8:21 AM on March 29, 2008


Sigh. I have the sad duty to inform you that this is not an uncommon problem with Vista. In fact, my Lenovo X61 developed it after one of the various updates I applied. I never did find the specific update that caused the problem. I simply had to roll-back to an earlier backup to get back to the functionality. Since then, I have made backups prior to every system update and have eschewed all driver updates. James Kendrick tackled this subject when he ran into it. Perhaps it will offer you some clues.
posted by tcv at 9:01 AM on March 29, 2008


Okay so I'm assuming you've done what I'm about to suggest, but hey doesn't hurt to try:

Check your power and button / lid settings.
Bring up the start menu, and in the search box, type "power options" (without quotes) and hit enter. First look at the items on the left and you should see a selection titled "Choose what the power buttons do" Check that and make sure the buttons are set to what you want them to do, if they aren't, there's your issue.

Also check the plan settings for whatever plan is selected, and go into the "advanced settings'. Check sleep and hibernation settings there if they're there.

WIth that out of the way, here are some possible causes and solutions for your problem if the above checks out:

Excellent tutorials related to your problem
(2nd post in that thread is titled "How to Restore the Hibernation File in Vista" - sounds like this might be what you're looking for as for your hibernation issue)



Hope that helps!
posted by rasmerack at 9:18 AM on March 29, 2008


er my links didn't appear. I'm new here, so not sure how this all works but here goes again

http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html#post317574

http://support.microsoft.com/kb/929658
posted by rasmerack at 9:19 AM on March 29, 2008


Here are some snippets from that thread regarding BIOS settings that affect sleep / hybrid / hibernate in Windows:

Check Sleep State in BIOS :
NOTE: Make sure you have the latest Video drivers and BIOS for your motherboard.
1. Open Start Menu.
2. In white line (Start Search) area, type cmd and press Enter.
3. In command prompt, type powercfg -a and press Enter.
NOTE: This will give you a report of the available sleep states for your computer and will attempt to report reasons why sleep states are unavailable. You will want to see S1 and/or S3 listed.
4. Restart the computer into the BIOS settings, and go into the Power Management sectionin the BIOS.
NOTE: Usually you will press the F2 or Delete key as soon as your computer starts booting to enter the BIOS.
5. Make sure ACPI mode: S3 or S1 is enabled.
NOTE: S1 (Sleep) and S3 (Hybrid/ deeper sleep). If you are running an incompatible video card, some or all of these states below will be unavailable. If one of the settings causes your computer to not wake back up, then unplug the computer and plug it back in and start it back up into the BIOS and change the setting back.

6. Make sure Wake on Ring and Wake on Lan are disabled.
NOTE: This will help with keep the computer from waking up on it's on.

7. Save the BIOS setting changes and exit to restart the computer.
8. Test sleep mode. If this does not help, then move on to the next step.
posted by rasmerack at 9:33 AM on March 29, 2008


There is of course the obvious answer = dont use standby or hibernate.

Yes, I realize it 'should' work (and does for some people/configurations), but in my 10+ years of PC Support work, its been my experience that Standby/Hibernate generally causes more problems than the convenience its supposed to provide. I realize its a minor annoyance to wait for your laptop to boot every time you need it, but thats a small price to pay for the reliability of not using standby/hibernate. I guess you just have to ask yourself: How much valuable time and resources are you willing to sink into figuring it out, as compared to the relatively easy solution of just turning OFF power management.
posted by jmnugent at 11:13 AM on March 29, 2008


Somehow my standby is working tonight... I realized my power was set to "High Performance" rather than "Balanced", so I changed it to balanced. Then I got the bright idea that maybe, somehow, that was preventing standby, so I hit the button - and my computer went to sleep.

But the odd thing is, I then woke it up and changed back to high performance, and hit standby again, and it worked again. It's so inconsistent! And I don't see any different in my running programs between now and before. I really have no idea what caused this suddenly to start working.

But perhaps the fact that it was on 'high performance' was preventing standby somehow? I'll be keeping it between balanced and power saver for the next few days and standby-ing every time I walk away from the computer, so I will post back here with any updated information.

Thanks for the tips everyone. I still am not sure what caused the hibernation to wake up, and I've used it twice today and both times it stayed hibernated, so I really am clueless in that respect. But as for the standby, the event log showed nothing and the power settings were all fine so I don't know.
posted by Ricket at 8:05 PM on March 29, 2008


I don't have the exact screen in front of me and and currently too busy to go searching, but my similar (vexing!) problem was solved with I disabled, "wake on LAN". It was waking on directed network traffic by default.
posted by RikiTikiTavi at 3:31 PM on March 31, 2008


« Older How do I deal with my boyfriend's insane work...   |   who does good haircuts for curly/wavy hair in... Newer »
This thread is closed to new comments.