Why no white space?
November 7, 2007 12:30 PM   Subscribe

Thunderbird - Where is my white space?

A few months ago I switched from OE to Thunderbird, and am very happy with it except for this one annoyance.

I'm an old-school touch-typist and by habit I create paragraph breaks by hitting the return key twice. In OE this always created a paragraph break, but in Thunderbird, it doesn't always do this and I have to remember to hit the return key three times, which doesn't come naturally, so I usually forget to do it.

As a result, my emails - once they are sent - often look as if they contain no paragraph breaks or white space, which I know is a PITA for recipients.

The thing is, when I'm composing emails, they look perfectly normal. It's only when people reply to me quoting my email in their reply, or if I send an email to myself in the office that I see the lack of paragraph breaks.

My settings for email composition are: Body Text/Variable Width/HTML with a Verdana font. Windows XP Home edition.

Is there any way of fixing this so I get a paragraph break with two hits of the return key?
posted by essexjan to Computers & Internet (24 answers total) 1 user marked this as a favorite
This is just one of many problems that are caused by HTML mail. People creating HTML mail in Outlook also create e-mail that is a pain and ugly to people using some other mailers. To turn it off:

Tools > Account Settings
Composition & Addressing
Composition > Compose messages in HTML format
posted by grouse at 12:37 PM on November 7, 2007

Response by poster: I'm using Thunderbird, not Outlook.
posted by essexjan at 12:41 PM on November 7, 2007

So am I. The instructions above were for version 2.0. What version are you using?
posted by grouse at 12:56 PM on November 7, 2007

grouse, you said "People creating HTML mail in Outlook"
posted by misterbrandt at 12:59 PM on November 7, 2007

The next word is "also." That implies some other entity that can create HTML mail that is a pain for a recipients. In this case, I thought it was pretty clear that the other entity was Thunderbird. Maybe not. In any case, you now know what I meant.
posted by grouse at 1:01 PM on November 7, 2007

Response by poster: Oh. Your reply was worded as if I am an Outlook user.


So if I turn off HTML, how do I get rid of forwarding/reply carats in T-bird?
posted by essexjan at 1:01 PM on November 7, 2007

Response by poster: (I meant 'carets'. I can't have enough 'carats')
posted by essexjan at 1:05 PM on November 7, 2007

By "carets" are you referring to the right angle/greater than quote symbols at the left of quoted text?

You shouldn't get any when you forward messages.

When you reply to messages the quote symbols will show up instead as blue lines to people using Thunderbird, just as if you were in HTML mode. People who aren't using an HTML mailer would have seen the same quote symbols as well when getting your HTML mail—except it could sometimes get really ugly.
posted by grouse at 1:13 PM on November 7, 2007

Response by poster: Yes, >>> these things. I hate them. I just switched to plain text on my main account. Got an email from a friend (who uses Outlook HTML and Comic Sans MS, so I am not as bad as that). I went to reply and it was all


down the page.

Can I get rid of them automatically in Thunderbird? Or replace them with something less obtrusive?
posted by essexjan at 1:18 PM on November 7, 2007

Response by poster: I also just forwarded an email from one account to another in plain text and got > all down the margin, not a blue line. I only get the blue line when forwarding in HTML.
posted by essexjan at 1:26 PM on November 7, 2007

I don't understand why you are getting quote symbols when you forward. You should only get them for replies. Is this not the case?
posted by grouse at 1:30 PM on November 7, 2007

Response by poster: No, I'm not now, go figure. The ones showing up on reply are a PITA. What can be done about them?
posted by essexjan at 1:36 PM on November 7, 2007

They are the correct way of indicating quoting, so nothing should be done about them.
posted by kindall at 1:50 PM on November 7, 2007

I'm not sure that there is anything that you can do about them, and I've looked. You can use forward and then type in the addresses again, or you can use reply and copy-and-paste the original text. If no one else gives you an answer here you might try the MozillaZine forums.

Keep in mind that even when you were sending HTML mail and you saw blue lines, text mail recipients would have seen the quote symbols.
posted by grouse at 1:52 PM on November 7, 2007

Response by poster: Thanks guys.

*downloads Incredimail*
posted by essexjan at 1:56 PM on November 7, 2007

I'm using Thunderbird, with plain text, and I get a blue bar to the left of quoted content (instead of seeing the '> ' before each line) -- at least when I'm just reading messages. I don't know what setting does this, though -- it just started happening by when I upgraded a while ago. I'm now using version

I made a quick pass at researching this via Google, but only found a reference to some setting having to do with "text=flow" - not a definitive answer. Maybe someone else knows how to turn this on and off?
posted by amtho at 2:12 PM on November 7, 2007

Hm. Weird. I just composed an email with your settings (Body Text/Variable Width/HTML with a Verdana font), and hitting enter twice made for normal-looking paragraphs. Nothing was run together.

And forwarding never results in >s, whether I am in HTML or plain text mode.

Sounds like your Thunderbird is a bit out of sorts. Do you have an old version or something?
posted by zsazsa at 3:10 PM on November 7, 2007

Response by poster: zsazsa, it always looked just fine when composing. It was only after it was sent that it looked like crap. I only saw this if people quoted my replies, or if I sent myself something to the office.

I must've got the forwarding thing wrong, I had a long, long day yesterday. Reply in plain text gives me >s, which are vile, but if I need to quote a reply in detail, I'll just have to copy & paste it instead.
posted by essexjan at 10:53 PM on November 7, 2007

It looks like with default options you shouldn't be seeing the >'s, except while actually composing your reply. Check your sent mail folder - do you see the blue bar or >'s?

Tweaking the quoting style is not very well supported in the UI. You can read through 8 pages of forum posts here if you feel like it.

Thankfully, there is an extension that may help you set things up the way you like.
posted by the number 17 at 1:30 AM on November 8, 2007

Well you can not auto-quote when replying at all, that way you won't have chevrons (or anything)--because you'll have no text.

Or you can use Nested Quote Remover to keep it down to only one layer of chevrons, by automagically removing anything that's been quoted more than once.
posted by anaelith at 1:52 AM on November 8, 2007

the number 17: I saw that earlier. It won't help as it is only for viewing mail, and relies on Thunderbird's own quoting recognition.

essexjan: Even when you were seeing blue bars, the >s were always seen by some recipients. I just double-checked this. You can send me some HTML mail if you want a screenshot. So you've probably been sending the >s since you started using Thunderbird without knowing it.

I wouldn't worry about it too much—it has been the standard way of quoting in Internet e-mail for decades. But unless there's another extension, you'll have to make do or switch to another mailer.
posted by grouse at 1:56 AM on November 8, 2007

Best answer: This was really annoying me too, and when looking for an answer, I found this page. The comments here don't seem to address the actual question asked. When looking at my emails, the newlines were not consistently stripped so I tried sending several test emails. It looks as though the newlines are stripped when they are preceded by content and whitespace (check out the link). So to make your emails formatted correctly, make sure your newlines are not preceded by any whitespace.
posted by treetop at 10:27 AM on May 16, 2008

After a little more reading, here is the specification explaining what his happening:

So, I think what you're seeing is your newlines turned to "flowed" lines, as a result of having spaces at the end of your paragraph. Eudora and Apple Mail both strip trailing white-space from the end of paragraphs; thunderbird does not. Is this a bug? I don't know.
posted by treetop at 7:32 AM on May 19, 2008

Response by poster: Thanks treetop. Yes, as a touch-typist I put two spaces after a period before hitting return. Can I ever stop doing that? I don't know, but at least now I know the answer.
posted by essexjan at 3:33 AM on May 31, 2008

« Older Question on converting numbers into formatted text...   |   Get Me Drunk In Iowa Newer »
This thread is closed to new comments.