Audio help...
August 2, 2007 12:12 PM   Subscribe

So I procured an HD copy of "300" in 720p matroska (.mkv) format, but the 5.1 audio track won't play on my 2.1 speakers. Is there any way I can configure VLC or another media player to convert the audio to 2.1 format?

Any help would be much appreciated. Just FYI I'm using an integrated 2.1 soundcard, which is what is causing the trouble. Thanks!
posted by Aanidaani to Computers & Internet (9 answers total)
If you are using windows, AC3Filter will do this for you.
posted by jtfowl0 at 12:14 PM on August 2, 2007

Take it one step further and just get the k-lite codec pack (google it). You shouldn't have to download codecs ever again. It also includes nifty applets like the g-spot codec info appliance and ac3-filter.
posted by ijoyner at 12:28 PM on August 2, 2007

Can you choose stereo in VLC? (Audio -> Audio Device -> Stereo)?
posted by null terminated at 12:33 PM on August 2, 2007

Response by poster: I have AC3 Filter installed, but I don't know how to configure Media Player Classic to use it. I just can't get any audio.
posted by Aanidaani at 2:23 PM on August 2, 2007

Did you tell AC3Filter to output to stereo mode? You can get to the configuration from the program group added to the start menu when you installed the program. Muck around with the settings until you figure it out.

Media player should use it automatically without you having to configure it. When you open the movie, watch for the AC3Filter icon to appear in your system tray (assuming you have it set to do so from the "system" tab of the config menu mentioned above).
posted by jtfowl0 at 3:45 PM on August 2, 2007

Exactly what Null Terminated said. This works also on dvd's that have only 5.1 options.
posted by starscream at 4:02 PM on August 2, 2007

Do you get the option to force it when you choose Audio from the main interface?
posted by Solomon at 4:41 PM on August 2, 2007

In MPC, go to Options.
In the Audio Switcher pane, enable the built-in audio switcher. Map back-left and back-right to front-left and front-right respectively.

Alternatively, while the video is opened, right click and look at the contents of the filters submenu. Choose whatever filter is acting as the audio decoder. When the properties window opens, find the option to down-mix. If it's ffdshow audio, it's in the Mixer pane.
posted by tksh at 6:11 PM on August 2, 2007

I had this same issue, I just told VLC to switch to stereo every time. Then I discovered that if you go to Control Panel > Sounds and Audio Devices > Speaker Settings > Advanced and set your speaker setup to Desktop Stereo Speakers, every program will always default to stereo.
posted by exhilaration at 2:01 PM on August 5, 2007

« Older Where to find circular graphic/image?   |   Is there a headlamp with switches how I want them? Newer »
This thread is closed to new comments.