XP won't let me change (or give) Guest account a password.
July 1, 2007 3:51 PM   Subscribe

Why the hell won't Windows XP Sp2 let me change (or even give me an option field anywhere) to alter the password for the Guest account? I'm the administrator, dammit!

And yeah, it's enabled (the guest account). I cannot see anything anywhere, Computer Management, User Accounts, you name it. I gotta be missing SOMEthing....
posted by bitterkitten to Computers & Internet (4 answers total) 1 user marked this as a favorite
 
Does this change it?

Start->Run->type ‘command’

type: net user Guest NEWPASSWORD
posted by mattdini at 3:54 PM on July 1, 2007


Microsoft believes whole idea of the Guest account is that no password should be required. You have two options if you want a password-protected Guest account:

(1) EASY: You create a new one called something like "PC Guest" and protect it that way.

(2) MODERATE: Start > Run > compmgmt.msc
- Expand Local Users and Groups
- Click the Users folder
- Right-click Guest, then Set Password
- Click Proceed
- Enter password and confirm
posted by fusinski at 3:56 PM on July 1, 2007


By definition, the Guest account in XP doesn't have a password -- just as a houseguest is unlikely to have a key to your house. You can enable it or disable it, but passwords aren't really intended for guest accounts (on preview, even if you set it up the way fusiniski says).

If you want the functionality of a guest account with a password, you can disable the guest account, then set up a Limited User account with a password. More info here.
posted by I EAT TAPAS at 3:58 PM on July 1, 2007 [2 favorites]


The Guest account also can't establish dialup connections, which makes it a total PITA for actual guests if you have dialup. Just make an ordinary limited account called Visitors and use that instead.
posted by flabdablet at 5:57 PM on July 1, 2007


« Older What is this strange object attached to my...   |   How do I get rid of these blankety-blank tabs? Newer »
This thread is closed to new comments.