Streaming sound should stream seamlessly
December 17, 2006 5:13 AM   Subscribe

OS X, Netgear DG834G, "Network stalled" message in iTunes is getting rather annoying!

First the basic setup: I've got two several Macs all sharing a Netgear FG384G wireless router.

Downstairs in my lounge there are two iMacs. Upstairs in my back bedroom there is an iBook with Apple Pro speakers. It streams sound via iTunes 7.02 from one of the iMacs in the lounge.

Intermittently music will pause and I"ll get the message "Network stalled" with a progress bar that refreshes while the iBook pulls down more of the track.

The problem comes and goes, and it's getting annoying.

Further details: downstairs in my lounge I've got two iMacs, one an iMac DV+ (G3, 450Mhz) and the other a flat panel 1.83Ghz Intel Core 2 Duo iMac.

Regardless of which Mac is used, I get the problem intermittently. I've also experimented with my G4 PowerBooks (1.25Ghz and 1.5Ghz), same problem. The iBook currently being used is a 466Mhz G3 running 10.4.6. I've got a second G3 iBook, 300 Mhz, and it exhibits the same behaviour if I try to stream sound from it.

I've had this problem for a while; the iTunes update is recent.

I'm stumped why this would happen. There is very little traffic on the internal LAN. I haven't run a tool to verify, but the boxes are just sitting there. The G3 iMac pings two remote boxes that I own, and is running little else (iCal to kick off some scripts but they aren't running when this problem happens, and the G3 iMac isn't streaming sound).

The MacIntel is doing pretty much nothing sometimes when the problem rears it's head.

I've experimented with one of my PowerBooks and even if in the same room as the iBook, when the problem is happening it happens.

I've checked the router logs to see if there was perhaps a DOS from the WAN side that might be overwhelming it, and preventing it from forwarding packets on the internal 'Net and found nothing.

On the iBook I've tried quitting iTunes, logging out and rebooting - nope. When the problem happens, it happens.

No matter what machine I'm streaming from when it happens it happens.

I've been in this flat five years, and when I first moved in there were no other access points about. Now there are at least three that I can see and maybe more that are running silent (I know about Kismet but haven't tried this yet).

I have had interference in the past, which I solved by configuring the router to use a specific channel instead of 'auto'. Before that I'd sit in the lounge and sometimes watch the signal strength swing from five bars to zero and back to five.

I had the streaming audio problem back then, but now even though the signal is consistently stable and five bars across the flat (and into my garden - whoot!), I still, from time to time, have problems streaming sound in my upstairs bedroom.

Any suggestions? I've got 23GB of sound, so dumping a copy on the iBook isn't an option.
posted by Mutant to Computers & Internet (2 answers total)
 
You have a lot of computers on one low-grade router which might or might not be dealing with attacks, leechers, and interference.

Some things to try to narrow down the problem:

1) What happens if you have only two computers on the network (the one serving the stream and the one receiving the stream), and the others put to sleep?
2) Do you have filesharing running on any of your computers? If so, turn it off. By 'any' I mean any in the house. Not only the ones you use iTunes on
3) Do you have any Macs using an 802.11b (Airport) card rather than an 802.11g (Airport Extreme) card? If so, put that Mac to sleep and see if sharing over wireless improves. An 802.11b unit can potentially downgrade everybody's connection to the slower (11mbps) speed.
4) What happens if the server and client computers are both connected by ethernet cable?
5) Do you have buggy or old versions of iTunes on any of the participating computers?
6) See if Apple has any docs regarding sharing music over iTunes. Here's a starting point.
posted by ardgedee at 7:48 AM on December 17, 2006


Yeh, interesting points - only three Macs or so at a time are on. Unfortunately I can't disable 802.11b as the G3 iBook uses it. But all machines did have Personal file, Windows File and Web sharing enabled - thanks for pointing that out. I've disabled and I'll see if the problem rears it's head again.

Thanks
posted by Mutant at 11:09 PM on December 17, 2006


« Older Lost my keys at Ikea   |   "Louisiana SOS" Shirt? Newer »
This thread is closed to new comments.