Help me fix my "limited connectivity" in Windows Vista RC2
October 26, 2006 12:39 PM   Subscribe

EarlyAdopterFilter: After several happy months of running Windows Vista RC1, I've upgraded to RC2. Ever since that day, I've been intermittently getting a "Limited connectivity" error that requires my network adapter to be reset. I don't want to go back to XP or RC1, so I need to make this work.

My specs: a Pentium D on an Intel board with integrated PRO/1000 PM network adapter. Linksys WRT54G v4 router, connected over wire.

The problem seems to be worst when the connection is consuming a lot of bandwidth (particularly when using uTorrent).

So far, I've tried a few things (based on extensive research):

1. Reinstalled the network card drivers
2. Changed the advanced settings to turn IPv4 and IPv6 checksums off
3. Disabled SPI firewall on the router.
4. Installed the DD-WRT firmware (v23SP2) on my router.
5. Decreased the number of allowable half-open connections in uTorrent to 2.
6. Unchecked the IPv6 protocol in my network settings.
7. Switched from using the router's DHCP to a static IP on my machine.

After all of these things, I still have intermittent connection drops where the lovely yellow triangle with an exclamation mark in it proclaims that I have limited connectivity. It seems to me to be more like *zero* connectivity, as I can't usually even reach my router once this happens.

Based on all the research I've done, I really feel like Vista's relationship with my router (specifically after the installation of RC2) is the area of trouble. I've considered going back to RC1, or XP, but I would like to resolve this issue if at all possible.

Thanks in advance for preventing me from having to reinstall my OS! ;)
posted by superboy422 to Computers & Internet (5 answers total) 1 user marked this as a favorite
 
Cross-post to Neowin. (not a call-out or anything)
posted by aye at 12:56 PM on October 26, 2006


You might try disabling the service called Wireless zero configuration. Click on Run, enter Services.msc, go to the bottom of the list and click on WZC select stop.
posted by ptm at 2:25 PM on October 26, 2006


ptm, thanks for that. However, I don't have a wireless adapter in this machine. Any ideas for a wired solution?
posted by superboy422 at 3:27 PM on October 26, 2006


You could try running the following command from a cmd prompt. (Make sure you launch the cmd window using the "run as administrator" option and reboot afterwards):

netsh int tcp set global autotuninglevel=disabled

I know that fixes some problems in Vista with particular routers.
posted by llamateur at 8:12 PM on October 26, 2006


What kind of errors are you seeing in the event log?
posted by Dunwitty at 4:12 AM on October 27, 2006


« Older Dodgeball gear in Boston, Help Please!   |   In search of good religious discussion Newer »
This thread is closed to new comments.