It's not spam, I promise
May 9, 2023 7:14 AM   Subscribe

Every time someone buys something through my website, I get an email confirmation. It goes into my spam folder. I don't want that to happen. Help.

The sender is [my store email address] via (my website host). I use POP3 to check that address through my gmail account. The following steps occur: (a) This email goes into my spam folder. (b) I open it. (c) I report it as not spam. (d) It then goes into my inbox with both "inbox" and "store" labels (store being a label I created for emails that come to/from that address. (e) I deselect the inbox label. (f) It's in the folder where I want it. I would like to eliminate steps a through e. How do I convince Gmail that these emails are not spam?
posted by goatdog to Computers & Internet (11 answers total)
Best answer: Make a rule to never send emails from that email to spam.
posted by noloveforned at 7:18 AM on May 9, 2023 [3 favorites]

Response by poster: Ooh, thank you. I just tried it. We'll see if it works on the next email.
posted by goatdog at 7:50 AM on May 9, 2023

You can do all of that with a filter.
  1. Go to your "store" folder, and use the checkbox to select an email.
  2. Click on the three-dot button at the right of the toolbar at the top of the page, and select "Filter messages like these".
  3. A filter form will open, hopefully with the "From" field pre-populated to the email address in question. If not, put the value in the field (and delete whatever other field got populated instead).
  4. Click "Create filter" at the bottom of the form.
  5. Now you should be looking at a form that starts "When a message is an exact match for your search criteria:". Check the boxes for:
    • Skip the Inbox (Archive it)
    • Apply the label (and choose the label "store")
    • Never send it to Spam, and
    • Also apply filter to [N] matching conversations. (Just in case you've missed any.)

  6. Click "Create filter" again, and you're done.

posted by ManyLeggedCreature at 7:58 AM on May 9, 2023 [1 favorite]

It's possible, if the "From:" address has your store's domain name, that it's going to Junk because it's failing some kind of authentication. If you open one and click on the three-dot 'More' menu on the right (next to 'Reply' and 'Star'), you'll get a "Show original" option. Clicking on that will open a new page with the raw email displayed and, at the top, the results of various authentication methods - SPF, DKIM, and DMARC. Are they all "PASS"?
posted by hanov3r at 7:59 AM on May 9, 2023

I'd recommend, as hanov3r suggests, looking into the *reason* that the emails are going to spam, as opposed to just creating a filter. The reason for this is that if, say, the emails are going to spam is because your SPF/DKIM/etc are messed up - you may find that your emails to customers are going into their spam folders, and you don't want that.
posted by ManInSuit at 8:17 AM on May 9, 2023

Response by poster: Yes, noloveforned (and MannyLeggedCreature) were right. I just needed to add "never send to spam" to the filter I already had set up.
posted by goatdog at 8:55 AM on May 9, 2023

Response by poster: Oh, hm. When I do what hanov3r suggested, I get SPF results but not DKIM or DMARC.

spf=pass ( found no external ips, assuming domain of [server] as permitted sender) smtp.mailfrom=[server]
Received-SPF: pass ( found no external ips, assuming domain of [server] as permitted sender)

Is the lack of DKIM and DMARC causing an issue?
posted by goatdog at 8:58 AM on May 9, 2023

>Is the lack of DKIM and DMARC causing an issue?

"Failure of" would matter more than "lack of", honestly. ManInSuit has a point, though - you might want to check to see if mail to your customers is going to their Junk folder (maybe do a transaction through your store using another email address of yours and make sure the receipt's going to the Inbox).
posted by hanov3r at 4:33 PM on May 9, 2023

Response by poster: I have noticed that emails I send through the store address tend to end up in spam filters more often than seems normal. How do I fix it?
posted by goatdog at 5:28 PM on May 9, 2023

Google has become extremely, extremely strict about hosts originating email without DKIM, even if you have SPF. Even when my recipients move the message out of spam multiple times, even when I'm replying to an email they sent me, my delivery for even personal messages is very poor. The cynic in me says Google wants to force everyone to use Gmail, possibly they are just overwhelmed by the quantity of spam.
posted by wnissen at 11:41 AM on May 10, 2023

Response by poster: Ugh. So I went to cpanel on my host to look into enabling DKIM, and it says it's already enabled. But it's not showing up on emails sent from my account.
posted by goatdog at 12:30 PM on May 10, 2023

« Older Celebrating college grad without the ceremony-what...   |   Should I try to move our "porch cat" with us? Newer »
This thread is closed to new comments.