Hijacked by Microsoft
March 20, 2006 5:28 AM   Subscribe

Microsoft continues to hijack my computer. Every time I get a new Windows update, it changes my default email client from Outlook Express to Outlook (I prefer OE) and my browser from Firefox to IE.

It's really a pain to have to go into my default settings every time I get an update to undo what Microsoft does. It seems like it should be illegal to just take over my settings like this. How do I make it stop doing this?
posted by Mrs. Smith to Computers & Internet (11 answers total)
 
For the record, this isn't actually standard operating procedure, to the best of my knowledge. I update as frequently as anyone, and it never touches my default browser or email client settings.

Are you running Service Pack 2? Have you considered "upgrading" to "Microsoft Update" (which differs from Windows Update) and is this problem occuring through the in-built system updater, or from when you manually visit Windows Update through IE?
posted by disillusioned at 5:55 AM on March 20, 2006


I guess I should have been more clear. It happens with the automatic updates (generally on Tuesday nights)...not when visiting the website. I am running Windows XP, SP2.
posted by Mrs. Smith at 6:03 AM on March 20, 2006


Have you considered un-installing Outlook?
posted by snickerdoodle at 6:19 AM on March 20, 2006


Yes, but I was hoping to solve the issue without uninstalling it. It may come down to that, though.

However, I don't think this will solve the Firefox/IE issue.
posted by Mrs. Smith at 6:22 AM on March 20, 2006


I call shenanigans. Windows just doesn't do this.

I'll do my bit to help, though: Start Menu -> All Programs -> Set Program Access and Defaults. Set your defaults there, and see what happens.
posted by Merdryn at 7:54 AM on March 20, 2006


Merdryn,

That's how I change it every time, after the updates take over.

I've run all the anti-virus & anti-spyware programs and I'm clean.

It really, really is happening as I described.
posted by Mrs. Smith at 10:07 AM on March 20, 2006


Do you have a branded PC, ie Dell/Gateway/etc? If so, it may be one of their auto-support tools that is 'fixing' this for you each time. I had to turn off the Sony Viao's special tools to prevent similar issues on one of my pc's.
posted by nomisxid at 10:24 AM on March 20, 2006


It's a Dell, but it just started doing this recently--since after installing SP2, but not necessarily right after the installation.

My computer is about 3 years old, if that means anything.
posted by Mrs. Smith at 10:37 AM on March 20, 2006


The DOJ would have its foot up MS' hind-end faster than you can say "antitrust" if Windows were doing this on purpose. I know, it's quick and easy to say that Microsoft is evil, but MS just wouldn't even try to get away with something like this, really.

My guess is that it's some other program (Dell has auto-support programs pre-installed on their machines, as nomisxid mentioned). Or, some form of malware.

Are you running Spybot Search and Destroy or Ad Aware for anti-spyware? Other applications may in fact be spyware disguised as anti-spyware tools (there are quite a few of those around).
posted by Merdryn at 12:10 PM on March 20, 2006


I routinely remove the Outlook Express icon from my start menu. It used to come back after I did Windows updates. Hasn't happened lately.

There are likely to be registry settings you can copy and save to make re-applying your preferences easier. What OS?
posted by theora55 at 2:42 PM on March 20, 2006


Merdryn--I am running Norton AV, Spybot S&D, and MS beta AV program. I also run Ad Aware every couple of weeks. The problem has been happening for a couple of months.

theora55--I'm running Win XP, SP2. I don't know much about hacking the registry.
posted by Mrs. Smith at 12:39 PM on March 21, 2006


« Older iBook trouble   |   Thoughts on wood-inlay wedding rings? Newer »
This thread is closed to new comments.