TextEdit makes my computer squeak.
February 26, 2006 2:39 PM   Subscribe

When I type in TextEdit, my PowerBook (15", 10.4.5) emits a high-pitched squeak with every entered character or press of the delete key. WTF?

It only happens in TextEdit. The sound seems to be coming from underneath the keyboard -- in any case, it's definitely not coming from the speaker, because it still happens with the sound plugged in (or with external speakers hooked up). Has anyone heard of this before? I tried Google, but I'm honestly not even sure what to search for.
posted by danb to Computers & Internet (8 answers total)
My Powerbook (15", G4, 10.4.5) does this occasionally. I haven't paid attention to see if it's only in TextEdit but it very well could be.. I just checked now, but the keys aren't squeaking at the moment. Anyway, I have no idea what the issue is, but you're not the only one with the problem.
posted by hopeless romantique at 2:55 PM on February 26, 2006

Best answer: Hmm....looks like you're not the only one with this problem. Unfortunately, I do not know of any solution, I just wanted to post the link.
posted by invisible ink at 3:09 PM on February 26, 2006

Mine does exactly the same thing - but only sometimes.

It doesn't seem to cause any problems.
posted by Mwongozi at 3:36 PM on February 26, 2006

imho lots of different apple machines suffer from similar problems. it is probably a combination of the cpu power supply circuitry and the power-saving features in the cpu.

what happens is that the cpu requires a much lower voltage than most of the other components in the system, so there are small regulators to create the low voltage for the cpu. if the processor is in full-on power saving mode, when its not doing anything, it has shut down different sections of the chip. when you push a key, an interrupt is generated which results in a whole lot of code being executed. the cpu suddenly wakes up, which causes it to suddenly require a whole lot more power.

the most efficient DC-DC regulators are called "switching" regulators, since they employ a low-frequency oscillator as part of the power supply circuit. normally these switching frequencies, while low, are near the human range of hearing. a good switching supply should not have a frequency directly in the human range of hearing (20-20000Hz) but even if they use higher frequencies, there can be harmonics which are still audible.

now the weird part. components that deal with magnetic fields (well, all do as a necessity of physics, but i'm talking about inductors and transformers here) can actually create audible noise directly, from the currents flowing in the core material.

alternatively, these electric currents can couple into the audio system and cause the speakers to make noise, even if you have the volume turned all the way down.

my G5 tower chirps when idle, once a second, as some process wakes it up over and over again. the only way to get rid of it was to change the energy saver setting from "automatic" to "highest", which is a shame, because otherwise on automatic the machine really burns a whole lot less power. also the fan behavior is a whole lot more consistent and less annoying on "highest".

the G5 processors have something called "nap" mode. turning this off helped. i dont know if the G4 has something similar, but you can try downloading apple's CHUD tools and see what the processor settings application will let you do.

the "sometimes" behavior on powerbooks probably has to do with whether or not its plugged into AC or not. by default i think the AC profile has the performance set to "maximum", which, if i'm right, will fix this problem..
posted by joeblough at 3:47 PM on February 26, 2006

I've had this happen from time to time, and usually in situations with high CPU utilization such as WYSIWYG forms on Web sites (intense JavaScript, etc).

To guarantee a way to recreate the effect, run VNCViewer and connect to a VNC server. You'll have the same noise permanently (not just per keypress). I think I figured the noise is coming from somewhere around the 5-6-7-T-Y keys. However, looking at this area on a picture of a disabled PowerBook I can't see anything there.

Combine this with the new Powerbook's "sound echoing" problem, I hope this is pretty much it for defects, as I can just about put up with em.
posted by wackybrit at 3:53 PM on February 26, 2006

Oh, it seems they fixed the sound defect but not this cheeping one. There's hope!
posted by wackybrit at 3:55 PM on February 26, 2006

My Dual 2GHz G5 PowerMac had the same problem. I downloaded CHUD tools and disabled napping, and all was well again. There are AppleScripts floating around out there that disable it automatically at startup.

The RSS screensaver, iirc, is a great way to demonstrate it (if you have Tiger). Otherwise, Marcel Bresink's SystemLoad does a great job of playing a C-Major scale on your CPU, in true Mac user style.
posted by armoured-ant at 4:55 PM on February 26, 2006

Best answer: invisibleink's thread had the answer. I recently changed my Processor Performance to "Highest" for some reason. Switching it back to "Automatic" did the trick.

Thanks, everyone.
posted by danb at 6:07 PM on February 26, 2006

« Older Where can I find a partner for my business?   |   Are Nalgene water bottles really unsafe? Newer »
This thread is closed to new comments.