Join 3,553 readers in helping fund MetaFilter (Hide)


Why does Metafilter hate my Macs?
July 14, 2007 7:17 PM   Subscribe

Why can I reach Metafilter from my PCs, but not my Macs?

I've had this problem since April 1st, but haven't had the time to put any effort into troubleshooting it. Prior to around April 1st, everything worked without issue. This is a pretty consistent problem, and the only website affected, to my knowledge, is Metafilter.

I'm using an Airport Express behind a Netgear router, connected to a DSL modem, on the AT&T network. I can reach it from any of the PCs I've tried, including from within Parallels (which is where I'm posting this from), but none of the Macs I've tried can get through. To be more specific, Firefox and Safari both attempt connection for several minutes (right now I'm at 15 min. and counting), but never resolve an actual page. I can get through on the Mac if I use a proxy server (such as anonymouse.org).

Affected computers include my old G4 titanium powerbook that was 5 years old, an aluminum G4 powerbook, and a brand new, latest MacBook Pro, straight out of the box!

WTF?
posted by danny the boy to Computers & Internet (14 answers total) 4 users marked this as a favorite
 
Any response from pinging metafilter.com?
posted by rancidchickn at 7:39 PM on July 14, 2007


I had this problem with my Macs too. You need to change the MTU on your router. Read this thread for more information.
posted by rocketman at 7:41 PM on July 14, 2007


Someone asked a similar question a couple of months back. Perhaps some of the suggestions offered might be helpful to you.
posted by HotPatatta at 8:42 PM on July 14, 2007


Rocketman:

I tend to agree with the next to the last comment in that thread. I'm not sure that I want to be mucking about with my router settings when I can reach pretty much every other site on the internet...

There are a couple of solutions implied in that thread. Which solved the problem for you? Changing the MTU to 1500?
posted by danny the boy at 9:08 PM on July 14, 2007


And I just checked the firmware on my router. It's current. :/ I guess I can either get a new router, change the MTU settings (which I am hesitant to do), or launch parallels every time I want to browse mefi.

It kind of annoys me that Matt knew about this, knew that people were getting shut out (I've basically stopped reading metafilter the last 3.5 months), but decided that was fine.
posted by danny the boy at 9:24 PM on July 14, 2007


Yes, mucking around with your router settings shouldn't be necessary, because the real problem is at metafilter's end: a firewall somewhere is overzealously blocking ICMP fragmentation-needed packets. But until that is fixed, reducing the MTU at your end is the only way to make things work.

This problem is actually quite widespread, but something about the route to metafilter means that the reduced MTU set automatically by most ADSL routers — 1492 bytes — is still too large.
posted by narge at 9:49 PM on July 14, 2007


I have the same problem too.
posted by slightlybewildered at 1:04 AM on July 15, 2007


Don't be afraid to change this on your router, you aren't going to break anything. MTU is something that can vary all over the place; it's built to be changed by design. You can always change it back.
posted by TravellingDen at 7:08 AM on July 15, 2007


I had this same problem recently, but for elbo.ws/vanilla ... I found a few different potential solutions for it, though none of them worked for me (they might for you).

... and technically, shouldn't this be in metatalk?
posted by Tuwa at 7:18 AM on July 15, 2007


I am a Mac user. I had massive problems with the Netgear brand name; after struggling with a router over nine months, it made a very nice arc through the air into the dumpster, and first a Linksys and then an Apple Airport Express have given me nowhere near as much trouble. Just wanted to offer that feedback, although if you're happy with your Netgear, please feel free to ignore me. :)
posted by WCityMike at 11:21 AM on July 15, 2007


It kind of annoys me that Matt knew about this, knew that people were getting shut out (I've basically stopped reading metafilter the last 3.5 months), but decided that was fine.

Jesus, you act as if you have some sort of knowledge that Matt decided to forsake you... rather than there being some hop on the route between you and the Metafilter server that's causing the problem. I can assure you that that's the case, though -- since I, a few thousand others, and Matt himself have no problem getting here via our Macs.

Change the MTU setting on your router to fix it -- or don't, and continue to not be able to get to MeFi on your Macs. It's pretty much your call, not Matt's.
posted by delfuego at 5:00 PM on July 16, 2007


Update your netgear router to the latest firmware. If that doesn't do it, mess with the MTU settings. There's a firewall somewhere at my ISP that is blocking some macs on some routers, and often it's out-of-date firmware or a MTU setting.
posted by mathowie at 5:04 PM on July 16, 2007


I changed my MTU settings from 1492 down to 1450, and suddenly Metafilter reappeared. It took me all of ten seconds to do it - a minor inconvenience, at most.
posted by rocketman at 8:42 AM on July 17, 2007


Jesus, you act as if you have some sort of knowledge that Matt decided to forsake you...

Well. Yes. From all the threads that I read while researching this issue, it seemed like the consensus was that the problem was very likely on mefi's ISP's end (and looks like Matt just confirmed that), and I also read that Matt was personally aware that people were still having problems. Hey, I recognize that this particular issue probably only affects like maybe 1% of all users, and I accept that it's logical to decide that it's not worth the effort for such a small number of users. But it is what it is (a decision), so yes, I did feel FORESAKEN.

You're right, it is now up to me if I want to get a new router or fiddle with the settings on my current one, the latter filling me with a lot more cognitive discomfort than it really should ("inelegant" is such a perfect word for it).

Whatevs. Life goes on.
posted by danny the boy at 4:43 PM on July 17, 2007


« Older A few weeks ago, I asked MeFit...   |  Can I purchase CDs at wholesal... Newer »
This thread is closed to new comments.