When I email myself, iMessage converts the email to text--how to stop???
May 31, 2016 10:18 AM   Subscribe

I sometimes send reminders and to-do items from my phone to my gmail account. To do this, I send texts from my phone's text app (currently iMessage) to my gmail address. This system has worked fine for years. But ever since I entered/updated my Apple ID in my phone's System Preferences a day ago, all my reminder emails have been converted into texts. (It happens that my gmail account is also my Apple ID.) Each email is converted to an iMessage and shows up within the iMessage app ONLY, so I have a long -running iMessage conversation consisting of nothing but texts to myself. This is useless. Help??

I feel like I am locked in some kind of Apple sandbox, where Apple is trying to box me into using the iMessage client because it associates my gmail account and my iMessage account. When I log out of iMessage and try to email myself, I get a notice saying that I can't send an email to my gmail address until I log back into iMessage! This is in spite of the fact that I can send emails to my other accounts, to other users, etc., using iMessage without trouble.

This is a minor problem but I'm sadly reliant on this little system of text-to-email reminders, so I feel totally paralyzed. I've tried turning off every setting I can find, and I've spent about half an hour looking for fixes online, but so far without luck. Some people seem to have the opposite problem--texts becoming emails--but even those threads didn't turn up a solution for me.

Any help or suggestions would be greatly appreciated! Thanks in advance.
posted by lotf629 to Technology (7 answers total) 1 user marked this as a favorite
 
Hopefully someone can fix your exact problem but I came here to recommend an awesome app I use for the same purpose, called Captio. You set it up with a single email address and with one click, anything you post into the app will be emailed to you. You can even share links and stuff to Captio from other apps like Facebook and Safari.
posted by Brittanie at 10:41 AM on May 31, 2016 [1 favorite]


Can you change your Apple ID to something other than this gmail account and see if that fixes the problem?

If you aren't able to find a way to fix this, your best option might just be designating one of your other email accounts as the destination for these text to email reminders since it sounds like the only problem is with this particular gmail account.
posted by litera scripta manet at 10:43 AM on May 31, 2016


iMessage works by intercepting the email / phone number you're texting to and checking if it's attached to an iMessage account. Your email address is associated with iMessage, so your phone is dutifully trying to iMessage it.

If I was you I'd simply try adding a + to the end of the address you're texting, e.g. yourself+reminder@gmail.com. This will also make it easier to find these messages to yourself later (GMail can direct them to another inbox or whatever, if you want).

I just tried this on my own iPhone and it seems to work. foo@gmail goes to iMessage, foo+bar@gmail goes to text message.
posted by neckro23 at 11:04 AM on May 31, 2016


An alternate, equivalent solution would be to make a separate gmail account for this purpose, and have it forward to your normal account.
posted by kickingtheground at 11:25 AM on May 31, 2016


You can disable what addresses you receive facetime/imessages at (and also initiate conversations FROM). Probably, during a recent reinstall/update of an OS, or a new device, this was enabled semi-automatically.

On the iPhone, go to 'settings', then 'messages', then 'send & receive' and uncheck the gmail account, and/or any other ones that you want to act like actual email addresses and nothing more. Edit: you may have to do this with facetime, as well as other devices/Macs as well.
posted by destructive cactus at 12:01 PM on May 31, 2016


Yes 1) turn off that email as a send and receive email under messages in settings
2) another solution would just be to email yourself without using messages at all but the Mail app. On the iOS mail app if you don't put in a sender it automatically sends it to yourself if the TO field is blank. I do this all the time with quick reminders.
posted by Crystalinne at 12:41 PM on May 31, 2016


Thank you, all! Neckro23, that works beautifully, with a minimum of hassle (and also taught me something new about gmail addresses). Thanks to everybody else too!
posted by lotf629 at 10:56 AM on June 1, 2016


« Older After Bangkok, Chiang Mai or beaches?   |   Penalties to re-file tax forms? Newer »
This thread is closed to new comments.