I do not have any voicemails, Android. SERIOUSLY.
April 20, 2016 8:38 AM   Subscribe

I have a Nexus 5 running Android 6.01. I have a notification that will not clear that says I have 5 voicemails. I have zero voicemails. The internet is positively lousy with advice on how to fix this. Not a drop of it works. HALP.
posted by DirtyOldTown to Technology (12 answers total)
 
Did you try calling yourself and leaving a voicemail, and then calling back to clear it?
posted by jozxyqk at 8:47 AM on April 20, 2016 [2 favorites]


That cleared the icon... for now. I'm about hip deep in techniques that have cleared it temporarily. So far, it always comes back. Here's hoping.
posted by DirtyOldTown at 8:51 AM on April 20, 2016


I'm gonna go ahead and state the obvious possible solution that is sometimes so obvious I forget to try it myself.

Turn your device off/shut down and then turn back on.
posted by ZabeLeeZoo at 10:10 AM on April 20, 2016 [2 favorites]


I don't think it has anything to do with the device, and everything to do with the carrier actually having an erroneous "active voicemail flag" on the line.

I just hope DirtyOldTown returns to this question in.. say.. 24 hours or so to report back :)
posted by jozxyqk at 10:22 AM on April 20, 2016


There is an app called Snowball that can hide persistent notifications. But that won't help if you want to see voicemail notifications under other circumstances.
posted by hungrytiger at 10:23 AM on April 20, 2016


I used to get that problem a lot on my HTC One. I was never able to solve it, it always just went away on its own when it felt like it. It happened again yesterday.

I was poking around my device's settings for an unrelated issue and I noticed an entry that I swear was not there before the Android 6.0 "upgrade." I'm not sure if it's device-specific, but I went into Settings, tapped the Call heading, and in the Call settings there's a section called Voicemail. Below that is an option "Clear voicemail notification."

Like I said, I'm not sure if that's an Adroid OS setting or a device-specific setting but it looks like it exists for no other reason than to solve this particular problem.
posted by under_petticoat_rule at 10:56 AM on April 20, 2016 [1 favorite]


The 5 voicemails notification came back.

I have tried resetting before. No dice.

The thing u_p_r recommended must be phone specific. I don't have that option.
posted by DirtyOldTown at 3:59 PM on April 20, 2016


Huh. Who's your carrier? Have you tried contacting them?
Do you have the ability to swap your SIM into a different phone to see if the VMs register there?

I still suspect it's a bug on the carrier side and not the hardware.
The way I understand it, the "voice mail indicator" shows up because of a magic signal being sent to you.
posted by jozxyqk at 5:04 AM on April 21, 2016


Are you using Google Voice for your messages?

I ran into this a while back and the answer was disabling google voice for my number, calling my carrier's voicemail box, clearing the messages, and reconnecting Google Voice. No notifications several phones and Android since.
posted by notyou at 5:48 AM on April 21, 2016 [1 favorite]


Also tried clearing the data from the system app. Also worked. Also came back.

I'll try contacting Sprint.
posted by DirtyOldTown at 8:36 AM on April 22, 2016


Nope, I don't use Google Voice.
posted by DirtyOldTown at 8:45 AM on April 22, 2016


This is still happening. I called Sprint, but the support guy I got couldn't fix it. I should probably call again.

I even ended up--for unrelated reasons--getting a new phone. The issue followed me there. Still "5 voicemails."
posted by DirtyOldTown at 7:16 AM on July 1, 2016


« Older Best prenatal vitamin?   |   How to deal with anxiety about actual health... Newer »
This thread is closed to new comments.