Starbucks/Public WiFi Problem
October 26, 2015 1:14 PM   Subscribe

Lately I've been having trouble connecting to Starbucks and other public WiFi that uses an "Accept these terms and conditions" pop-up. The pop-up prompt doesn't appear and so I can't use the connection. Can anyone help?

I'll connect to the network but the prompt never pops up, so I can't actually use the connection to browse the Internet. It acts as if I'm not connected even though the Network Utility shows me as connected. The prompt won't pop-up no matter what I do: I've tried turning the WiFi off and on again, tried in Safari and Chrome, tried closing all of the browsers and opening them again, restarting the computer, etc.

I'm using a late 2010 Macbook Air running OSX Yosemite v. 10.10.2. I looked around online and found various ideas like opening the localhost or going to "purple.com" but nothing works.

Two strange things:

1. This has happened off and on again with this computer but hadn't happened in a long time until the last week or so. I used to be able to connect to these networks and get the prompt no problem. I had just used the connection at the Starbucks I tried today last week and it worked fine then. I haven't updated or installed any software since then.

2. I tried in various Starbucks, a public space WiFi, and a Pret A Manger, and the Pret prompt came up and I was able to use their connection.

Any help is appreciated!
posted by Sangermaine to Technology (13 answers total) 2 users marked this as a favorite
 
Did you ever set up DNS servers manually for your wifi connection? For a while I used google DNS to circumvent an issue with my ISP's DNS at home, and had to remember to switch to automatic DNS to make captive portals work (Google DNS would fail because my machine of course couldn't get past the captive portal to resolve the portal landing page's IP, so I was not able to accept the terms and continue; switching to automatic DNS config resolved this).
posted by Alterscape at 1:20 PM on October 26, 2015 [2 favorites]


Response by poster: No, though actually I did just buy a new modem for my home network and had to reset the router configurations. Could that have caused this?

Keep in mind my technical knowledge is pretty limited so any answers should be aimed at a layman...
posted by Sangermaine at 1:25 PM on October 26, 2015


Could it be hiding on the web browser? The last time I tried to use hotel wifi to look up directions using a phone app, I wasn't getting through despite having a signal. The web browser had the prompt.
posted by bentley at 1:44 PM on October 26, 2015 [1 favorite]


Bentley, Sangermaine said that turning browsers on and off and on again is one of the things they tried.

I have this problem too, where sometimes the prompt just takes its sweet-ass time to show up. But I've noticed this problem happen most commonly with a connection that I've used before, and my computer just tries automatically logging in. Somehow that makes it forget to go to the step where I have to accept the terms and conditions, and so my computer just thinks it's logged in and doesn't have to do anything and I'm stuck in limbo.

Sometimes it helps to pull up the "list of available networks" and erase the Starbucks/Pret/Whatever network entirely, then try logging on again as if it's the first time. That sometimes helps my computer remember "oh, yeah, I forgot that verification step".

And sometimes I just have to wait a minute or so if the network is especially slow; but that's not my problem, that's the network just being overloaded.
posted by EmpressCallipygos at 1:50 PM on October 26, 2015 [2 favorites]


Most "Captive Portal" Wi-Fi services use a proxy server to capture your request and send you a redirection URL. Usually this comes in the form of a 302 redirect and has a page where you can sign in.

This approach is getting less useful as more sites convert from http to https. Capturing secure sites is just as easy, but doing so in a way that doesn't look like something fishy is going on is getting harder and harder, so some providers won't even try. Some providers, in an attempt to get around this, mistakenly whitelist the probe pages of the client software. This results in systems that think they have open access when they do not.

If you're in a Captive Portal network, MacOS X devices (like Win10, some Android, and iOS devices) may launch a captive portal client, which is a thin browser designed to show you the splash page for the venue and then be closed. If that is disabled, or somehow won't launch, you may not get the connection page you want. The app is here: /System/Library/CoreServices/Captive\ Network\ Assistant.app/

The portal page may also be a fixed size that keeps a button on the bottom or the right from being visible. In those cases where you see the captive portal window but not a button, you probably can click and drag inside the window to see the rest of the portal page. That's an easy fix, if that's the case.

So, what the advice you're being given is trying to tell you is to try a page that you know is http (not https) to force the page to load in your browser.
posted by Mad_Carew at 1:51 PM on October 26, 2015 [5 favorites]


What Mad_Carew said, with the added caveat that you may need to disable any browser extensions/addons/plugins that enforce a policy of HTTPS Everywhere (which are good things to run in general.)
posted by Sunburnt at 1:57 PM on October 26, 2015


This could be DNS related as others have said. Try putting an ip address in and see if comes up then. http://1.1.1.1 is as good as any. It also could be a security feature of your browser if your homepage is an https page. The browser may be trying to keep a secure page request from redirecting. On preview in reference to captive portal what Mad_Carew said.
posted by white_devil at 2:19 PM on October 26, 2015


Nthing disabling extensions/clearing cache. I tend to use a separate, stripped down, browser than my standard ones to do this stuff in, since I have lots of extensions that mess with the connection.
posted by troytroy at 2:52 PM on October 26, 2015


Response by poster: Thanks for the suggestions. I haven't had a chance to try anything yet, but if these are the correct why was it working before and then suddenly stopped working?
posted by Sangermaine at 3:42 PM on October 26, 2015


I've had this problem more and more of late. One thing that seems to help is to keep those landing pages bookmarked and just go to them directly instead of waiting for the browser to get there on its own. Don't know if this actually works or it's just a placebo but it feels like it works.
posted by bfootdav at 3:50 PM on October 26, 2015


Are you running an ad blocker?
posted by rhizome at 8:41 PM on October 26, 2015


As a workaround I typically open Internet Explorer, accept the terms and conditions, then close Internet Explorer. For some reason kludgy-looking "terms and conditions" sites work well with kludgy-looking IE.
posted by sninctown at 9:42 PM on October 26, 2015 [1 favorite]


I deal with this all the time on the road. ALL THE TIME.

That it doesn't trigger MacOSX's sensing of a capture portal - or that I've ignored it and I need to get back to the portal itself.

You need to navigate in your browser to the router itself - that will trigger the interstitial capture page.

System Preferences > Network; on Wifi, press Advanced. Then press TCP/IP to get the details of your connection - the router address is what you need.

Copy the router address and paste it into a browser. This should force the landing page.

Bonus note: I had horrendous problems with this when flying/using GoGo Air. Turns out, it wasn't working because I had google servers for my DNS. I created an additional location without the google DNS and everything worked again.
posted by filmgeek at 3:43 AM on October 27, 2015


« Older "Floating" grand jeté videos   |   Gift for two year old Newer »
This thread is closed to new comments.