How Do I Stop Text Messages Occurring on My Mac?
March 13, 2015 6:31 AM   Subscribe

I recently upgraded my MacBook Air to Yosemite. Everything seems to be fine, except for the fact that my iPhones text messages now happen on my computer (I think this is the continuity feature?). Anyway, I want this to stop. Of course, I Googled it before I posted, here, but the fixes that I found, don't appear to be relevant (they were from 2014 and probably from Mavericks). For example, one fix suggested opening the Messages app on your Mac (which I did) and open the Preferences menu, which I don't see. Can anyone help me stop this?? Thanks!
posted by dbirchum to Computers & Internet (9 answers total) 2 users marked this as a favorite
 
"Preferences" is the second option under the "Messages" menu, just to the right of the apple on the upper left.
posted by Dip Flash at 6:46 AM on March 13, 2015


That's weird, I had to specifically enable the setting to get texts on my Mac. Check your settings: Launch the Settings app on your iPhone, go to Messages. Look at the Text Message Forwarding settings. If your MBA is listed, turn it off.
posted by entropicamericana at 6:50 AM on March 13, 2015


Response by poster: Weird. I have iMessage turned off on my iPhone.
posted by dbirchum at 6:52 AM on March 13, 2015 [1 favorite]


Do you want other notifications but not this one? Because I went into Notification Center (in System Preferences) and set Do Not Disturb times to be all but one minute of every day. There may be a ton of notifications that jam into that one minute, but I'm asleep generally. Here's more information on this.
posted by jessamyn at 7:05 AM on March 13, 2015


Open the Messages app on your computer, click "Messages" in the upper left-hand corner, click Preferences, click Accounts, select the relevant account (should be your email address or phone number), then uncheck "enable this account".

If that doesn't work-- you could signing out or unchecking your email address (both on the same screen).
posted by acidic at 8:22 AM on March 13, 2015


There are two ways text messages end up on your Mac:
* iMessage: on your Mac disable accounts in the Messages app preferences (⌘+Comma)
* Continuity: on your iPhone, Settings->Messages->Text Message Forwarding. Remove all devices listed.

Similarly if you want to disable phone call integration:
* on a single Mac: in the FaceTime app preferences uncheck "iPhone Cellular Calls"
* disable the feature entirely: on your iPhone, Settings->Facetime->iPhone Cellular Calls. Toggle it off.
posted by notpeter at 8:25 AM on March 13, 2015 [3 favorites]


notpeter is right, you need to disable text message forwarding on your iPhone. His steps will work.
posted by shesbenevolent at 10:44 AM on March 13, 2015


Also if you do at any point enable iMessage, make sure you go to Settings->Messages->Send & Receive and un-check your email addresses.
posted by shesbenevolent at 10:47 AM on March 13, 2015


I disagree by removing the email addresses from Messages. These are the touch points to connect with other people via iChat.
Simply adjust the settings in:
System Preferences > Notifications
posted by Mac-Expert at 3:34 PM on March 13, 2015


« Older My cat came home! (Yay!) Now what?   |   PayPal fundraising for unions Newer »
This thread is closed to new comments.