Those drop-down top bar menu things... how do I make them go away?
November 15, 2014 9:30 AM   Subscribe

See this New Yorker article. When I read it, the top New Yorker menu bar is hovering over the top of the page, so when I use the space bar to page down the bar blocks a part of the text. Is there some secret way to page down so that part of the text isn't hidden (I'm on a Macbook), or some way to make this type of menu bar go away? It's not just the New Yorker website--I see these many places.
posted by c'mon sea legs to Computers & Internet (16 answers total) 13 users marked this as a favorite
They're really pretty rude. Have you considered a readability extension to your browser? Like readability?
posted by leotrotsky at 9:41 AM on November 15, 2014 [2 favorites]

Some browsers, like Firefox, will detect those headers and automatically adjust the page-down motion to compensate. Others, like Safari, have a built-in reader mode that shows just the main content of the article. (This works the same as the readability extension that leotrotsky posted above.)
posted by mbrubeck at 9:43 AM on November 15, 2014 [1 favorite]

I don't know of a way to make the header go away, but in a situation like this I would find dragging two fingers on the trackpad an easy and satisfactory solution to the problem.
posted by humboldt32 at 9:49 AM on November 15, 2014

Response by poster: Ahhhhh, thank you! I use Chrome, got Readability.
posted by c'mon sea legs at 9:52 AM on November 15, 2014

Press Command+Option+I and paste this line:

document.getElementById("nav-container").style.display = "none"
posted by gwint at 9:53 AM on November 15, 2014

I'm on a Mac, using Firefox, and this is what I do: Hover over that bar, and two-finger click; select "inspect element" and then in the box that opens at the bottom of your browser window select the div id=mobile-nav-container. Two-finger select that and hit "delete node." Gone. It's only gone for that article; it will reappear when you load a different page. But still.
posted by rtha at 9:53 AM on November 15, 2014

I have had that same annoyance and leotrotsky's link to the Readability extension just made my day.
posted by jaguar at 9:53 AM on November 15, 2014

Oh, and on lack of preview: Yeah, readability works, too!
posted by rtha at 9:54 AM on November 15, 2014

For the web site designers in the house, Mike Bostock (NYT Graphics) has an excellent article on how to scroll in Javascript.

I see this bug on a lot of sites now. I'm surprised a highbrow site like the New Yorker is this broken; I'd think their web team would take more pride in their work.
posted by Nelson at 10:45 AM on November 15, 2014

Nthing any browser's Inspect Element. It should also be trivial to remove with a Javascript button or permanently remove with Greasemonkey, or Adblock Plus.
posted by turkeyphant at 11:35 AM on November 15, 2014

I'm on a MBP and I don't see what you're seeing, which appears to be because of NoScript. Disabling AdBlock doesn't affect things, temporarily "allowing all" with NoScript brings up the menu.
posted by Room 641-A at 11:52 AM on November 15, 2014

What browser do you use? I have a Firefox extension called "Nuke Anything Enhanced" and I right-clicked on the New Yorker menu you bar and selected "remove this object" and it got rid of it without issue. Try that. I'm sure Chrome has a similar extension.

Nuke Anything Enhanced is great for annoying features you don't want, photos you don't want to see, or removing crap you don't want when printing a page/saving a screenshot.
posted by AppleTurnover at 1:41 PM on November 15, 2014

I use the Ad Block extension for things like this, even though they aren't ads. Just tell it you want to block an ad on the page and it will prompt you to click the offending element, with a slider to increase/decrease the scope. This is essentially rtha's tip, but it's sticky: you've taught Ad Block to not show that thing to you, and you'll not see it again as long as the extension is enabled.
posted by mumkin at 2:24 PM on November 15, 2014

There's a Chrome extension called "Click to Remove Element" which may be similar to the Nuke Anything Enhanced Firefox extension. I used it when I still used Chrome.
posted by fedward at 9:39 PM on November 15, 2014

Right click on the bar and select 'Inspect Element' (in Chrome or Firefox) then go to the text box on the right, hit return and add "display:none" and hit return again.
posted by Happy Dave at 10:04 AM on November 16, 2014

You know, fwiw, this site does that screwy paging-with-a-spacebar problem too w/ the new redesign, unless you click the little "x" in the top right corner. I'm really glad they added the ability to hide the top nav here. Everybody should do that.
posted by nushustu at 1:00 PM on November 16, 2014 [2 favorites]

« Older The most important question ever asked on AskMe   |   I'm a great listener. Sound me up. Newer »
This thread is closed to new comments.