Invalid Certificate Problem
June 11, 2013 5:09 PM   Subscribe

Does anyone know why Google keep going out periodically at my house?

It happens for my entire network, not just my computer, and then it comes back just as inexplicably. I've tried everything I know how to do, but I'm stymied. Here's the error message I get in Chrome. It's basically an invalid certificate, WHATEVER THE HELL THAT MEANS. Here's an image of the error message I'm getting.
posted by sholdens12 to Computers & Internet (7 answers total) 3 users marked this as a favorite
Another vote for Malwarebytes.
posted by desjardins at 5:26 PM on June 11, 2013

If that doesn't solve it, check out deezil's guide.
posted by emptythought at 6:27 PM on June 11, 2013

Response by poster: Hi guys, thanks so much. I'm on a MacBook Air, and my wife is on a MacBook Pro. Could it help if I changed my DNS?

My hosts file is fine.
posted by sholdens12 at 6:44 PM on June 11, 2013

Same problem in Safari and Firefox?

You can change DNS for your computer in Apple Menu --> System Preferences --> Network. Click on your interface that is connected (probably Airport). Click on advanced. Click on DNS. What you see in light gray is the dns specified by your modem / router. Click the plus and add google dns ( which will override that. Then apply the change and try again in your browser. If that fixes the problem you will want to remove that change on your computer and set your router to use google DNS.
posted by ridogi at 7:07 PM on June 11, 2013

Response by poster: Yes, same problem in any browser. I was able to configure my computer to Google's DNS, and it seems to be okay, but how does one configure the router to use Google DNS?
posted by sholdens12 at 7:12 PM on June 11, 2013

Just so you know, some ISPs were (and possibly still are) spoofing Google's IP address in DNS to stuff their own ads in Google search.
posted by zippy at 7:37 PM on June 11, 2013

Depends on the model of router. To the left of DNS tab you saw above is the TCP / IP tab which will list your router's address (probably or similar). Go to that webpage which is where you configure your router. Look for DNS setting, possibly under DHCP and change your DNS entry there. Toggle Airpot on your computer and you should see in light grey on the DNS tab on the computers.
posted by ridogi at 8:00 PM on June 11, 2013

« Older Exchange Student to Scotland   |   Why do I always end up in the 'Friend Zone'? Newer »
This thread is closed to new comments.