Opera's URL Filtering Tribulations
April 4, 2013 7:03 AM   Subscribe

I'm trying to setup Opera to allow surfing on one site only, but my URL filter is failing me.

Per the kiosk mode instructions, my urlfilter.ini looks like the following.

[prefs]
prioritize excludelist=0
[include]
http://*.opera.com/*
[exclude]
*.*

However, when navigating to opera.com, I get: "Web Address Blocked" -- the block content being the "*.*", according to the Block Content details.

The precedence to the includelist seems appropriate. (I've also tried "prioritize includelist=1".) Otherwise, removing *.* fixes the block but defeats the purpose.

Do you have any other ideas on how I might tweak this? Thanks for your help.
posted by glibhamdreck to Technology (3 answers total)
 
Technically "opera.com" doesn't match your include list - www.opera.com does - does it block www.opera.com if you type it directly? (opera.com does just redirect to www.opera.com but you won't get the redirect with that filter in place).
posted by samj at 7:21 AM on April 4, 2013


It blocks regardless of the www.
posted by glibhamdreck at 7:26 AM on April 4, 2013


Hm, I copy pasted your settings into an urlfilter.ini and it works OK here (opera 12.15). So your settings are right, so the other things I can think of are:
  • Opera hasn't been restarted properly (make sure it's gone from the task manager).
  • You have some sort of weird http proxy
  • You need to clear your browser cache

  • posted by samj at 7:51 AM on April 4, 2013


    « Older Going to the Big Dance this weekend. For the music...   |   How can I get the monkey off my back without... Newer »
    This thread is closed to new comments.