Help me watch the olympics online: technical difficulties edition
July 29, 2012 3:14 PM   Subscribe

When I go to the NBC Olympics site to log in with my cable package details, the iframe that should show the log in fields (username and password) does not load. This is on a win7 machine with both chrome and FF. The problem does not occur on a different computer on the same network (a macbook running 10.6.8). What setting on my computer seems to be blocking this, and how can I get this frame to load?

For further detail, when you visit the site, and hit "click here & get ready," it prompts you to sign in by picking your provider (in my case, time warner). But when I click on time warner, the foreground pop-up displays a blank frame-- when I try to view source for the frame, it gives me an about:blank. I figure something somewhere in my security settings is blocking the frame loading from another url, as this happens on different browsers on this same PC but not on my mac. What gives?
posted by stresstwig to Computers & Internet (10 answers total)
The first thing you do is flush the cache in your browser and then try it again, with all your ad blockers turned off (and every other weird plugin turned off, too).
posted by Chocolate Pickle at 3:23 PM on July 29, 2012

Response by poster: Yeah, that was the first thing I did-- my chrome install has no add-ons or weird plug-ins enabled, cache cleared, same thing. FF add-ons disabled, cache cleared, still no dice.
posted by stresstwig at 3:25 PM on July 29, 2012

Do you Norton or some security suite program that might be over riding your browser settings?
posted by COD at 3:47 PM on July 29, 2012

What version of browser works on the Mac? Maybe you could try that version under Windows.
posted by Blazecock Pileon at 3:50 PM on July 29, 2012

Response by poster: COD-- I've got MSE running, tried turning off real-time protection to see if that did anything. Same results. On a lark, I tried totally disabling the firewall too. Same thing.

BP-- same browser versions, both FF and chrome most up to date release.

I'm figuring since neither browser works on the win7 box, it must be some greater option somewhere. I've tried changing various things in "internet options" to no avail. At this point, I'm baffled.
posted by stresstwig at 4:10 PM on July 29, 2012

What about proxy settings? I confess that I forget if this is still built into web browsers on Windows. Maybe there's something left over in there.
posted by Blazecock Pileon at 4:34 PM on July 29, 2012

Do you have the flash player plugin installed? If you don't, it won't work. (I think that Chrome defaults to "not having it" IIRC.)

Or maybe your flash plugin isn't up to date. Try this.
posted by Chocolate Pickle at 4:48 PM on July 29, 2012

A different answer is to temporarily use IE, if it works.
posted by Chocolate Pickle at 4:49 PM on July 29, 2012

You could also try downloading Opera.
posted by COD at 5:17 PM on July 29, 2012

Did you manually disable third party cookies at some point? Their login process requires that.

Another thing to try in Chrome is Incognito mode; that'll run without any addons. Your browser settings (like cookies) still apply though.
posted by Nelson at 9:16 AM on July 30, 2012

« Older Use vim for everything   |   Help me help my puddy cat. Newer »
This thread is closed to new comments.