Can't hear MIDI keyboard in Logic Pro 8
July 17, 2011 3:08 PM   Subscribe

Logic Pro problem: I can't hear my MIDI keyboard.

I’m using Logic Pro 8 on a MacBook Pro, and I want to record using a MIDI keyboard (M-AUDIO Keystation 49-e).

I have the keyboard plugged in, and I can tell that Logic does register what I'm playing. (There are several indicators that the application is picking up, such as the correct note names appearing at the bottom of the Arrange window in place of "No In"). I'm also able to record in GarageBand and hear it back.

Under “GM Device 2” on the left-hand side of the screen, I changed the “Port” setting to “USB Keystation 49-e.”

I can record and cause notes to show up in the Piano Roll.

Yet I get no sound before or after I try recording.

This is in a project where I've already recorded lots of instruments (audio and MIDI), and I can hear them fine. So this isn't a broader issue of being able to hear sound coming from Logic Pro.

I’ve looked in the manuals but can’t find any answers. I've tried to follow the instructions under the section called "Setting Up External MIDI Instruments," but I'm not getting the results described in the manual.

I've also Googled and read through many threads about similar issues, but I mostly keep finding threads that make the general assertion that “MIDI isn’t audio.” OK, I understand the concept of MIDI being different from audio. But I also know I can hear myself playing MIDI because I can do it with the caps-lock keyboard and with the same keyboard in GarageBand. So I don’t see why the fact that “MIDI isn’t audio” should prevent me from hearing any sound when I play that keyboard in Logic Pro.

More info:

- In case screen shots are helpful, here's my main window and my Mixer window with the keyboard track selected. Notably, my Environment window is completely empty, contrary to what the manual says should happen when you first create a MIDI track! I also see that there are some basic plug-ins (or inserts or whatever they're called) missing from this track which all the other tracks have, as you can see in the mixer window. I have no idea how to get them to show up.

- I believe I created the track properly: I selected "New track," chose the “External MIDI” option, then selected “Perc. Organ” from the Library.

- The volume level does not seem to be an issue. I have the physical volume lever on my keyboard turned up high, and even LogicPro's meters show that the sound is registering at a medium-high volume level.

- I have the red "R" button (for "record") turned on. The track isn't muted.

- I've tried closing and restarting the application many times and this doesn't solve the problem.

Any ideas?
posted by John Cohen to Computers & Internet (4 answers total)
Response by poster: Never mind! I solved my problem on my own!
posted by John Cohen at 3:21 PM on July 17, 2011

Best answer: The solution was: when you create a track, select "software instrument" instead of "external MIDI." (I have no idea what "external MIDI" is for — I thought that's exactly what I was using.)
posted by John Cohen at 3:22 PM on July 17, 2011

If I remember correctly, External MIDI routes MIDI signals originating from some other input device or channel to the external MIDI device you select. You get audio output back.
posted by invitapriore at 4:06 PM on July 17, 2011

Response by poster: Oh.
posted by John Cohen at 6:40 PM on July 17, 2011

« Older Where can I learn about court jesters?   |   Cash rules some things around me. Newer »
This thread is closed to new comments.