Double-zero sept just isn't the same.
June 9, 2011 8:20 PM   Subscribe

My DVD player automatically plays all DVDs in French. I like French and all, but James Bond is so much more fun in English!

I have a Panasonid DVD-F87 (manual here) and it automatically starts playing all disks in French. Annoying, but I could change it with the remote. Until the remote was corroded with battery acid... The remote is now completely useless.

Whatever, I could usually use the number keys to change the language. But this time, that didn't work. And I'm trying to watch Dr. No! I'd really like to change the default language back to English. Can anyone more technically savvy figure out how to do this?

Merci beaucoup!
posted by chatongriffes to Technology (9 answers total) 1 user marked this as a favorite
 
Left field here, seeing how you don't have a functional remote (do you have a PDA with IR out? There are apps for emulating remotes. My old Sony Trinitron's remote was able to emulate/learn other remotes), perhaps upgrading the firmware will reset the default (back) to English.
posted by porpoise at 9:28 PM on June 9, 2011


Clean your remote, let it dry, insert fresh batteries and you can access the audio menu to switch the language track on the DVDs.

Voila!
posted by plokent at 6:48 AM on June 10, 2011


I've gotten the corrosion off battery contacts by sanding them with an emory board, so you might try that if the Q-tip scrub or baking soda don't work. Bonne chance.
posted by aught at 8:59 AM on June 10, 2011


There's no such thing as "battery acid" with modern alkaline batteries. If you're at all handy, take the remote apart, give the circuit board a good scrub with a toothbrush and isopropyl alcohol, and let it dry.

I imagine your French problem is because the DVD player is set to French by default. You can usually change this in the player's setup menu, but you're going to need a working remote for that.
posted by neckro23 at 12:33 PM on June 10, 2011


Check yr MeMail.
posted by herrdoktor at 12:47 AM on June 11, 2011


There's a couple of ways you could approach this.
First thing I could think of is using the controls on the actual DVD player to access the menu where you can set language options back to English. This is normally done by powering the player on without a DVD in it.

Looking at the manual, you should be able to hit "Setup" and navigate to language options. This might work with a DVD in the player, or while the movie's playing.

Other option is to buy a generic remote and program it for your player.
posted by herrdoktor at 12:52 AM on June 11, 2011


Refer to page 12 in the manual.
On the player, hit Setup, then the Up/Down arrows to select "Disc."
Hit the Right arrow, then you should be able to get to "Audio."
Hit Up/Down to select English, then hit Enter to select it.
Hit Setup to exit.

Hope it works.
posted by herrdoktor at 12:57 AM on June 11, 2011


Last note: if the above works, might want to try selecting the language to Original, too. That way you get the standard language encode for the DVD. I dunno. My brain hurts right now thinking about how language is encoded on DVDs and how it's selected by the player. Anyway, good luck!
posted by herrdoktor at 1:00 AM on June 11, 2011


Ahh, nevermind. Those buttons are on the remote, and not on the player itself. Will post if I have any other half-thought-out ideas. Sorry.
Only other thing I can think of is plokent and neckro23's cleaning ideas.
posted by herrdoktor at 1:06 AM on June 11, 2011


« Older need a bag   |   Help me log in to Wordpress. Newer »
This thread is closed to new comments.