iPhone disrupting WiFi on Mac
November 27, 2010 3:52 PM   Subscribe

Why would an iPhone disable my Mac's internet connection?

Suddenly my Mac stopped connecting to web pages. I checked and Airport was enabled, and had a good signal - the computer is about three feet away from the router - but the Mac would not connect to any web sites. Restarted the Mac, same result. The internet was working, and web sites could be visited from other computers.

As a quick fix, I connected an ethernet cable and immediately was able to connect to web sites.

The only thing different was that we had a visitor who was using an iPhone, and who was using our WiFi to connect with it. Sure enough, after the visitor left, I unplugged the ethernet cable, re-enabled Airport, and immediately could visit web sites.

So is there something that could explain this behavior? We have been using an iPad on this WiFi signal for several months without any similar behavior.
posted by yclipse to Computers & Internet (4 answers total)
dhcp assigning both devices the same ip address?

did you try to turn wifi off then turn it back on for your mac?
posted by mulligan at 4:01 PM on November 27, 2010 [2 favorites]

Mulligan beat me to it. I suspect conflicting ip addresses was at the root.
posted by gern at 4:03 PM on November 27, 2010

I've had problems with other devices swiping my Mac's IP number on the network. I fixed it by going into the router setup and reserving addresses for all my devices - mac, PC, wireless printer etc. On a Netgear router this was found in the Advanced section, under "LAN IP Settings".
posted by nowonmai at 4:16 PM on November 27, 2010

I have this problem and it turns out my wireless router (Linksys, I think?) only allows 5 devices to connect to it at a time. So on occasion when we have company, we run into problems with everyone connecting at the same time.
posted by shopefowler at 9:31 PM on November 27, 2010

« Older Can you get mosquito bites in the winter or...   |   For the stylish gentleman who occasionally needs... Newer »
This thread is closed to new comments.