Google Chome: Too Much Noise
November 9, 2010 2:48 PM   Subscribe

When users of my Spanish-language learning website visit it using Google Chrome, all the audio podcasts open at once, creating a cacophony which leads to bewildered emails (my users) and shame (me). The site is Spanish Newsbites, it's been built using Typepad, and I can't believe I'm the only person in the world experiencing this. Any solutions (simple is good) gratefully received.
posted by Holly to Computers & Internet (10 answers total)
I'm on a mac using Chrome and it doesn't happen to me. That could help nail down the problem.
posted by wayland at 2:50 PM on November 9, 2010

Response by poster: Thanks, wayland. Unfortunately I'm on a PC and Windows...
posted by Holly at 2:58 PM on November 9, 2010

Same story -- Mac user (Mac OS X 10.6.4) with Chrome 7.0.517.44 and no simultaneous launching of podcasts at all. Can you get the people who report the problem to also report platform/OS/version to start to narrow down things?
posted by briank at 3:02 PM on November 9, 2010

Response by poster: Will do, briank - thanks.
posted by Holly at 3:05 PM on November 9, 2010

Chrome, windows 7. I started hearing noises until I quickly muted my computer, can't say if there were multiple podcasts but definitely noise.
posted by R a c h e l at 3:16 PM on November 9, 2010

Okay, just tried it on a PC running WinXP and same version of Chrome and DID get the simultaneous autolaunch.

embed autostart="false" bgcolor="#FFFFFF" controller="true" loop="false" src="" height="42" width="300"

Maybe the Win version of Chrome doesn't like the autostart parameter. Have you tried any other scripts that embed an audio player to see if Chrome likes them better?
posted by briank at 3:22 PM on November 9, 2010

Definitely seems to be a weakness of Chrome for Windows. WinXP, SP3, and Chrome 7.0.517.44 ("up to date").
posted by dhartung at 7:13 PM on November 9, 2010

Best answer: As a former TypePad support employee, I'm pretty sure this issue has to do with how Chrome does (er, doesn't) handle autoplay=false for embeds unless a type is defined.

I'm not sure if you are using the default TypePad audio inserting, but the resolution is pretty simple regardless. For any post with an embedded mp3, click to the HTML tab for editing the post and look for:

<embed autostart="false" .... />

and add in type="audio/mpeg" so it will look like:

<embed autostart="false" type="audio/mpeg" .... />

save your changes, then move on to each of the posts that are showing on the main/home page, and that should do it.

Reference material:
posted by zalary at 7:49 PM on November 9, 2010 [1 favorite]

Response by poster: That is absolutely fantastic, everyone. And Zachary: what a shame you aren't STILL a Typepad support employee, if you understand me ;-)
posted by Holly at 8:57 AM on November 10, 2010

Response by poster: Sorry, Zalary - make that 'Zalary', not 'Zachary'. Thanks again.
posted by Holly at 2:15 PM on November 17, 2010

« Older Craigslist scam or legit?   |   England Dan? NOT from England. But was his song a... Newer »
This thread is closed to new comments.