Canon Pixma MX340 won't print wirelessly from iMac
September 5, 2010 6:07 PM   Subscribe

Can anyone help me with setting up my Canon Pixma MX340 to print wirelessly from my iMac?

I've followed all the instructions in the manual and even tried using the directions given online to others who have experienced a similar problem, but my iMac keeps saying that my canon printer is offline. Can anyone help me solve this?

Thank you in advance if you are willing and able.
posted by jefficator to Computers & Internet (9 answers total) 4 users marked this as a favorite
First, do you know you have the Wifi set up right, with your encryption protocol (WEP/WPA) and passphrase? Wifi setup on those printers has to be (IME, I have an 870) by the book.

Second, in Safari, if you look at Bookmarks/Bonjour/Printers, do you see a gobbledygook-looking name in there? If so, and if you click on it, do you get a network configuration page with the printer's name as the header?
posted by jet_silver at 8:01 PM on September 5, 2010

Is the first time you're setting up the printer? If you're running 10.6 make sure you have the latest drivers from the Canon website. I just bought a Pixma 560 last week and had to do this. The 10.5 drivers on the install disk won't work.
posted by Room 641-A at 8:07 PM on September 5, 2010

I got mine printing in Leopard (I had it hooked up to an AirPort Express) but I couldn't get it to find the scanner. I wasted a lot of time before sending it back. The Apple store accepted it without discussion.
posted by bonobothegreat at 8:13 PM on September 5, 2010

Had this problem, the wireless network name had an apostrophe in it, had to input the network name manually. (could not find it even with laptop sitting on the printer). Works fine now.
posted by KenManiac at 8:32 PM on September 5, 2010

I don't see a bookmarks/bonjour/printers option?

I am downloading the drivers now.

Ken, where did you have to input the name?
posted by jefficator at 9:13 PM on September 5, 2010

Drivers did the trick. Thanks for the help!
posted by jefficator at 9:47 PM on September 5, 2010

(If it makes you feel any better, I got a Pixma running on my wireless studio network recently with my MacBookPro, it was also a problem with the drivers, and it was a mega pain in the butt, so lots of sympathy from these quarters!)
posted by at 2:08 AM on September 6, 2010

I'm glad it worked!

Canon really needs to document this.
posted by Room 641-A at 6:18 AM on September 6, 2010

For the record, after discovering network failed, there was an option to do it manually, or advanced mode, don't remember exactly.
posted by KenManiac at 7:51 AM on September 6, 2010

« Older Student loans for the post-grad post-bac   |   Just a simple list of songs Newer »
This thread is closed to new comments.