Help me force iTunes to not lost my songs!
April 10, 2010 6:54 PM   Subscribe

iTunes filter: I store all my MP3s on an external hard drive, and iTunes is set to automatically sync my iPhone whenever I plug it in. Everything works fine, except when I'm traveling without my external hd and I plug in my iPhone. If I do that, the next time I check my iTunes all the songs that are on the iPhone have a gray exclamation point next to them. Help!

After this happens, I have to go through and click each song, individually, so iTunes will "rediscover" them. I've tried to select all the missing tracks and change something non-essential in the info in hopes of forcing iTunes to find the songs again, but that doesn't work.

Does anyone have any suggestions other than "turn off auto-sync?" Thanks!
posted by bjork24 to Computers & Internet (4 answers total) 1 user marked this as a favorite
 
I'm not certain I understand. Auto-sync is working as designed. When you connect you Iphone to the computer, it syncs but can't find the mp3's specified on the computer so they get disabled.

I'm not going to say the one solution that you don't want me to suggest.
posted by Megafly at 12:14 AM on April 11, 2010


You can turn off "open itunes when I connect my device" for your phone.
posted by jeather at 8:09 AM on April 11, 2010


Only suggestion I have, being in the exact same situation (macmini, but external storage on another server that may not be awake/on) - is to turn off auto-sync.
posted by ish__ at 10:17 AM on April 11, 2010


Actually, after some tinkering, I seemed to have figured this one out myself, and here's how:

Since I have iTunes set up to both auto-sync and "open on connect," I simply close iTunes (which is showing all the tracks as missing), unplug my iPhone, plug the iPhone back in, iTunes re-opens and all of the songs are miraculously restored! No setting tweaks required!
posted by bjork24 at 8:16 AM on April 12, 2010


« Older Cuba in Comics   |   Primer primer Newer »
This thread is closed to new comments.