OS X Server kicking me out?
January 18, 2010 3:16 PM   Subscribe

Why is OS X Server logging me out after a period of inactivity?

I have an Apple Discussions thread about it here but I haven't had any real solutions so far. I have also inquired about this at afp548.com, to no avail.

I am NOT talking about AFP/NFS/SMB or SSH. This is me, sitting at the server with a monitor and keyboard attached. I can log in just like a normal ol' user and surf the web, but if I go away from the machine for a while, it will log me out.
The screen saver does activate and if I return in a timely manner, it will ask me for my password to unlock the screen saver. This is normal, and I expect this.

What I do NOT expect is to come back and find that I have been logged out completely. This is annoying, and I cannot seem to find a way to disable this.
posted by drstein to Computers & Internet (7 answers total)
 
The Security system preferences pane has a setting for logging out users after a period of inactivity. Have you checked there?
posted by BryanPayne at 3:33 PM on January 18, 2010 [1 favorite]


Are you sure it's a logout and not a restart? Mac OS X Server on most hardware will restart itself by default if there's a software lockup (this is the default). Very easy way to find out: the next time you think you've been logged out, log back in and type "uptime" at the Terminal. If your uptime is different from what you think it should be (e.g. you see a recent restart), then you've found your answer....the system is (probably) locking up and restarting itself. This would also explain why you're not returning to a "Are you sure you want to close all these Safari/Firefox tabs and logout; or Safari has cancelled your logout." messages....

If it turns out you're having system lockups and restarts, you might be able to track down the culprit by examining the relevant logs (CrashReporter, HangReporter, etc.).

And bad or marginal RAM can cause this. Often. Swap out your RAM for known-good chips and see if the problem persists.
posted by mrbarrett.com at 5:12 PM on January 18, 2010


"Mac OS X Server on most hardware will restart itself by default if there's a software lockup"

Huh? Care to elaborate on that? Most or all Apple hardware will restart itself in the event of a power failure, but not in the case of a software lockup.
posted by BryanPayne at 5:54 PM on January 18, 2010


BryanPayne: No offense, but you clearly didn't read the information. I linked to the Apple Discussions thread because I didn't want to rehash it. This machine DOES NOT have that option. I keep having to explain this over and over, so I apologize for being frustrated.

Here's a screenshot.

For the others:

"Greetings!

I have a fresh installation of 10.5.x Server on a G5 and I'm noticing something that I haven't seen on any OS X Server before - it's logging me out after a period of inactivity. I currently have one account on the machine, and this is happening when I'm logging in on the machine itself. It's in a small office environment, and there are no security concerns with access. I'd like to just have the screensaver password, but it's logging me out completely.

I have Googled, Binged, Yahooed, Dogpiled, and dug through the Apple Discussions to no avail. I did see another similar thread, but no answers.

On OS X 'client' I know that the "log out after X minutes of inactivity" is in System Preferences -> Security, but on my server there is no such option. ("Security" is there, but there's nothing about logout.)
I've looked everywhere I can think of in Server Admin and Workgroup Manager but no dice.

And like I said, I have not seen this happen on other 10.5.x Server boxes...just this new install.

Help! "
posted by drstein at 7:39 PM on January 18, 2010


BryanPayne, in Mac OS X Server 10.0 -> 10.3, there was a watchdog process that watched for a "hung" system and would trigger a restart if detected. It has since been replaced by launchd, but the functionality is the same in 10.4 and 10.5 Server. The hardware does have to support this option. I'm positive that Xserves have it and if my memory is correct, G5 tower and Mac Pro towers also have this support for hardware as they are hardware that Apple has "officially approved" for the running of Mac OS X Server. Read about watchdog and launchd here.

Dr. Stein, I understand your frustration. It sounds like a very frustrating problem. However, none of your links nor your answers have answered my first question to you. Are you sure it's a logout and not a restart?

And just so we're thorough...have you removed all 3rd party devices from this box? I've seen some really strange behavior, including mysterious restarts and logouts when incompatible or partially-compatible USB or Firewire hardware is attached (I'm looking at you ancient MacAlly USB keyboard).
posted by mrbarrett.com at 8:34 PM on January 18, 2010


Sorry about that.. I was out looking for poultry to sacrifice and didn't see your first question. :-)

I am 100% positive that it's not a restart. This is verified by 'uptime' - and I can also delay the logout by leaving an unsaved TextEdit document.

Interesting that you should mention an old MacAlly USB keyboard... have you been having problems with one? I have an old OLD OLD (like, from the first days of the original iMac) MacAlly iKey but I've never had problems with it.

Check out the Apple Discussions thread. I might have found a solution, and my theory is that it's an issue with Workgroup Manager.
posted by drstein at 2:55 PM on January 20, 2010


Ah, interesting. There is definitely an MCX setting (settings pulled down from WGM) that can control idle timeouts, etc. I use it in my labs all the time.

But, for it to affect your *server*, you'd have to be managing the *server* with WGM. Not impossible, just not that common. You would have had to add the Server to a managed computer list and then set the Logout preferences in WGM (Preferences section) and have applied it to the server. Again, not impossible, just unusual. Essentially, you'd be treating the server like it was a client computer and it was behaving as such, pulling MCX settings from itself and following them.

MCX settings are stored in /Library/Managed Preferences. You might be able to open up the different .plist files in here and look for the culprit. You could also, of course, check your MCX settings in WGM and make sure the server isn't listed in any managed computer group.
posted by mrbarrett.com at 6:55 AM on January 21, 2010


« Older Experiences with chemotherapy drug, Xeloda.   |   Pablo Neruda's French Equivalent? Newer »
This thread is closed to new comments.