VPN woes
November 24, 2009 4:20 PM   Subscribe

I have set up a VPN connection, and two network adapters: wired and wireless. How do I force the VPN connection to use the wireless adapter, without disabling the wired adapter?

I am on Windows 7.

Problem is that the wired network connection on my company's LAN goes through a firewall that blocks my ability to use the VPN connection that connects me to my customer's LAN. The wireless network, however, is open to the internet.

Currently I disable my wired adapter, fire up the VPN which connects over the wireless adapter, then re-enable my wired adapter. This works fine but is really annoying.
posted by randomstriker to Computers & Internet (5 answers total) 3 users marked this as a favorite
 
Aha...figured it out on my own. From the command prompt, I typed:

ROUTE -P ADD [ip# of vpn server] [ip# of wireless gateway] METRIC [a very low number]

Moral of the story: try harder to figure it out before wasting my weekly question.
posted by randomstriker at 4:43 PM on November 24, 2009


You may not even need the [very low number] part. I would think that the most specific route would be chosen first. Of course, I haven't actually tested this hypothesis. My Windows 7 is in a virtualbox that's put away at the moment.
posted by axiom at 4:46 PM on November 24, 2009


I did need it.

You are correct that if there is no valid route via the wired network, I would not need the low metric.

However there is a valid route via the wired network...it is the VPN port that is blocked on the firewall via the wired network.

So I have to use a low metric on the wireless gateway to force traffic to be defaulted through it.
posted by randomstriker at 4:52 PM on November 24, 2009


Windows automatically assigned network connections a certain metric depending on their connection speed - that way it attempts to use the faster network first. If you want to manually choose which connection to use, you have to override the automatically-assigned metric. I don't use Windows 7 but there should be a GUI way to change this in the TCP/IP settings too. The number just needs to be lower than that of the wired connection (or conversely, the wired connection's metric needs to be changed to be higher than that of the wireless one).
posted by turkeyphant at 4:38 AM on November 25, 2009


Assigning a low metric to the wireless adapter would route all traffic through it. That's not what I want; if it were then I may as well just disable the wired adapter.

I want the VPN connection alone to go through the wireless adapter, and everything else through the wired adapter. To achieve that I must use the ROUTE command.
posted by randomstriker at 7:07 AM on November 25, 2009


« Older Help solve the mystery of the missing extension.   |   lorem ipsum Newer »
This thread is closed to new comments.