How to make the music stop skipping?
October 24, 2009 10:44 AM   Subscribe

Calling all network experts...How can I make the music on my PC stop skipping?

Greetings...okay, trying to provide all relevant details: My main PC in my den/playroom stores my entire MP3 collection. It's a fine computer, and I never have any issues playing music on it.

It is one of two PCs on my home's wireless network.

The other PC on the network is out in the living room. It's a perfectly fine, not-ancient (2005 or so) laptop hooked up to my home theater system with a sole purpose of playing music through said system.

Yet whenever it's playing, about three times per song (so about once every 90 or so seconds), the song will just stop and then pick right back up about 2 seconds later. It's almost like a buffering effect...the music is playing, then it disappears, then it's back.

Does anyone know why this is happening, and if there's any way to fix it?

Potentially key details:

1. The MP3s are not stored on the laptop; they are stored on the main PC...which shares them with the laptop. (I like it this way so I only have to maintain one library.)

2. There's a wall between the den and the living room.

3. Both machines run Windows XP (fully updated with service packs, etc.).

4. The cable modem and router are always going strong.
posted by st starseed to Computers & Internet (10 answers total)
Have you tried using wires with the two PCs (first together, then one at a time) to see if that alleviates the problem? Not saying you need to use it as a permanent solution if it works, but it never hurts to isolate the problem.
posted by adamdschneider at 11:19 AM on October 24, 2009

What music player are you using and what is your wireless signal strength?
posted by wongcorgi at 12:46 PM on October 24, 2009

Yeah, as others here are hinting at I would be suspicious of the wireless network first off. Try using a hard wire connection just to test.
posted by theButterFly at 1:43 PM on October 24, 2009

As wongcorgi said, the software may also have something to do with it. Older VLC versions used to do it, which is why I didn't use it. I have a gigabit wired network in my house and some players will still do that, while others don't.
posted by Katravax at 2:52 PM on October 24, 2009

Don't use a wireless network.

If you absolutely have to use a wireless network, look to see if your client playback software has any buffering options. If it does, turn the buffering way up: at least 60 seconds of audio. If the software is well written it may work around a flaky wireless network with out many ill effects.
posted by Nelson at 3:30 PM on October 24, 2009

Do you have any wireless devices near your router that operate int he 2.4Ghz range? Cordless phone, etc? I would often see my connection drop up an down and could never explain it until I moved that away and it worked fine.
posted by CharlesV42 at 3:43 PM on October 24, 2009

Actually the very first thing I'd try would be to copy a bunch of the MP3s locally to the laptop, play them from there, and see if you still have the problem. The amount of bandwidth required to stream an MP3 is about a megabyte per minute, which even a really crappy wireless connection would handle no problem. In fact, if the wireless network was having problems sending that tiny amount of data, you would find your laptop's online functions like web browsing unbearable. We're talking 20 - 30 seconds to pull up Yahoo's front page speeds.

If it does still happen when the MP3s are copied locally, maybe whatever you're using to play them has some sort of codec issue, so try another player. Or there could be bigger issues with the laptop in general, either software or hardware.
posted by barc0001 at 4:05 PM on October 24, 2009

I arranged a similar setup at a uncle's house once and ran into the same problem. Nelson seems to have the solution - find the buffering settings on the music player and increase the buffer. Most media players (VLC, windows media player, MPC too I think, etc) have a setting for buffering. That's what I did and it worked fine.

Modern 802.11G networks should not have this issue, but a older "B" network very well could. I'd also do as barc0001 suggested and copy some mp3's over and see if those work or not - just in case it's the computer.
posted by rmathew1 at 7:40 PM on October 24, 2009

Try it with a wire as a first option. Also, install something that allows you to see how much network activity there is - if there's a big gap in traffic before the silence, you know that you have issues, maybe interference. If the network just can't keep up with the data, that will look like a continuous stream of data going past at a bitrate slightly lower than your MP3s.

Anecdata: I use a Squeezebox on an 802.11g (54Mbps) wireless network and stream FLACs to it, which are a lot more bandwidth than MP3s. Works perfectly, unless someone uses the microwave, at which point the network just stops. Squeezebox has enough buffering that a 30s nuking will cause no glitches but if you put it on for a couple minutes, the music all but stops entirely.
posted by polyglot at 2:00 AM on October 25, 2009

Response by poster: Thank you! I just listened to all eight minutes of Stairway To Heaven without fail...

The issue was, as some suggested, the buffer. I'm using Winamp 5.5, and by kicking up the buffer a few notches, playback was smooth and clean.

Good on y'all...the wisdom is appreciated.
posted by st starseed at 6:23 AM on October 25, 2009

« Older For Dog's Sake - Help Me Start A Business!   |   How to avoid police charges? Newer »
This thread is closed to new comments.