OS X Terminal problem
November 17, 2004 4:01 PM   Subscribe

OS X Terminal problem: somehow, at some point, my Terminal application window became unusable. It's minimized to the point where I can't see ANY of the actual "terminal", and I can't maximize it. I can ONLY see the "red" close button, cannot drag scale the window anymore, and cannot doubleclick or otherwise use any of the keyboard shortcuts I know to restore it. [mi]

Further, I've tried trashing the Preferences for Terminal (the classic Mac fix-it) to no avail, and any New Terminal window opened comes up at the same ultra-minimzed size, where the application cannot function. I've checked the applications preferences to try to force a window size, but again to no avail. And yes, I've had my IT dept. look at it. They were stumped.
posted by robbie01 to Computers & Internet (18 answers total)
 
This is what it looks like (yes, that's all of it):



posted by robbie01 at 4:06 PM on November 17, 2004


Um; you've got some password protection on that image, robbie.
posted by mr_roboto at 4:13 PM on November 17, 2004


I have the same problem and have never gotten it resolved. However, there were many suggestions in this thread. Maybe one will work for you.
posted by dobbs at 4:27 PM on November 17, 2004


"Window" menu --> "Return to default size" does nothing for you?

Failing that, you could try using the shareware app Pacifist to reinstall Terminal from an OS X install CD.

Oh - you could also try creating another user (if none exists) and see if the behavior is the same.
posted by stonerose at 4:28 PM on November 17, 2004


Whenever something is super-wacky like this it's usually your preference files. Two ways to deal with it:

1) Test it: Create a new user and log in as that user. Does the problem persist? If so, then the application is b0rked and I can't help you, although re-installing like stonerose said would be a good place to start.

2) Test and Fix it: Preferential Treatment (click on it on the left side then download it from the main frame, the site has an unhealthy fixation on frames) will find corrupted preference files and fix the hell out of them.
posted by revgeorge at 4:53 PM on November 17, 2004


Thanks for the suggestions, still no luck.

I tried all of the suggestions in that other thread (at least I know I'm not the only one) and have also attempted to copy Terminal.app (and its .plist) from another user's computer, completely replacing my own copies (not sure if this counts as "reinstalling" or not). Still does the same thing.

Creating a new User Account reveals an even stranger problem: when using the new account, Terminal.app's icon appears as a folder with a red minus on it (not readable?) and reports a size of "--k".

I tried Preferential Treatment as well, but it did not report a problem with Terminal's preferences.

I've also tried changing default fonts that Terminal uses, still no go.
posted by robbie01 at 5:38 PM on November 17, 2004


Maybe you have permissions issues. You didn't, by chance, ever click on your hard drive or Applications folder, fiddle with the Details, and then click the "Apply to enclosed items" button, did you?

In any case, even if you've used the Disk Utility, I recommend booting from the system CD and re-running the "Repair Disk Permissions" from there. It will catch things running the program from the hard drive, while booted from that drive, will not.
posted by Mo Nickels at 5:49 PM on November 17, 2004


The problem with the new user account indicates some deeper problem that this couldn't fix... but I imagine that you can easily write an applescript to 1) open terminal.app, and 2) maximize the window.
posted by armchairsocialist at 6:02 PM on November 17, 2004


Start Terminal.
Open the ScriptEditor application.
Enter this script:

tell application "Terminal"
activate
tell window 1
set number of rows to 40
set number of columns to 80
end tell
end tell

Click on Run
posted by plinth at 6:19 PM on November 17, 2004


Where would one find the ScriptEditor application?
posted by dobbs at 8:46 PM on November 17, 2004


Applications -> AppleScript -> Script Editor.
posted by teg at 8:56 PM on November 17, 2004


Thanks, teg.

plinth, that had no effect on mine, but thanks for trying.
posted by dobbs at 10:44 PM on November 17, 2004


Wow, that's spectacular. I used a similar script to make my Terminal tiny and then restored it with that one.
posted by plinth at 2:40 AM on November 18, 2004


Just tried the script (bonus points for innovation!) but unfortunately it didn't work for me either :(
posted by robbie01 at 10:20 AM on November 18, 2004


I've seen this before. For one of many reasons your term window can't find the font it needs.

Its always always always about the fonts
-Freud
posted by Fupped Duck at 12:36 PM on November 18, 2004


My closest assumption at this point was fonts as well, Fupped. The evidence is that under Window Settings -> Display, the "Text:" item reads "null" and then either 0 pt. size or some astronomical pt. size (30201890.1)

Unfortunately, whatever this bug is also does not allow you to change the Font using the Fonts... dialog box. You can select another font/pt. size but it never registers to the application.

I've also tried disabling Suitcase as well, but the same effect occurs.
posted by robbie01 at 3:21 PM on November 18, 2004


does any of this help? and dobbs, any luck with the high processor? I had it a couple of times with quicksilver, but it seems to have calmed down once I removed my user directory from the catalog.
posted by grimley at 5:11 PM on November 18, 2004


Tried poking around in Font Book as well, to no avail :(
posted by robbie01 at 11:29 AM on November 19, 2004


« Older Downloading corporate logos?   |   CMS recommendation Newer »
This thread is closed to new comments.