Help me, Metafilter? Or, hel me etafilter?mp
January 8, 2009 5:32 AM   Subscribe

My laptop keyboard cursor randomly backtracks one space as I type. This only seems to happen in Firefox. Has anyone else had this problem, and how do I fix it?

I'm running an acer aspire 2000 cl32 laptop, and the latest version of Firefox, although this problem began before my latest update. It doesn't happen in other text applications like Word and Notebook (which is where I'm typing now).

It's not due to the edge of my hands pressing down on the touchpad. It's also not due to any keys sticking, as far as I can tell. The problem seems to go away if I restart Firefox, but there are only so many times I can do that before it gets annoying.

Is there anything else that I'm not thinking of? Googling comes up with other users with the same problem, but no solutions.

Hep me metafilterl (ees?)
posted by minus zero to Computers & Internet (6 answers total)
Latest version? You mean the 3.1 beta or 3.05? I don't have any issues with 3.05. Check version (Help --> About) and check bug reports on Bugzilla for the issue. There's a chance it's screwed up in the beta due to a regression but fixed in the nightlies.
posted by caution live frogs at 6:46 AM on January 8, 2009

Best answer: I've had similar problems. It generally had to do with Firefox's language support. It has something to do with it switching input modes for languages that write right to left. I know how frustrating it is. It seems like a simple problem doesn't it?

Have you tried reinstalling?

My final solution was to wipe the system and reinstall windows :/ Good luck.
posted by teabag at 7:22 AM on January 8, 2009

I had this happen once, too! It was really weird. I just closed firefox and everything was fine (I think that's how it was fixed).

Googling for firefox right to left text came up with this page, and the handy hot-key set of Ctrl-Shift-X. I just tried it, and it works! Type it again to undo the setting.
posted by filthy light thief at 9:21 AM on January 8, 2009

On re-reading your question, I don't know if I answered this. It does sound like a touchpad issue, but since you say it's not, do you use hot-key combination much? That's how I flipped my text by accident.
posted by filthy light thief at 9:24 AM on January 8, 2009

Response by poster: This is version 3.05.

I'll give reinstalling a go.

Filthy light thief - it happens quite randomly, so I don't think it's me pressing the hot key set! And my hands are positioned in such a way that they don't touch the type pad at all.

My OS is Windows XP in Chinese - maybe that's what's screwing it up (I've only ever typed in English, but perhaps Firefox doesn't play nicely with the language settings?).
posted by minus zero at 11:42 AM on January 8, 2009

That sometimes happens to me. This might be just anecdotal evidence, but the last time that it happened to me, the site I was on had a java applet running, and when I tried to use the search bar, it happened. Then when I left the page and the java thing stopped running it stopped. So that's weird.

It's also probably the fact that you're using XP in Chinese, and Firefox gets confused sometimes.
posted by azarbayejani at 1:46 PM on January 8, 2009

« Older Where in Paris should my friend propose to his...   |   6YO girl BD Present Newer »
This thread is closed to new comments.