Microsoft Word Error
September 24, 2004 1:07 PM   Subscribe

All of a sudden, Word's giving me this error when trying to save anything at all, even a new document with one word in it: This operation couldn't be completed, because an error occured. The specified encoding is not supported for this operation (MacOS Error code: -8738). WTF?
posted by dobbs to Computers & Internet (5 answers total)
 
This looks helpful.
posted by modofo at 1:45 PM on September 24, 2004


That would only be helpful if he's using Mac OS 9. Error -8738 is "kTextUnsupportedEncodingError", and generally speaking, it means Word is asking the Mac OS (either 9 or X) to change the encoding of text either to or from an encoding that your version of the OS does not support.

If you're using Mac OS 9, the hints in that article may help. If you're using Word v.X or Word 2004, make sure you didn't install some new font that's using a non-standard encoding that Word is trying to use in your new documents. It's possible that some side effect of the "Match font to keyboard" preference could have something to do with it if you recently picked a new keyboard layout, but I'm more skeptical about that idea.

If Word is getting a text encoding error on everything you do, either Word or the OS is confused about the text you're trying to save. Beyond that, I can't say much.
posted by mdeatherage at 2:47 PM on September 24, 2004


I am not sure if this would solve your problem, but I would suggest opening the International preference pane and making sure everything's set to U.S.
posted by ikkyu2 at 9:02 PM on September 24, 2004


Thanks, folks.

ikkyu2, I opened the pane and in the Input Menu section, the U.S. option is checked, but grayed out as are Romaji, Hiragana, and Katakana under the Koteiri submenu.

It's not allowing me to check or uncheck any of the boxes. I have no idea what an Input Menu is for. How do I make the U.S. one a solid checkmark?
posted by dobbs at 1:45 PM on September 25, 2004


The Input Menu can be a menu item, up there in the top right corner along with your little sound-volume thingy and clock. It allows you to specify the encoding you're using to input text. The preference pane International/Input Menu is to configure that menu, not for choosing the current encoding.

U.S. is grayed out, I believe, because it is already automatically in your input menu. But you want to make sure it is actually the chosen encoding.

So enable 'show input menu in menu bar' in the International/Input Menu pane and take a look. I left mine enabled because I like having a little American flag in my menu bar.

Under International/Formats I have United States (POSIX), and under Languages I have English first.

I feel skeptical that this is going to fix your problem, though.

You might also try opening one of the offending documents, then going to Word/Preferences/Compatibility and clicking Font Substitution, and/or fooling around with some of those checkboxes and/or resetting to Word defaults.
posted by ikkyu2 at 10:06 PM on September 27, 2004


« Older Movable Type   |   Our office Macs won't connect to new NetGear... Newer »
This thread is closed to new comments.