Why doesn't this page display properly in Netscape 7?
September 20, 2004 1:17 PM   Subscribe

HTML/CSS helpfilter: This page displays properly in Internet Explorer, Firefox and Safari, but confounds Netscape 7.0. Why? [mi]

This CSS Style Sheet controls the layout and displays a header and three columns. Netscape 7.0 (Win) only displays the header. Heck, even NS 4.8 displays the page more or less correctly. Although any NS 7 users should probably upgrade to a newer browser, what in the HTML or CSS prevents the 3 columns from displaying in NS 7?
posted by andrewraff to Computers & Internet (4 answers total)
 
You seem to have an extra closing div near the end of your html and the ".mp3foot" class in in your stylesheet appears to be missing an ending curly-brace }

I don't know why either of those would cause the problem you describe, but it's worth a shot.
posted by mkdg at 10:19 PM on September 20, 2004


It would be a good idea to check your html and css with a validator. There seem to be a few errors.
posted by teg at 10:36 PM on September 20, 2004


the validator results for the page and the css. Best advice would be to check the errors in both.
posted by bob sarabia at 12:02 AM on September 21, 2004


Thanks all!

You don't do this html stuff for a while, you forget about useful tools like the validators...
posted by andrewraff at 5:42 AM on September 21, 2004


« Older Does anyone know of an iTunes plug-in that will...   |   How do I generate a true weekly top 25 list in... Newer »
This thread is closed to new comments.