Join 3,558 readers in helping fund MetaFilter (Hide)


My MacBook's Internal Speakers Are Stuck on Mute
May 17, 2008 10:08 AM   Subscribe

I can't get my Mac laptop's internal speakers to work -- they just stopped one day. When I press the volume adjust buttons, the little bars don't move, and the classic circle-with-bar-through-it appears. I've checked the volume in System Preferences, and the "mute" button is not selected by accident.

When my headphones are plugged in, they sound fine, and I can adjust the volume under System Prefs. But when I unplug the headphones, the volume control greys out -- and the Selected Output switches to "Digital Out."

I have a slightly older Macbook Pro -- a 2.1, with Intel Core 2 Duo, if that matters.

I've checked AskMefi, searched around, and I know this is not a unique problem, but everyone on all the threads I've seen has just said "oh, figured it out, thanks," without offering any explanation!

Please -- if any of you know how I can fix this, I would greatly appreciate the help.

Thanks so much ...
posted by chinese_fashion to Computers & Internet (9 answers total)
 
And -- a red light shines out from the headphone jack. Not sure if that ever happened before.
posted by chinese_fashion at 10:27 AM on May 17, 2008


Try blowing out the optical out jack with canned air. It should be the same jack as for your headphone. I had that problem with my iPhone, where there was dust in the port which made it think there was something plugged in.

Having the adjust buttons disabled is what happens when you have an optical cable hooked up. (I'm running optical out on my Mac mini).
posted by wongcorgi at 10:29 AM on May 17, 2008


After trying the above with the headphone jack you should try a pram reset: Directions Here
posted by humanawho at 10:53 AM on May 17, 2008


As wongcorgi suggests, it is most probably dust in the microswitch which tells the port that there is an optical jack plugged in.

A good blast of canned air, jack and re-jack with headphones, (or better yet, an optical cable) and another blast of air should do it.
posted by tomierna at 12:25 PM on May 17, 2008


Another trick that helps with software-based mystery muting is to launch Garage Band and start a new project. Apparently this process runs through some diagnostics in the background and clears up some issues. It's worked for me.
posted by adamrice at 2:48 PM on May 17, 2008


I had the same problem, and this thread on macrumors solved it.
"After reading forum thread after forum thread of users that had this problem, I found a dude who fixed his jack with a rubber ended bobby pin. It seems a sensor gets bent (?) and the system thinks your digital external line is still plugged in. I took the butt end of a matchstick and tickled inside the jack. My red light went out. My internal speakers work again."
posted by kolophon at 5:31 PM on May 17, 2008


Poke a toothpick in the headphone jack and your problems will go away. You can confirm the issue (MBP thinking there is an optical TOSlink cable connected) by going to System Preferences > Sound and seeing "Digital Audio" rather than "Internal Speakers" as it should.
posted by cgomez at 8:15 PM on May 17, 2008


What tomlerna said.

I used to have this problem all the time on my old 2.16 1.5 gen MacBook Pro....the red light and everything.

The only thing that works is to stick a headphone plug into the jack, remove it and reinsert it several times in rapid succession. I'm not entirely sure if this is a hardware problem or a software problem, but all I know is that several months after I frequently experienced this issue, the problem just went away forever. Maybe an OSX update fixed it or something?
posted by melorama at 9:54 PM on May 17, 2008 [1 favorite]


Thanks, guys. I didn't have canned air, so I just pursed my lips and blew in there with my breath real hard -- then poked the headphones in and out repeatedly. And: success! Thanks so much, all of you.
posted by chinese_fashion at 7:10 AM on May 18, 2008 [1 favorite]


« Older How do I train for a (half-)ma...   |  Am looking for something nice ... Newer »
This thread is closed to new comments.