Skip

Problems with my outgoing (SMTP) mail server with Outlook 2007.
February 24, 2008 1:56 PM   Subscribe

Problems with my outgoing (SMTP) mail server with Outlook 2007.

For some reason I was able to set up Outlook 2007 at my office just fine, but I can't get it to work at home. Incoming (POP3) is fine at the office and at home, but I can't get outgoing (SMTP) to work at all from home. I have checked and all the account settings are the exact same as far as I can tell. Really trying to work this but feeling lost. As a bonus boner, my inbox at work doesn't contain all the same received emails as my inbox at home. I'm going nuts here.

Home Settings: (Same as work settings AFAIK)

Your Name Joe J. Doe
E-mail Address joe@domain.com
Account Type POP3
Incoming Mail Server mail.domain.com
Outgoing Mail Server(SMTP) mail.domain.com
User Name joe@domain.com
Password 1234
Remember Password CHECKED
Require Login with SPA UNCHECKED
Mail Account joe@domain.com
Organization BLANK
Reply E-Mail BLANK
Outgoing SMTP Req. Auth. CHECKED
Use same setting as my… CHECKED
Connect using my LAN CHECKED
Incoming Server 110
Outgoing (SMTP) 25
Use the following type… None
Leave a copy of messages… CHECKED

Error Message when testing settings:
Send test e-mail message: Outlook cannot connect to your outgoing (SMTP) e-mail server. If you continue to receive this message, contact your server administrator or Internet service provider (ISP).

This would seem to be an issue with my ISP, but I can login fine at work with the same settings.

I'll be around checking today.

God bless your little hearts.
posted by Mr_Crazyhorse to Computers & Internet (17 answers total)
 
For some reason I was able to set up Outlook 2007 at my office just fine, but I can't get it to work at home.

This is because at work you rely on your ISPs smtp server to send out your mail. So lets say your business is on AT&T but your home connection is on Comcast. You will not be able to connect.

Now your home or business smtp might have some settings for outside of network use. You'll have to contact them or google for the right settings.
posted by damn dirty ape at 2:03 PM on February 24, 2008


Your ISP typically will block outgoing port tcp/25. You can try alternative mail ports, such as tcp/465 (this is SMTP with SSL, so make sure your SSL is turned on) and tcp/587, the mail submission port.

Note that your office may also block tcp/25 for relaying if the connection isn't encrypted, so you can try turning on TLS on tcp/25 to see if that helps. But, most likely, what you're seeing is your ISP trying to block off spambots by prohibiting tcp/25 to anything other than their own mail server.
posted by chengjih at 2:15 PM on February 24, 2008


To test chengjlh's theory, try this - from a command prompt, try to telnet to your mail server on port 25. For example:

telnet mail.domain.com 25
Trying IP_address_of_server...
Connected to mail.domain.com.
Escape character is '^]'.
220 mail.domain.com ESMTP Sendmail 8.13.1/8.13.1; Sun, 24 Feb 2008 17:47:24 -0500

This assumes that your mail server uses sendmail, but I would think that the basics would be the same. I get the 220 response from a sendmail and a qmail server. I don't have an Exchange or Postfix server to test with.

If you don't get the 220 response, you're not connecting to the SMTP port on mail.domain.com. This could mean something on your local network is blocking the port, but generally, it's your ISP blocking port 25 unless you're connecting directly to their mail server.
posted by ralan at 3:00 PM on February 24, 2008


Ask your IT department if they have smtp over SSL set up, that sends on port 465 and is generally not filtered by ISPs.

Ideally all mail communication would be over SSL, but i'm not your IT guy. :)
posted by jbroome at 3:13 PM on February 24, 2008


I saw this on re-read:

"As a bonus boner, my inbox at work doesn't contain all the same received emails as my inbox at home".

IMAP would fix that. The mail would live on the server instead of being downloaded to either your home or work client. You could access it from either machine and see the same messages each place.

Again, IANYITG.
posted by jbroome at 3:16 PM on February 24, 2008


just to clarify, I work in a small professional office and we use regular business DSL. sorry for not making that clear.

I am unable to telnet from the CMD prompt.
posted by Mr_Crazyhorse at 3:20 PM on February 24, 2008


I'm using AT&T broadband at home btw.
posted by Mr_Crazyhorse at 3:21 PM on February 24, 2008


Port 465/SSL is not working.

any advice on how to get telnet access from the cmd prompt would be appreciated.
posted by Mr_Crazyhorse at 3:25 PM on February 24, 2008


I am unable to telnet from the CMD prompt.

Does that mean you can't get to the command prompt, or that when you try to telnet from the command prompt, you don't get the 220 response - you get an error message?

If the former, what version of Windows? If the latter, what is the error message?

Also, most "business" class DSL packages don't block any ports, while a lot of residential DSL/Cable packages do, and port 25 is a common one to block.
posted by ralan at 3:44 PM on February 24, 2008


Vista Ultimate

"'telnet' is not recognized as an internal or external command, operable program or batch file"
posted by Mr_Crazyhorse at 3:58 PM on February 24, 2008


I don't use Vista, but I've heard from coworkers who do that this a "feature" in Vista. Here are my notes on how to correct, I'm pretty sure this is what works:

Go to Control Panel.
Go to Programs.
Go to Program and Features.
Click Turn Windows Feature on or off.
Check the telnet client.

I don't know if this requires a restart, or if telnet will start working immediately.
posted by ralan at 4:04 PM on February 24, 2008


Hmm. The first thing I should have suggested was, talk to your IT guy on how to send email using Outlook from home. Really, a bunch of people on the Internet don't really know how the network is set up. In the worst case, your IT guy will get an AskMeFi account and post a question on how to set up his firewall to allow this behavior.

TCP/465 typically is not blocked by the ISP. Possibly, given your description of the small business setup, your firewall is not forwarding TCP/465 to your mail server. This assumes your mail server is located in your office. If not, then check out the documentation at the hosting service.

Note that TCP/465 is, as said, SMTP over SSL. This means that you must have SSL turned on for that connection, or else the connection attempt will fail. This is SSL, not TLS (which is also encrypted, but which starts at a different point in the connection). Make sure those options are correct.

For the test with telnet mentioned above, try the following: open up a command prompt (Start... Run... Then type "cmd" into the Run box.) You should have a DOS box at this point. Type "telnet mail.domain.com 25" (or whichever port you're testing). Windows telnet sucks, and I don't remember exactly how it looks, but you may get some sort of text like "trying..." and maybe the DOS box will clear the text and go blank while it tries. If you get the blank box, or just "trying..." without any other sort of response, then the connection is being blocked, either by the ISP or because your firewall isn't configured to allow that traffic. If you do get some sort of response, then the connection is going through. In this case, then you have some configuration issue with how your Outlook is authenticating, etc., but you probably do have a good network connection. Oh, this applies to XP. I don't know how the Vista telnet client behaves, but you should basically get some sort of response if the connection is working, and no response if the connection is being blocked somehow.
posted by chengjih at 4:07 PM on February 24, 2008


if you haven't yet, try port 587 for your smtp port (mentioned earlier by chenghjjh), it's the alt. submit port for non-ssl smtp (for ssl-based you'd want 465), which is probably what you are using on a pop3/smtp account.

it's just about guaranteed that you can't send on port 25 from consumer dsl/cable these days; anything else is the norm. (for folks looking for providers that DO let you send on 25 -- DSLExtreme does, but it's not on by default).

ideally you can ask your mail provider or IT admin what settings you should be using and they can let you know exactly what you need to do.
posted by fishfucker at 4:10 PM on February 24, 2008


Some ISPs are polite enough to put their customers in charge of their own filtering policy to some extent. If your ISP gives you a web page that lets you manage your account, you may be lucky enough to find a checkbox there that lets you enable or disable outgoing connections on port 25.

But in general, the simplest thing is, when you're at home, use your own ISP's SMTP server for outgoing mails instead of your work's one. It doesn't normally matter which SMTP server is the first port of call for your outgoing mails.
posted by flabdablet at 5:06 PM on February 24, 2008


C:\Users\Shmoe>telnet mail.domain.com 25
Connecting to mail.domain.com...Could not open connection to the host, on port 25: connect failed.

Guess I gotta call my ISP.

Thanks for the help you guys. and/or gals.
posted by Mr_Crazyhorse at 5:21 PM on February 24, 2008


Lemme put this another way. Before you go doing anything hard, try simply changing the outgoing mail server on the work email account in Outlook on your home box from mail.domain.com to smtp.yourisp.com or mail.yourisp.com or whatever your ISP says to use for your own ISP-provided mail account.

You will probably also want to turn off Outgoing SMTP Req. Auth; it's pretty rare for an ISP to require its own customers to authenticate on its own SMTP server.

If this is in fact a laptop you're trying to set up, and you use it both at home and at work, set up an additional mail account called something like "Work mail from home". This would start out as a complete clone of your "Work mail" account, except for the SMTP settings I just mentioned above. Next, change the incoming mail server from mail.domain.com to localhost, and turn off all the options that make the account automatically check for mail. These last steps will stop "Work mail from home" and "Work mail" fighting each other over who is supposed to be responsible for collecting mail from mail.domain.com via POP3.

When you want to send a mail from home, just use the dropdown menu in the From: box to change your outgoing account from "Joe Doe (Work mail)" to "Joe Doe (Work mail from home)". Because all the personal stuff is cloned, this will make no difference to how your mail looks at the far end, except that it will have been sent via your own ISP's SMTP server instead of failing to get sent via your work's SMTP server.

I've used this kind of trick on staff laptops at school for staff who have cranky ISP's, and it works. The only downside (or was it an upside?) was that because the mails weren't being handled by the Education Department's idiot EduMail SMTP server, they didn't get automatically tagged with the Education Department's idiot disclaimer.
posted by flabdablet at 1:24 AM on February 25, 2008


What Flabdablet says is reasonable, though with a couple of caveats:

1) Your company's IT policy may require email to be routed through servers it controls, rather than the ISP's servers. Check with your IT department, who may also show you how to properly connect to the mail server from home. As noted earlier, your first step should be to check with your IT department, as this may be a solved scenario. DO NOT BYPASS YOUR IT DEPARTMENT. If I were them, I would smack you if you were deliberately avoiding me.

2) You may run into antispam filters because your email claims to be from "joe@domain.com" but instead appears to originate from "mail.yourISP.com". Some antispam filters, say working with SPF or other similar tests, may mark this as spam as "domain.com" email isn't supposed to originate from "mail.yourISP.com". Note that this isn't necessarily restricted to your company's mail server, but may also apply to third parties, e.g., you send email to Yahoo using your ISP, and Yahoo marks your email as spam because it fails the SPF test.
posted by chengjih at 6:42 AM on February 25, 2008


« Older Thunderbird is messing up my o...   |  Palm Centro GSM Unlocked: how ... Newer »
This thread is closed to new comments.


Post