Join 3,555 readers in helping fund MetaFilter (Hide)


Will someone marry my keyboard?
January 23, 2008 3:29 AM   Subscribe

I've just bought a Microsoft Wireless Entertainment Keyboard 7000, which comes with the matching mouse (8000). It works great with my Windows XP computer, as long as the computer is on. Once I switch the computer off and attempt to restart, the Bluetooth connection is lost and the computer won't start, citing the lack of a keyboard as the reason. Only by repeatedly fiddling and resynching can I get the computer started up. Can anyone suggest how I bond these three devices in permanent holy matrimony?
posted by skylar to Computers & Internet (15 answers total)
 
Are you using the included Microsoft mini Bluetooth transceiver or are you going through pre-installed Bluetooth hardware? I am guessing that it is this transceiver that tells your PC that a keyboard is in play. And you are running SP2 on that machine, yes?
posted by B(oYo)BIES at 3:48 AM on January 23, 2008


Leave a keyboard attached, but don't use it.
posted by Steven C. Den Beste at 4:13 AM on January 23, 2008


It is the included Microsoft Bluetooth USB device. SP2 on Windows XP, yes. Though I do notice that the keyboard and mouse is "certified for Vista" - could that be a problem?
posted by skylar at 4:15 AM on January 23, 2008


Hi Steven - thanks for your suggestion - I think this would work, though obviously it's ungainly, and this is a living-room PC so ideally I'd love to keep things neat and tidy.
posted by skylar at 4:16 AM on January 23, 2008


The link you give shows certified for Vista. I read that they included an insert in the packaging about an updated driver. I guess there should be a piece of paper included with a URL to this download. This may be old information, but did you see anything like that?

Also, lets hear more about your setup, motherboard in particular.
posted by B(oYo)BIES at 4:35 AM on January 23, 2008


When does the computer complain about the keyboard? Is this just a "no keyboard detected - press f1 to continue" that the system is balking at? You might be able to disable that error in the bios, if that's what's causing the problem. I can't think of any other reason why the computer would complain about it.
posted by yeoz at 4:52 AM on January 23, 2008


Now I am starting to confuse what you are saying, yes it is Vista certified, but will work just as well on XP Sp2.

Check this article.

Make sure this software is installed properly.

Title says Logitech, but the 'Applies to' says 7000. - This is crappy. No safe mode or getting back into bios without a USB/PS2 keyboard attached if you follow these instructions.

All else fails, you get one free contact with MS on this one. Give it a shot if you are running out of luck.
posted by B(oYo)BIES at 4:53 AM on January 23, 2008


Another - Looks like your gonna have to make a BIOS change or attach a USB/PS2 keyboard.

You said this was a living-room setup? May I suggest something easy to hide?
posted by B(oYo)BIES at 4:57 AM on January 23, 2008


Nthing the BIOS suggestion. You're looking for something like "Halt on keyboard error", which you want to disable.
posted by krisjohn at 5:11 AM on January 23, 2008


Might be an answer, not sure, but check the bios. We have a server at work that wouldn't start if no keyboard was plugged in. It would halt with that dumb- no keyboard, press F1 to resume message. After sux months of being sick of this we turned the Halt on Errors swich in the bios to off.
posted by mattoxic at 5:40 AM on January 23, 2008


sux months? Sounds like a kiwi. I meant sex months.
posted by mattoxic at 5:40 AM on January 23, 2008


Odd, that problem doesn't happen with my Logitech wireless keyboards, either in Windows or Linux. The hardware receiver should appear to the motherboard as a keyboard.
posted by Goofyy at 6:25 AM on January 23, 2008


Thanks for all these great suggestions. The software is all installed correctly. Yes, the complaint is a "no keyboard detected - press F1" message. I think disabling it in the BIOS could be the way forward. I'll keep you informed!
posted by skylar at 6:46 AM on January 23, 2008


You may also want to play around with "legacy usb" support in the BIOS if disabling the nag message doesn't work.
posted by ijoyner at 7:39 AM on January 23, 2008


I was going to say what Steven C. Den Beste said.
posted by CautionToTheWind at 9:03 AM on January 23, 2008


« Older Best clothing for traveling in...   |  After watching BBC Horizon las... Newer »
This thread is closed to new comments.