Help me open an Apple Mail attachment on my Windows PC.
January 7, 2008 11:16 AM   Subscribe

Help me open an Apple Mail attachment on my Windows PC.

OK, a bunch of you are going to think that this has been answered before, but to the best of my ability I could not find a pointer to this exact problem.

I have a super important E-mail attachment which I received from a Apple user who used Apple Mail. The attachment arrived in my gmail as "noname" when really it should have been "proposal.doc". I've tried opening this attachment both on a Mac and a PC and both just show it as:

Content-Transfer-Encoding: base64
Content-Type: application/applefile;
Content-Disposition: attachment;


Content-Transfer-Encoding: base64
Content-Type: application/octet-stream;
Content-Disposition: attachment;



Now, I've tried a bunch of stuff before resorting to askmefi. I've tried saving the file locally and renaming it. I've tried stripping the first part of the encoding (the Windows friendly fix thing, but that still didn't work and that wasn't the problem in the first place because I couldn't the file on a Mac either). I just don't know what else to try, but I'm desperate because without this attachment I lose a full day of productivity.
posted by analogue to Computers & Internet (6 answers total)
Can this person resend the attachment? There is a setting in Entourage (the MS equivalent of Outlook on the Mac) for how attachments should be encoded, with an option for Windows.

It appears to be base64 encoded. There is a command line utility on GNU/Linux (and Cygwin) to decode base64 called, oddly enough, 'base64'.
posted by kableh at 11:27 AM on January 7, 2008

Can you save it locally and try importing it into Google docs, or similar?
posted by csimpkins at 11:29 AM on January 7, 2008

Ask your friend to resend the file with Apple Mail, using these tips.
posted by Blazecock Pileon at 11:30 AM on January 7, 2008

Apple Mail has "a send Windows friendly attachments" as a tick box the user should have ticked when attaching the file. I've found I don't need to tick the box when sending it to 99.9% of Windows users I send stuff to. It is possible that the person's ISP and its mailer encoding the file weirdly and Gmail is not able to decode properly.

If the person can't resend it to you, then you could try to decode the base64 jibbersih with someting found here.
posted by birdherder at 11:35 AM on January 7, 2008

Try this: save the attachment to disk, rename the file to end in .uue and try opening it with WinZip.
posted by Arthur Dent at 11:42 AM on January 7, 2008 [2 favorites]

Good ol' Arthur Dent! That did the trick!! However, I still needed to strip the first of the two encoding things off before it worked. Thank you so much!
posted by analogue at 12:03 PM on January 7, 2008

« Older I have recently acquired an ol...   |  I am being impersonated and mi... Newer »
This thread is closed to new comments.