Join 3,572 readers in helping fund MetaFilter (Hide)


Is Fedora this bad?
October 22, 2007 5:24 PM   Subscribe

I've upgraded to Ubuntu 7.10, and now I seem to be having problems with both my wireless and graphics card. Any help would be greatly appreciated.

So I upgraded to Gutsy Gibbon last Friday night, and everything went smashingly -- until I rebooted for the first time Sunday morning. At that point (and ever since), I've been having problems with my wireless (using ndiswrapper) and video (Nvidia). To wit:

When I boot, the first symptom that something is awry is an 800x600 screen saying that Ubuntu's running in low-graphics mode. I'm given the option to Configure or Cancel, but configuring doesn't seem to do a dang thing -- I can pick the nv or nvidia drivers, but the test always fails and none of the changes I make seem to stick. So I click "Continue." The machine continues to boot, and I get the same message about 20 seconds later, click Continue. This goes on about three or four more times, at which I'm finally given an "X Server could not be started" error, the details of which have to do with failsafeXServer. It kicks me back to the CLI.

At that point, I do a sudo dpkg-reconfigure xserver-xorg and plow through all the prompts (selecting the default nv driver). Once it's done (at which point I get a warning about overwriting a previous custom configuration file), I can startx, and yay, I'm at my desktop.

At this point, however, I still have no wireless. A ping results in a "network not reachable" error. I do a dhclient, and then voila, I'm connected, and all seems right the world -- except that I can't seem to perform any administrative-type tasks (from the desktop), as I get an error "Can not run /usr/bin/whatever as user root. Unable to copy the user's Xauthorization file."

I've searched the Ubuntu forums (and even posted a question of my own), but have had no luck trying to resolve this problem. Making things just a hair more frustrating is the fact that even once I get into GNOME, I have no mouse cursor -- the mouse works, but I have to guess where it is (or draw a trail and figure it out).

Sorry for the extended length, but I'm pretty sure these are all semi-related, and with my luck it's something stupid simple like a read-only filesystem or something.
posted by Doofus Magoo to Computers & Internet (28 answers total) 3 users marked this as a favorite
 
Definitely try their IRC channel (#ubuntu) on Freenode.

For the wireless, I'd first make sure you have the original Windows wireless drivers available. Then just clear out the ndiswrapper drivers, and reinstall them -- I believe they upgraded to a newer version, so you're most likely feeling those changes. It should be a simple matter of:
sudo ndiswrapper -l
to list them. To remove them:
sudo ndiswrapper -r (name).

If that fails, then ping the IRC channel and just keep trying until you find a solution. Also try the ndiswrapper website -- it links you to their forum.
posted by spiderskull at 5:35 PM on October 22, 2007


Speaking of read-only, have you tried running off of an Ubuntu boot CD? If that works, it indicates something went wrong post install and that a simple reinstall will fix it.
posted by TeatimeGrommit at 5:37 PM on October 22, 2007


I'm sorry I can't offer any real help, but I can tell you that my attempted upgrade from Feisty went horribly awry. I ended up backing up my data and doing a clean install. Apart from some confusion with my video driver*everything has been working pretty well.

*don't use the restricted ATI driver, no good can come from it
posted by jjb at 5:37 PM on October 22, 2007


I don't trust dist-upgrade one bit (at least not to cross major version boundaries.) In your shoes, I'd re-install (after backing up everything somewhere that's not the same hard-drive I'll be doing the install on.)

Sorry not to have anything more specific. But if you email me the last few hundred lines of /var/log/Xorg.0.log, I'll tell you if anything jumps out at me (email in profile.)
posted by Zed_Lopez at 5:42 PM on October 22, 2007


Thanks for the IRC suggestion -- I tried that Sunday, posted the question three times in a two-hour span, and got no responses (it looked like they were swamped). Perhaps I'll try again a bit later if a reinstall doesn't do the trick.

However, if I'm going to go the reinstall route (which would frankly piss me off), the semi-facetious question in my post title stands -- would I be any better off going with Fedora when it comes to wireless/Nvidia support? I imagine not, but it never hurts to ask.
posted by Doofus Magoo at 5:44 PM on October 22, 2007


Thanks Zed -- email's on the way in about two minutes.
posted by Doofus Magoo at 5:45 PM on October 22, 2007


What kind of wireless card is it, and are you sure you need ndiswrapper? Late Feisty updates and now Gutsy have enabled me to use "native" drivers with my RA61-architecture card, but network-manager does not like it at all (even sometimes hangs on startup). I have to uninstall network-manager and any panel plugins and specify my network in /etc/network/interfaces ... but then it works every time.
posted by zachxman at 5:46 PM on October 22, 2007


It's likely that the nvidia and wireless support in Gutsy are just fine of themselves (given that they work after you do the futzing you describe); it's just that something's insane about your state of your system right now.

Last time I did anything with Fedora, a couple of years ago, I also thoroughly hosed a system trying to upgrade to a new major version. It's a hard problem in general; I'd be surprised if any distro claimed flawless revision upgrades. (But my experience with anything that isn't Ubuntu or Debian is outdated by now.)
posted by Zed_Lopez at 5:53 PM on October 22, 2007


I'm not positive I need ndiswrapper, although I'm pretty sure I did under 6.04/6.10. I believe the card is some off-brand from Newegg (Rosewill?) with a Marvell (?) chipset that wasn't specifically on the list of ndiswrapper-supported drivers, but was the same as a card that was on the list. If you need more information than that, please let me know how to do it. I'm more than capable of Googling, but doing anything without a mouse pointer on this computer is positively painful, so I'm more or less just staying in Firefoxing and F5ing.
posted by Doofus Magoo at 5:56 PM on October 22, 2007


This probably won't help directly, but I know more people who have had wireless LAN issues with Ubuntu than I do with Fedora. One co-worker moved his laptop from Ubuntu to Fedora, and all of his wireless issues went away. He was even using an old school Cisco Aironet card....
posted by jeversol at 6:05 PM on October 22, 2007


try booting off the live cd and see what happens, that should tell you whether it is something with gutsy or just a borked upgrade...

what does /var/log/Xorg.0.log say?

for what it's worth i've never had a dist-upgrade lead to anything other than a clean reinstall...

i actually just upgraded to gutsy with nvidia and everything seems to be working (i.e. compiz eye candy) except that 'bzflag' is unplayable... which all told is a good thing i think.

i'd say gutsy had less problems getting to work than feisty was at least on my laptop...
posted by geos at 6:35 PM on October 22, 2007


A pointer: Some people have problems with kernels that try to support hardware but do it badly or in a way your system isn't expecting. You may not need NDISwrapper any more. First investigate native support.

If you do need NDISwrapper because the kernel's support is useless, you may need to tell the kernel not to load a module, so NDISwrapper has pristine hardware to grab on to.
posted by cmiller at 6:54 PM on October 22, 2007


Here's a copy of xorg.0.log.
posted by Doofus Magoo at 7:00 PM on October 22, 2007


Make sure that you've got the restricted-manager and appropriate linux-restricted-modules packages installed. Check the restricted driver manager to make sure that any modules that fall under that category are loading, I had to re-enable my ATI drivers in upgrading to Gutsy. Try booting into the previous kernel from the Grub menu, see if that resolves one or both of the problems.

I've never had any issues on Ubuntu using dist-upgrade, and I've been using it since forever off of the same install. I did have problems years and years ago on Debian, but that was with a big glibc change (I think with the 2.0.x -> 2.2.x kernel) and everyone I know had an awful time with that particular upgrade.
posted by togdon at 7:00 PM on October 22, 2007


Based on what I'm hearing so far, it kind of sounds like (a) I need a reinstall; and (b) I should never in the future use any kind of automatic distro upgrade tool. :)

Tomorrow I'll probably give Gutsy one last shot on a clean install and see if it works a little better based on a fresh install, although the wireless problem is really the least severe of the three problems, as it's a five-second workaround until I get it fixed. The video drivers are a much bigger problem, as they make booting up the computer (literally) a twenty-minute ordeal while I go through four or five rounds of "Hey! I'm in low-graphics mode" "I know, shut up." And not having a mouse cursor makes the computer nearly unusable.

In any event -- thanks again for all who have helped so far, especially those of you who've volunteered to take a look at my configuration file. Hopefully I'll be in a better frame of mind in the morning and able to tackle this anew.
posted by Doofus Magoo at 7:08 PM on October 22, 2007


Can't say much except I feel your pain. I upgraded to Gutsy, found out afterwards on the forums that unless one's a developer one shouldn't upgrade until a few months after the distribution's release, and you should do a clean install. My system's wonky but I haven't the patience to try a clean install of Feisty after spending eight hours messing with Gutsy.
posted by schroedinger at 7:17 PM on October 22, 2007


Just checked out restricted-manager and linux-restricted-modules -- restricted-manager was up-to-date and linux-restricted-modules downloaded an update; that seemed to have fixed my mouse problems (yay!), but the "low-graphics" cycle of dialog boxes on startup still exists, as does the need to manually execute dhclient to get the network connection.
posted by Doofus Magoo at 7:22 PM on October 22, 2007


When I upgraded to Gutsy yeasterday, I had similar problems with the restricted Nvidia drivers. I ended up using Envy to install the latest Nvidia drivers from their website, then replaced my xorg.conf file with a backup version from my last good config. Of course, I've always had nvidia issues, so *shrug*

You also might check your /etc/X11/ folder to see if you have any xorg.conf.bck or .backup files that look reasonable, and try plugging them in.
posted by chrisamiller at 7:38 PM on October 22, 2007


Another data point, for what it's worth. When I went into the restricted drivers manager (via the CLI, as I get the "unable to copy the user's Xauthorization file), the driver was not checked. I checked it, and logged out (taking me back to the CLI). At that point I noticed an error along the lines of "cannot write to /home/myname/.Xauthority."

I rebooted, went through the whole rigamarole again, and now that I'm back in GNOME, I open up the restricted driver manager (via the CLI), and see that the NVIDIA driver is "in use" (green light) but not "enabled" (check box is empty).

Anyways, just thought I'd throw those out there in case it helps. Thanks again for all the help so far -- I'm off to bed.
posted by Doofus Magoo at 7:40 PM on October 22, 2007


And no luck on Envy (but thanks for the suggestion) -- I just downloaded and ran it, let it do its thing (downloaded a whole mess of stuff), and rebooted without any (noticeable) errors, but I'm getting the same thing -- low-graphics mode and no wireless without running dhclient.
posted by Doofus Magoo at 7:59 PM on October 22, 2007


from the xorg file it looks like the 'glx' module isn't initializing. which is to say that the 'nv' driver isn't working.

i kind of think a clean install will work, but I wish I knew more... sorry.
posted by geos at 8:03 PM on October 22, 2007


As of the Xorg log you posted, it's using the nv driver, not the nvidia driver. You could try editing /etc/X11/xorg.conf to change Driver "nv" to Driver "nvidia" in section "Device".

Or you could install apt-get install nvidia-xconfig, run it, and let it totally rewrite your xorg.conf itself.

You've got a whole lot of complaints of not using given graphics modes because hsync or vrefresh is out of range. Do you have the specs for your monitor? When you do your dpkg-reconfigure xserver-xorg, what are you entering for them? (I'd guess that it's in response to these errors that it decides it has to go into limited graphics mode.)

And, in Gnome, be sure to turn off the advanced compositing effect stuff until you have everything else sorted.

And what are the permissions on your home directory and on its .Xauthority? (and who owns .Xauthority?)
posted by Zed_Lopez at 10:12 PM on October 22, 2007


ls -l /home from the command line gives me "drwxr-xr-x"
ls -l /home/myname/.Xauthority gives me "-rw-------"

How do I turn off advanced compositing? I went into CCSM and unchecked pretty much everything.

I'm pretty sure I've already tried changing the driver from nv to nvidia in xorg.conf, but I'll give nvidia-xconfig a shot. I'll also be sure to set my refresh rates to what the manual specifies (75V x 81H) rather than blindly accepting the defaults.
posted by Doofus Magoo at 3:13 AM on October 23, 2007


sudo apt-get install nvidia-xconfig gets me the following:

Need to get 0B/55.9kB of archives.
After unpacking 188kB of additional disk space will be used.
(Reading database ... 133439 files and directories currently installed.)
Unpacking nvidia-xconfig (from .../nvidia-xconfig_1.0+20070502-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/nvidia-xconfig_1.0+20070502-1_i386.deb (--unpack):
trying to overwrite `/usr/bin/nvidia-xconfig', which is also in package nvidia-glx-new
Errors were encountered while processing:
/var/cache/apt/archives/nvidia-xconfig_1.0+20070502-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

posted by Doofus Magoo at 3:20 AM on October 23, 2007


Ok, I ran dpkg-reconfigure again, and this time set the driver to 'nvidia' and the monitor refresh rates to their true values instead of what was entered as the default. Once I exited the config, I verified that xorg.conf contained the new correct values (nvidia, 75, 81) and rebooted. On reboot, I got the same low-graphics mode. On pulling up xorg.conf, all the new information that had been put in had been replaced with a bunch of failsafe values.
posted by Doofus Magoo at 3:41 AM on October 23, 2007


I did the dist-upgrade to the developmental version right before the "official" release. Worked fine, although I had to make use of the restricted driver manager for my nvidia / wireless. Now, it seems to be hanging in there just fine....
posted by ph00dz at 6:46 AM on October 23, 2007


Hmph. This bulletproof X stuff is a big departure from previous releases, and I don't know anything about it.

Yeah, nvidia-xconfig comes with nvidia-glx-new, so if you have that installed you don't need nvidia-xconfig.

do the dpkg-reconfigure again, then try:

sudo nvidia-glx-config enable
sudo nvidia-xconfig

How do I turn off advanced compositing?

System -> Preferences -> Appearance -> Visual Effects. Check 'None.'

Then try sudo /etc/init.d/gdm restart to just restart X instead of rebooting, and see what happens.
posted by Zed_Lopez at 12:15 PM on October 23, 2007


Gutsy's version of the nv driver (the default, free software driver for Nvidia cards) has caused me a lot of trouble. On two separate systems it has ended up setting the resolution to 800x600, where with Feisty it worked fine.

If you have the same problem, a clean install won't help - you'll just end up with the same broken "nv" driver.

The solution is to use Nvidia's closed driver, as noted above - but installation is pretty easy:

sudo apt-get install nvidia-glx
sudo /etc/init.d/gdm restart

You shouldn't have to edit anything or answer any questions. Though you may want to add 'Option "NoLogo" "True"' to /etc/X11/xorg.conf, in the same section as the nvidia driver, manually.
posted by yath at 12:24 AM on October 24, 2007


« Older What is the drumline/trumpets ...   |  Speaking French Canadian Frenc... Newer »
This thread is closed to new comments.