Join 3,562 readers in helping fund MetaFilter (Hide)


How do I share files and folders over a home network?
May 3, 2007 4:26 AM   Subscribe

I have a small network consisting of a couple of PC's and a router/firewall/ADSL modem. On one PC, files that are placed in a folder which is shared with everyone else aren't accessible by everyone else. What am I doing wrong?

I have a Netgear DG834G v3 router/firewall/ADSL modem which has three computers connected to it. Two of them wirelessly with dynamic IP addresses and one laptop which is connected directly into the box and assigned a fixed IP. All three machines are part of a workgroup called "Home". All three run Windows XP SP2 and all the latest patches.

The one with the fixed IP we shall call "server". It runs uTorrent. uTorrent downloads content and places it into a folder called "Completed Downloads" which is shared using Simple file sharing to be accessible to all.

The torrents that are downloaded tend to come as a folder, with other files in them. The other two machines on the network can see those folders in the top level. However when they go into any of these folders to get at the actual content, then they get permission denied.

So I turned off simple file sharing on the server and set up permissions so that "Everyone" had full control to the folder. I also made sure that "Inherit from parent" was selected.

Now the other two can see the folder and see the contents of the folder, but when they try to move (or even copy) the contents to their own hard-drive, then they get a permission denied message.

So I then went into the permissions on the folder again and selected "replace permission entries on child objects" and lo and behold, it worked and the other two machines were able to copy and move the files from the laptop! However this only lasted for the content currently there - as soon as new items were placed into that folder they could not be copied or moved.

My goal is simple, I want content to be downloaded on the server to this folder and anyone else on the network to be able to take that content from there and put it on their own machine.

Does anyone have any suggestions on what I can do?
posted by mr_silver to Computers & Internet (6 answers total) 2 users marked this as a favorite
 
I had this same problem, I think I setup a 'Guest' account and gave it full read permissions. The guest account should be in windows by default, so when you go to add a user to the permissions table just type in guest and it should automatically assign settings.
posted by chrisbucks at 6:07 AM on May 3, 2007


there's a check box in the permissions tab that should set the same properties for sub-folders as well. Make sure that's checked. I'm not on an XP box right now, or I'd give you the actual dialog boxes. Maybe somebody else can do that.
posted by cosmicbandito at 6:39 AM on May 3, 2007


Looks like I misinterpreted your question. never mind.
posted by cosmicbandito at 6:41 AM on May 3, 2007


I could never get NON-simple file sharing to work. I just reverted to simple file sharing and it just uses the guest account with no password. Its not the most secure, and you cant access shares that end in $, but you already have security set up for your network right (WPA on the wireless, etc).
On my linux box that has Samba shares, I actually have to create accounts for the other LAN users because the authentication on that actually works (go figure, its not M$). I keep the same user name and password across most of my computers, so this is rarely an issue, but if I have a guest, I must create a user account for them (which is darned easy with webmin)
posted by ijoyner at 9:00 AM on May 3, 2007


I've found that the "Everyone" group doesnt work like this. I believe "Everyone" only works on machines outside a domain or a workgroup, like basic home networking. When in a workgroup or domain you need to specify a user, like guest as mentioned above.

I'm not sure if this is an MS bug or some kind of built-in security limitation, but I remember having similiar experiences with the Everyone group before.

FWIW, this can happen if you convert a disk from fat to NTFS.
posted by damn dirty ape at 12:05 PM on May 3, 2007


I've set this up here at work. I think your problem has to do with how Windows authenticates users. There are two ways.

Way 1, which is most likely what you have, is computer-by-computer user based authentication. To get this to work, all your computers must have identical user names and passwords. Once this is the case, permissions you set on one computer will basically apply to those same users on the other network computers. The problem you are probably having is that "Everyone" on your host computer covers only local users, but you are authenticating a user on a remote computer that doesn't match a local user. I think accounts that don't match get mapped to "Guest". So chrisbuck's solution of setting permissions on the "Guest" account should work, for this reason. And be careful with the user names - there are short and long user names. To be safe, make both agree. You can mess with them via the Control Panel >> Administrative Tools >> Computer Management >> Local Users and Groups.

Way 2 is to have a domain server. I have no clue how this works, but with some research you could probably set this up for yourself.
posted by noble_rot at 4:02 PM on May 3, 2007


« Older I know someone's date of birth...   |  How can I copy an existing Act... Newer »
This thread is closed to new comments.