Join 3,494 readers in helping fund MetaFilter (Hide)


Windows is usually so good at deleting stuff, even the things you want.
April 24, 2007 8:00 PM   Subscribe

So for some unknown reason (probably I hit enter when I wasn't looking), Windows has decided to plunk down a 'Windows Service Pack Setup' file, update.exe on my external, USB, media HDD. I don't want it there. If it were as simple as right click-delete i wouldn't be here, and neither would the file.

So its in a folder with a sub folder and its labeled with a really cool name, something like E:\54435fdg6rergt5\update\update.exe (not actually the folder name).
There were a few other similar folders with it, but in my anger with windows at touching my drive (mine, dont touch, got that MS?) I deleted them. They all went straight to the recycle bin (which I've siince emptied). Since I like my computer pristine, I've tried every thing I can think of to delete, I tried shutting down explorer and deleting, but it did nothing (perhaps because the target was on an external USB drive?). I tried the program MoveOnBoot, but it gave me an error message, I tried a Linux Live boot CD, but it would only allow read-access of my HD, so I tried my copy of Ultimate Boot CD, but at this point it was just shots in the dark, and any utility that looked helpful (like a DOS file explorer) didnt recognize my laptop's chipset. Uhm...so, now what? How do i get rid of it?
posted by baserunner73 to Computers & Internet (13 answers total) 1 user marked this as a favorite
 
Unlocker?

for some reason i can't get the html to work, but it's

http://ccollomb.free.fr/unlocker/
posted by sharkfu at 8:11 PM on April 24, 2007


You haven't mentioned which OS you are using, but given there are service pack shenanigans involved, I'm gonna guess you are using XP

Well since you seem to have tried everything else - you might want to consider the nuclear option - deleting and recreating the recycle bin folder.

Here's
a MS Knowledge Base article that might help - it doesn't state it's applicable for XP, but the listed commands will work in XP as well.
posted by your mildly obsessive average geek at 8:45 PM on April 24, 2007


You say you tried "everything", but you didn't mention whether you tried any of it while being logged in as administrator.

If you're using a non-administrator account, the permission codes on the file may prevent you from deleting it.

By the way, for experimentation purposes take it back out of the recycle bin, and with the shift key held down right-click it and select "delete" from the popup menu. That means "Delete it immediately, don't put it in the recycle bin". Either it succeeds, or it tells you why you aren't permitted to remove it.

Also, after it's back out of the recycle bin, right-click on it, select "properties", and select the "security" button. That will tell you a lot about who owns the file and what permissions are set on it.

If you're logged in as an administrator, you'll have the ability to change the permissions even if it's a system file. For example, if no one has "full control" or "write" then no one will be able to delete it. Turning "full control" on should make it possible to remove it.
posted by Steven C. Den Beste at 9:02 PM on April 24, 2007


By the way, the most likely reason you have that thing is because you've got "automatic update" enabled.

"Automatic update" is a plague. To get rid of it, go to the control panel and run the "security center".
posted by Steven C. Den Beste at 9:04 PM on April 24, 2007


did you try rebooting in safe-mode and then deleting?
posted by T.D. Strange at 10:29 PM on April 24, 2007


I tried the unlocker: no help. when I try to delete it using Unlocker's tool it says 'no locking handle found.' It then gives me the oprtion do delete it at next reboot, which I selected, then rebooted, and still nothing. File's still there, strong as ever.
YMOAG: the file is nenver making it to the recycle bin, anytime i attempt to do anything to the file (move it, rename it, delete it, change fast indexing, anything!) I get: 'Cannot delete update, access is denied. make sure the disk is not full or write protected.' in a windows pop up error box. BTW, im using Windows XP MCE with all SP and security updates, which leads me to the automatic update thing. I have it set only to notify me, never act on its own, and i never do express install, always custom, I hate how it tries to install WGA and IE7 and WMP11 .
And finally, my account is an administrator, this is my home/school computer, so theres only one user, me on an admin account.
Ugh, I've always kept my installs SOOO CLEAN!
posted by baserunner73 at 11:31 PM on April 24, 2007


did you try a commandline delete?
posted by juv3nal at 1:33 AM on April 25, 2007


Probably you'll need to change the permissions on the file before you'll be permitted to delete it. It is possible to set the permissions on a file so that even an administrator cannot delete it, but it isn't possible to prevent the permissions to be changed, and then the file deleted afterwards.
posted by Steven C. Den Beste at 1:50 AM on April 25, 2007


Download Cygwin, then command line your way to the file directory, and type rm 'name of file', using the quotes around the name of the file. If that doesn't delete it I'll be very surprised.
posted by Happy Dave at 2:03 AM on April 25, 2007


Check the file permissions as Steven suggested, clear any read only permissions, then try deleting it from safe mode command line.
posted by Mr. Gunn at 6:11 AM on April 25, 2007


You can fartarse around with Windows file permissions and/or ownership until MS deigns to allow you to do what you want with your own machine, or you can use Linux. Personally I'd probably use Linux.

The live CD you want is the Trinity Rescue Kit. Once you've booted into that, use

mountallfs -g

to mount all available filesystems (the -g flag tells TRK to use NTFS-3G for any NTFS partitions, allowing full read-write access). Then find your file (if it's the only USB drive attached, and it's only got one partition, it will be under /sda1 unless your hard disk is SATA, in which case it will probably be under /sdb1):

cd /sda1
ls

(that last command is ell ess, for list sorted). If you see 54435fdg6rergt5 in the directory listing, remove it with

rm -rf 54435fdg6rergt5

(you can just type the first few characters - 544 - and hit Tab; the shell will fill in the rest of the name). Then get out of that directory, unmount all filesystems, and reboot:

cd
umountallfs
reboot

and you should be good to go.
posted by flabdablet at 7:21 AM on April 25, 2007 [1 favorite]


flabdablet, you're awesome
i am once again master of my domain!
posted by baserunner73 at 3:00 PM on April 25, 2007


I too have been annoyed by Windows deciding to unpack temp files to a folder in the root of the biggest available drive. In my case, it was a very large temp file, and the drive was connected to an old machine that only had USB1. Bloody thing took forever. But at least it cleaned up after itself.

Glad I could help.
posted by flabdablet at 5:12 PM on April 25, 2007


« Older What are some of the coolest 6...   |  [Word Filter] I have a Word do... Newer »
This thread is closed to new comments.