Skip

How can I make my Mac stop automatically connecting to my neighbors' networks?
February 29, 2004 1:57 PM   Subscribe

Stupid Mac question - I have an AirPort card, but no base station. I was just visiting my cousin for the weekend, and they have one, and they did something to my computer to get it to connect to their wireless network (they have all sorts of security on it) and now I cannot have my AirPort card turned on without it automatically connecting to my neighbors' networks. I use an ethernet cable here at home, and I have my configuration set to look for the ethernet connection before a wireless one. I am at a total loss as to what to do to tell it to not automatically connect, short of leaving the card turned off unless I'm using it (and Apple's website is no help, because they assume that you do want to use it). Any ideas?
posted by eilatan to Computers & Internet (12 answers total)
 
OS X or OS 9?

In OS X, go to the Apple Menu, to System Preferences, and choose the Network Preference. Click on the drop-down menu marked "Show" and choose "Network Port Configurations." Take the check off of the box marked "Airport." Click the Apply Now button. All done.

(Doing this from memory). In OS 9, go the the Apple Menu. You should see something there marked Airport. If so, open it. In the window that comes up, make sure the little drop-down triangle is clicked and pointing downwards. There will be a button to turn the Airport off. If you don't find such an item, look in your Utilities folder, which is inside the Applications (OS 9) folder. Alternately, you may have an Airport Control Strip item. Click and hold down on it, and it will give you the option to turn the Airport off.
posted by Mo Nickels at 2:05 PM on February 29, 2004


One more thing, to leave Airport on, but not to have it automatically connect.

In OS X, go to the Apple Menu, to System Preferences, and choose the Network Preference. Click on the drop-down menu marked "Show" and choose "Airport." Next to where it says "By default, join," click and hold down the drop-down menu. Change it from Automatic to "A Specific Network." Delete anything in the Network and Password fields. Click the Apply Now button. All done.
posted by Mo Nickels at 2:07 PM on February 29, 2004


I'm not sure I see the big problem though -- you're saying that, if you don't want to use the wireless card, you have to turn it off. Isn't this exactly what on-off switches are made for?

In other words, if you don't usually want to use the wireless card, why not leave it turned off? You can't possibly have any networking problems when it's turned entirely off, and it will save power too (especially important when running on batteries). When you do go back to your cousin's, turn it back on, and all is well.

Am I missing something?
posted by xil at 2:25 PM on February 29, 2004


OS 10.2.8.

I want to be able to use the AirPort w/o dinking around with turning it or the port on and off--I've tried disabling all those things, and it's not behaving in the same was as it was before my cousin's husband dinked with my computer.

What I used to have was my AirPort card turned on, but not actually connecting to any networks--to do that, I'd have to go to the AirPort status icon and pick the network to join--and to disconnect, I'd just turn the card off and back on again and it wouldn't reconnect. Now, I can't do that. When the card's on, it's connecting me to my neighbors' networks, and it's driving me nuts because I want to use the internet access that I pay for.

Unless the card was behaving incorrectly before and this is how it's supposed to work. In which case I'll deal with it, albeit crankily.
posted by eilatan at 2:27 PM on February 29, 2004


Then I second what Mo Nickels says above -- set it to connect to only a specific network (if you don't remember the network name, set it up the next time you're at your cousin's). If the card doesn't find that network, like when you're at home, it won't use any network at all.
posted by xil at 2:41 PM on February 29, 2004


sounds like you've got "always join" set. This is pretty common for airport cards, which is probably why your cousin set it.

and you know what? looking through my settings quickly, I'm not exactly sure how one would turn this off -- disconnecting from a network by turning your airport off, and then back on isn't really intended behavior. You could try kludging it by setting it to automatically join a network that does not exist -- or maybe automatically joining it's own network, or as most people have said, you might just turn it off.

it is a little lame that apple has a nice n easy setting for connecting automatically to a specific network (it asks you this when you first hit a specific one, in my experience) but no quick simple way to turn that feature off, but I don't think a ton of users would want to use their airport card in that manner anyways.
posted by fishfucker at 4:05 PM on February 29, 2004


Also, in the network control panel, in network port configurations the order they are placed determines the order your computer will attempt to make a network connection. If you want ethernet to be the primary attempt, drag it to the top, followed by airport. It sounds like you currently have airport at the top, probably with "join best network" selected in the airport control area.

So, like what mo said, with the join selected network, and also put it second in line, so it will try ethernet first.

I think what you're looking for is the order thing though, since I guess you want to occasionally use airport, but you would prefer ethernet if it is available. With that setting you shouldn't have to worry with the setting anymore.
posted by rhyax at 4:14 PM on February 29, 2004


I've got them in this order: ethernet, airport, internal modem. And even IF I have the ethernet cable plugged in and receiving data, the second the airport card is on, it goes looking for a connection and supersedes the ethernet connection. I even tried putting airport last and it still connected.

At this point, I'm just wondering why on earth the computer is disregarding my preference for internet connectivity when the first item on the list is present and functional (I have tested this). It has never done this before and it's rather puzzling.

Of course, it could be something as simple as turning the airport card on, making sure the ethernet cable is plugged in, and rebooting--flushing the system, although I shouldn't have to do that. This computer is sometimes quirky, though. Although not as quirky as the printer I had 15 years ago that would only print when my dad was physically in the room...
posted by eilatan at 5:34 PM on February 29, 2004


If I have the ethernet cable plugged in and receiving data, the second the airport card is on, it goes looking for a connection and supersedes the ethernet connection.

How can you tell that the wireless network is "superseding" the wired one? In other words, how did you figure out that the traffic is going over the wireless connection and not the wired one? Are you just guessing or is there actual evidence?

I would expect the wireless connection to be set up (so it can be used a moment's notice), but your network traffic should still go over the ethernet cable, as long as it is plugged in.
posted by xil at 6:12 PM on February 29, 2004


I'm sort of guessing based on the behavior of my instant messenger client. The damn thing never used to automatically go looking for and hooking me into networks--it would have the networks in the menu dropdown for my to choose if I wanted, but this is a completely new behavior on the part of my machine.

I just tested it again, by turning on the airport card and then unhooking the ethernet cable. I did lose my login for my IM client when I did that, so it does look like the computer is respecting my wishes to not use the neighbors' access, but it's still strange that it's looking for and making the connection available when it never did that before. Unless, as I said earlier, that's how it is supposed to work and it wasn't working properly before.
posted by eilatan at 6:47 PM on February 29, 2004


I'm still not sure why you want the airport card turned on but not connected to a network. And if you used to keep it on all the time and connect to a network by going to the menu item, what's the difference between going to the menu for the network and going to the same menu to turn it on?
posted by bonaldi at 6:47 PM on February 29, 2004


There's little difference.

The problem as I see it, I guess, is that the computer was doing one thing Friday and is now doing something different, and, as far as I can tell, nothing in my settings has been changed in such a way that would cause it to act in this way.
posted by eilatan at 7:42 PM on February 29, 2004


« Older Does anyone know the name of t...   |  Currently I have a 15 GB third... Newer »
This thread is closed to new comments.


Post