Join 3,424 readers in helping fund MetaFilter (Hide)


XP won't let me type in Thai.
February 18, 2004 8:57 AM   Subscribe

Internationalising email in WinXP. My wife can read emails sent to her in Thai script using Outlook on our Win XP machine, but I can't work out how to configure the machine so that she can type in Thai (using out Thai/ English keyboard) in a non-html email. Outlook help mentions configuring using Microsoft Office Tools from the program manager - but that requires using the XP discs, which we don't have as it was preinstalled by the PC manufacturer. Anyone got any ideas? I don't want to change the language of the whole O/S/ (there's a download from microsoft.com to do that) as I don't read Thai. We're by no means married to Outlook; Moz, Opera etc would be fine. We have Thai fonts.
posted by Pericles to Computers & Internet (5 answers total)
 
Have you tried typing in Thai using MS Word and then copying and pasting that into your plain text email? I just did it on a Windows XP machine with Word 2003. Here's what I did:

Go to Control Panels and select Regional and Language Settings.

Click on the Languages Tab and make sure both boxes are checked under Supplemental Language Support.

Click on the Details button and add Thai to the list of languages.

Click on the Language Bar button and turned on all the options for the Language Bar.

Click OK until the Control Panel is closed.

Launch MS Word and change the input language in the Language Bar from English to Thai.

Type in Thai and then select, copy and paste your Thai text into a new Outlook message (by default my Outlook is set to send html emails so I changed that to plain text before I pasted my text from word).

You should see the text in Thai. Send mail.

Hope that helps.
posted by inviolable at 9:41 AM on February 18, 2004


thanks inviolable, but Thai isn't on any lists - and when I check the boxes under Supplemental Language Support, it tells me to insert the CDs. Groan.
posted by Pericles at 10:00 AM on February 18, 2004


Yeah, I thought that maybe if you could read Thai that you had the Supplemental Language Support for East Asian Languages already installed.

One more thing you can try is to check for an i386 folder on your hard drive. If you have that directory, you may be able to browse to there instead of the CDs when you try adding the Supplemental Language Support.
posted by inviolable at 11:12 AM on February 18, 2004


Are you using XP Home or Professional? I think that the Home version does not have the same language support inbuilt that Pro does. We use (read and write) English, Japanese, Simplified Chinese, Korean and Thai on computers at work using XP Pro and have had no problems.
posted by dg at 3:17 PM on February 18, 2004


Here. Google is your friend.
posted by stavrosthewonderchicken at 3:53 PM on February 18, 2004


« Older I live in Washington, DC and I...   |  A coworker is trying to think ... Newer »
This thread is closed to new comments.