Join 3,442 readers in helping fund MetaFilter (Hide)


Troubleshooting Quicktime Install error
November 21, 2006 7:19 AM   Subscribe

Please help me COMPLETELY remove quicktime from my system (at least, that's what I think I need to do)

Ok, so my kids got 2 nanos from their grandmother last night. The PC they use was gifted from a friend, running XP home, and we have no XP disc.

Old version (6x) of quicktime works. I go to install the new itunes, which includes quicktime 7x, and it gets almost all the way through when it gives me this error:

Could not open key:HKEY_LOCAL_MACHINE\Software|classes\Quicktime.qt\Defaulticon. verify that you have sufficient access to that key or contact your support personnel.

I am running as admin on this machine. I find the appropropriate registry keys, and make sure I have permissions - i do.

So what is next? My gut tells me to just reformat and reinstall windows, and just be done with it, but where I don't have an XP disc....

So how can I make this wortk so my kids can use their ipods? itunes is a must, as they are not technically savvy.

My thought would be to go through the existing system and uniinstall everything quicktime, but the link in the add / remove programs doesn't work.
posted by quibx to Technology (5 answers total)
 
Ccleaner?
posted by the cuban at 7:24 AM on November 21, 2006


This similar question was solved by deleting the parent of the problematic registry key. (In this case the parent would be "Quicktime.qt.") Another possible solution is to use "Reset Permissions on all child objects" in regedit.
posted by mbrubeck at 7:47 AM on November 21, 2006


before you mess too much with your registry file, please save an original copy off to the side!
posted by j at 8:03 AM on November 21, 2006


Here is your answer. The good news is that it is quick and painless. It worked for me - I had exactly the same problem.

In short, the problem is in the registry, in the installer section (Quicktime itself and the Apple keys are fine, you can leave them alone). You should be good to go.
Take care.
posted by grahamwell at 10:49 AM on November 21, 2006


Actually that didn't work, I was unable to set the permissions with that method, but thanks. More research found this solution instead, which worked for me.
posted by quibx at 9:13 AM on November 26, 2006


« Older Anyone in the D.C./northern Vi...   |  Javascript / HTML : Let's say ... Newer »
This thread is closed to new comments.