Skip

only connect: adding a password to my router screws up my signal
October 27, 2006 4:08 PM   Subscribe

I can't figure out how to password-protect my wireless internet connection.

I'm pretty ignorant about networking, so please talk down to me. I have a Linksys Router (Wireless-B, model: BEFW1154) connected to a cable modem via an Ethernet cable. A second Ethernet cable runs from the router into my PC (Windows XP, SP2).

I typed 192.168.1.1 into my browser, set WEP to Mandatory, clicked the WEP Key Setting button and created a password.

This seemed to work: started my 2nd PC (Dell Laptop) and browsed for wireless connections. Instantly, I saw my main PC, and it had that little lock symbol by it, meaning I'd need to enter a password in order to connect with it. I did so, the machines connected, and... a message said "limited to no connectivity." Strange, because I usually get a strong signal and the two machines were just a few feet from each other (and from the router).

I turned WEP off and was instantly got an "EXCELLECT" signal. Turned it on again and got "limited or no connectivity." (And it really is "limited" since I can't use the Internet when I get that message.)

I don't get it. How is turning that security feature on affecting the signal (or making the laptop think the signal is affected)? What should I be doing? Have I totally misunderstood WEP? I just want a password on my connection.
posted by grumblebee to Computers & Internet (10 answers total) 1 user marked this as a favorite
 
I don't think there was ever a good standard for plain text wep keys, so, while you may be able to enter a password into the wireless config on the browser, it's turned into some hex code. You probably have to enter that same hex code, rather than the original password, when you connect to the network from your PC. Does the router's wireless security screen show some sort of hex code (ie A6B3D46C90AE...) after you enter and submit a password?

Also, be aware, WEP is quite hackable. Using it will keep casual appropriation of your connection, but it won't stop anyone serious.
posted by Good Brain at 4:13 PM on October 27, 2006


If the laptop is older it might not support a newer standard or have the capacity for a high-bit setting. Just try another one of the security options and see if that works (I have this problem when relatives visit with their old laptops). The laptop and the router have to agree on the setting before the password has a chance to work.
posted by _sirmissalot_ at 4:33 PM on October 27, 2006


The 'limited to no connectivity' message is nothing to do with the radio signal strength. It's talking about the IP network connectivity.

As Good Brain says, if your computer's using the wrong WEP key for encryption (which is easily done thanks to the mess that is plain text WEP passwords), it can have the strongest radio signal in the world, but everything it sends and receives at that raw level will be garbage. Therefore it can't even begin to set up IP connectivity on top of that. So that's why Windows says that your network adaptor has 'no connectivity'.

I always use hex keys now (unless I'm setting up, say, an all-Apple network). They're a pain to type in, but so much more reliable.
posted by chrismear at 4:35 PM on October 27, 2006


Good Brain's answer makes sense.

Can anyone send me to a resource where I can learn about sensible ways to protect my machines (keeping in mind my lack of experience with networking)?
posted by grumblebee at 4:50 PM on October 27, 2006


If the laptop is older it might not support a newer standard or have the capacity for a high-bit setting. Just try another one of the security options and see if that works

What other security options?
posted by grumblebee at 4:52 PM on October 27, 2006


In the properties tab of your Wireless Network Connection, there is a place to choose which kind of security - WAP, WEP, WPA-PSK. You also choose this in the router settings.
posted by _sirmissalot_ at 5:10 PM on October 27, 2006


Also, if you're going with WEP, you might have your router set to a higher bit rate than your laptop can handle. Knock it down to something low (like 64) as a test. This isn't very secure but it will keep your neighbors off of your internet.

All of the different types of security and their flavors are found in the Wireless>Wireless Security section of your router admin panel.
posted by _sirmissalot_ at 5:16 PM on October 27, 2006


(But if you have a newer laptop, just use a stronger security measure like WPA.)
posted by _sirmissalot_ at 5:18 PM on October 27, 2006


Can anyone send me to a resource where I can learn about sensible ways to protect my machines (keeping in mind my lack of experience with networking)?

This is pretty straightforward.
posted by _sirmissalot_ at 5:23 PM on October 27, 2006


Do you see your laptop listed when your logged on to you router? If so, try listing the MAC address in the MAC security feature and 'accept'.
posted by cjburton at 5:52 PM on October 29, 2006


« Older A few years ago I was diagnose...   |  After only a week or so of job... Newer »
This thread is closed to new comments.


Post