Join 3,375 readers in helping fund MetaFilter (Hide)


Why reset a router?
August 16, 2006 7:19 PM   Subscribe

Why is my Internet connection better after resetting my router?

My internet connection is through a cable modem, which is generally pretty good, but after several days--particularly if I've been doing lots of p2p downloading--web browsing gets sluggish. FireFox says at the bottom that it's "waiting for connection" longer than usual. This doesn't affect the bandwidth at all. Once a connection is made, everything pops up fine. It seems to have to do with making page requests, DNS lookups, that kind of thing. But after I restart my router (by unplugging the power), everything is much snappier.

I've got two questions. What, exactly, is happening to my router that is making it slow down after a while? Second, is there anything I can do about it short of getting a new router? And if I did buy a new one, what should I look for to see that it doesn't have the same issue?
posted by Brian James to Computers & Internet (19 answers total) 9 users marked this as a favorite
 
A few things could be at work. The simplest thing to try is to reflash your router with the latest revision of the firmware.
posted by cellphone at 7:28 PM on August 16, 2006


I'm also interested in this question as I have the same problem. FYI I have a TrendNet router.
posted by drleary at 7:45 PM on August 16, 2006


It's better because your router is hanging onto the connection table for an unreasonable amount of time. So, you probably have hundreds/thousands of unused connections that your router is still tracking, and a reboot erases them all and your router doesn't have to work as hard on each packet.

Depending on your router, you can reset the number and time to live of connections that your router will keep track of. For instance, I have a WRT54G that would normally keep track of connections for 5 days but I have that reset down to 15 minutes or so (with a 3rd party firmware) and it doesn't choke on me like it used to.
posted by Dipsomaniac at 7:47 PM on August 16, 2006 [4 favorites]


This doesn't affect the bandwidth at all. Once a connection is made, everything pops up fine. It seems to have to do with making page requests, DNS lookups, that kind of thing.

This sounds like a classic case of DNS problems. Your router may be using a name service cache that has a leak of some kind. Over time, it becomes borkified. I would follow cellphone's advice and see if there's a later version of firmware you can install.

In order to test my DNS theory, can you get it to hang on the same URL twice in a row (in a way that does not involve your browser cache)?

Is your router also a firewall?
posted by popechunk at 8:11 PM on August 16, 2006


Dipsomaniac, are you using ddwrt? If so, what is the setting that you are tweaking?
posted by |n$eCur3 at 8:20 PM on August 16, 2006


No, I'm using Thibor 15c, but the setting is on the Administration page, Management tab - I think DD-WRT has a similar layout. Look for the Established State Timeout and Max Connections fields.
posted by Dipsomaniac at 8:34 PM on August 16, 2006


This is strange. I use Thibor 15c and I have never experienced these types of issues (and I have a Vonage router behind my WRT54GS, so speed issues would definitely cause issues).

When you initially flashed the router, did you flash the NVRAM and restore factory defaults (on the Administration-Factory Defaults section)?

This clears out any existing NVRAM settings that were left over by stock Linksys, or other after-market firmware that could affect the performance of 15c.

I use BitTorrent heavily (uTorrent, I highly recommend it. Azureus used to bring my router to a screeching halt) and make sure that your established state timeout is set to 600 and max connections is 4096 (those should be the default settings in Thibor on the Management page in the Administration section, if they're not it is probably due to the NVRAM flash issue that I mentioned above).

So, short answer... use uTorrent and make sure you flash the NVRAM and restore factory settings in Thibor. That should help. One last thing, I've noticed that the web daemon on the router has/had a memory leak. As a habit, I usually reset the router through the web console, and then close the window while it reboots (and then not re-visit the console unless there's a problem).
posted by purephase at 9:31 PM on August 16, 2006


Purephase, I think the reason that you didn't have the issues is that Thibor resets the connection table to sane values when you flash the firmware. I definitely had router-freeze when I tried to use the Linksys stock firmware on a V3 and a V5. I'd run a well-connected torrent for 10 minutes and then I couldn't do anything.
posted by Dipsomaniac at 9:39 PM on August 16, 2006


My router is also a firewall, yes. It has the latest firmware. It's a Belkin F5D7321-4.

In order to test my DNS theory, can you get it to hang on the same URL twice in a row (in a way that does not involve your browser cache)?


I'll try this next time. I just reset my router tonight, which prompted me to ask the question.
posted by Brian James at 10:38 PM on August 16, 2006


Anyone know how well Apple Airport Express routers cope with this sort of thing?
posted by dance at 1:25 AM on August 17, 2006


I've NEVER seen a good Belkin product. Never. Update the firmware; if that doesn't fix the problem, buy a Linksys WRT54GL from somewhere with a good return policy and see if that helps. (note the L! The G and GS aren't Linux-based anymore and are more likely to give you trouble.) If the stock firmware doesn't work, the DD-WRT firmware should, but I'd try that last... and I don't think it's fair to return those units after you've flashed them with a nonstandard image.

dance, I haven't used the AE in a high-traffic environment, but Apple is pretty careful about that kind of thing, and they have a very solid code base to pull from. It would likely be just fine.
posted by Malor at 1:33 AM on August 17, 2006


I used to have a WRT54G. It did the same kind of issue. Then I switched to a netgear, after a couple of weeks it wouldn't work properly. I finally decided to do the right choice.
I went out a bought an access point and a switch. Then I loaded PFsense to an old PC and now I have absolutely no internet issue whatsoever.
posted by PowerCat at 5:24 AM on August 17, 2006


It's the NAT Table getting full up.

I have DD-WRT on a Linksys, a Belkin, and an Asus.

You can adjust half-open connection port lifetime in the GUI under

Administration -> IP Filter Settings -> IP Filter Settings

There are three settings exposed in the GUI:

Maximum Ports
You can go to 4096 on this. This is a trade-off. A larger table is better if you are doing lots of p2p, but a larger table will eat up your router's (usually) scarce RAM, which can result in slowdowns or instability. Many consumer routers seem to ship with a table size of 512. I usually go to 1500.

TCP Timeout (s)
Max is set to an unfeasible 3600. I usually set mine to 600 seconds.

UDP Timeout (s)
Max is set to an unfeasible 3600. I usually set mine to 600 seconds.

You can log into DD-WRT terminal and keep a running count of the NAT Table entries using this script.
i=1
while [ "$i" -ne 0 ]
do
cat /proc/net/ip_conntrack | wc -l
sleep 10
done
If it looks like you've set you values too conservatively, then it's time to lower the lifetime or raise the table size.
posted by meehawl at 6:14 AM on August 17, 2006


Well, people have given some pretty technical responses, all quite possibly valid. However, I just wanted to throw out the possibility of something really simple, especially since you said you've been doing lots of p2p. Cable modems get beaten into submission when their upstream bandwidth cap is met. The bandwidth "cap" management from cable modem service is atrociously bad, so if your upstream is pegged (i.e. you're uploading lots of data to other p2p users) then latency is hugely increased. Latency is what you're experiencing when you see "waiting for connection".

When you reset your cable modem, your p2p client loses connections with the folks it was uploading to, and may take some time to re-establish new ones, hence the relative speed increase again. If the solutions you've been given so far are too technical, I'd suggest you consider closing your P2P software (making sure you actually exit, most just go to the system tray unless you take special action) and see if that helps. If that helps, go into the settings of your P2P software and set your maximum upload speed to something a little below that of your max upload speed on the modem. If you know your upstream cap is 128kbps, for example, try about 12Kb/s (12Kb/s = 96kbps), if it's 256kbps, try 24Kb/s etc...
posted by twiggy at 7:36 AM on August 17, 2006


Back to the poster, Brian, if you can't find a way to adjust connections and time to live, and you're not running up against your upstream cap, you may want to consider a new router in any case. Belkin has a less than stellar reputation in the router field ever since they were discovered messing with the data going through their routers to serve ads. That's all it took for me to completely ditch any thought of buying their products.
posted by Dipsomaniac at 8:54 AM on August 17, 2006


I'm pretty sure meehawl's answer is the solution to my problem. Unfortunately, I don't think my router allows me to tweak those settings, and I don't know if a third-party firmware is available for it (I searched once, but not very thoroughly.) I'll keep in mind Belkin's reputation when it comes to buying a new router next time.
posted by Brian James at 10:13 AM on August 17, 2006


twiggy: while that's a possibility, note that the OP didn't *say* they were bouncing their cablemodem. It was the router they were resetting.
posted by baylink at 11:33 AM on August 17, 2006


I'd go with Twiggy... bouncing their router would effectively bounce the cable modem, as the incoming connections would get no ack, and would assume the connection timed out, and stop trying to connect.


If you're using bittorrent or other P2P software, lower your "maximum connections". I had a connextant(sp?) router for Verizon, and if I had more than 200 active connections, the modem died. I had to keep the connections at about 100 max, so I could surf and email and game.

Now that I'm on speakeasy and have a better modem, things are fine, and I don't have to worry about max connections. I've added QOS rules for my router (to keep upstream traffic flowing), and have set the scheduler to limit bandwidth on my torrents while I MIGHT be using the network.

Good luck!
posted by hatsix at 2:01 PM on August 17, 2006


FYI, I used to have similar problems and changing from the stock Linksys to the WW-DRT firmware made the problems go away.

In any case, the WW-DRT firmware allows me to automatically reboot my router once a day at a certain time. That also seems to help greatly. Does your Belkin router have the option to automatically reboot periodically?
posted by apark at 9:54 AM on August 18, 2006


« Older I need to restore a Mac OS X h...   |  Are my co-workers and I being ... Newer »
This thread is closed to new comments.