Join 3,523 readers in helping fund MetaFilter (Hide)


Nonfunctional linksys POS garbage router DIE DIE DIE
April 3, 2006 3:09 PM   Subscribe

I have a Linksys WRT54GC router, and I can't get it to work on my iMac.

I called my ISP's techsupport (SBC DSL), and they told me to call linksys, and then some idiot at an Indian call center told me that "They do not deal with the apple macintosh."

I can connect to the internet when I plug my desktop straight into the modem, but I want to share the connection with an older ibook too. When I plug the modem into the router, then the router in to the imac, it gives me an error about not being able to make a PPPoE connection. Anyone have any ideas?

As an aside, all mac users should boycott linksys. My favorite quote from the conversation was when he asked me what my isp was and I said SBC he asked me how to spell it.
posted by atom128 to Computers & Internet (17 answers total)
 
I take it SBC uses PPPoE to get your connection working - you'll need to connect to the router's configuration page (usually 192.168.1.1 in your browser) and put your PPPoE settings in the appropriate locations. it should just work after that. you shouldn't have to try to connect again using Internet Connect or whatever program SBC may have given you to get online.
posted by mrg at 3:15 PM on April 3, 2006


LOL, ouch.

Ok, first, if you can still return that one, you might want to. The 54GL is a little more expensive, but it's Linux-based, and works better. That's unrelated to your problem, it's just a general observation.. the 54GL is better than the 54GC.

It sounds like your Mac is trying to make a PPPoE connection to SBC, which it can't do with the router in the way. That's why you're getting an error. You need to configure the Linksys with the username/password from the Mac. IT needs to make your PPPoE connection, not the Mac.

Then you just set your Mac and any other computers in your home network to DHCP mode. They get the IP from the Linksys, and use it as the gateway. The Linksys does internal magic (called NAT) to let your multiple computers share a single outbound connection, and everything should just work.
posted by Malor at 3:16 PM on April 3, 2006


Thanks, gonna try that now! It's just odd because it was working for a week and then just *stopped* on saturday.
posted by atom128 at 3:20 PM on April 3, 2006


Okay, the field to put my username in won't accept enough characters. This is silly. *cries*
posted by atom128 at 3:33 PM on April 3, 2006


I have a Mac & Linksys router too (can't remember the model #; not at home right now) and being technically challenged, I was ready to give up but I found an outstanding Linksys tech in India who, with great patience and intelligence, was able to help me set my system up perfectly.
posted by lois1950 at 3:38 PM on April 3, 2006


atom, you should call Linksys on that one. That's really dumb. :(
posted by Malor at 3:40 PM on April 3, 2006


I just checked on my GL, and it will take 63 characters for PPPoE username. The GC doesn't do that much?
posted by Malor at 3:42 PM on April 3, 2006


Sounds like you may want to hit the reset button on the linksys.

Oddly, I had exactly this problem just yesterday. A friend and I came up with two possible solutions, which may help you:

1) Turn off DHCP on the Linksys. Plug the modem into one of the LAN ports on the Linksys. Modem does DHCP, Linksys acts as simple switch.

2) You have two networks. One "inside" the ADSL modem, and one "inside" the Linksys router. Fix the ADSL modem's internal IP to (say) 10.0.0.2 and the Linksys's external IP to (say) 10.0.0.3. Giev the Linksys an internal IP of 196.168.0.2 and turn on its DHCP server, and have it lease out addresses in the 192.168.0.x range.

(BTW, there's nothing wrong with that kit as long as you intend to stick with the official firmware).
posted by Leon at 3:44 PM on April 3, 2006


It just lets me type --------@sbcgloba and cuts off. I called tech support for sbc and they said I could sign in with a sub account so I just made one thats a bit shorter and am about to try it.

leon - Doesnt the modem have to go into the "Internet" plug? I thought the other four were just for various devices.
posted by atom128 at 3:55 PM on April 3, 2006


nope, shorter one still didn't work. *sigh* I hope I can find the receipt.
posted by atom128 at 4:18 PM on April 3, 2006


On the off chance, you have updated the firmware to the most recent version?
posted by Malor at 4:58 PM on April 3, 2006


Atom: No, it doesn't. *sigh*... I'm not very good at explaining this, without resorting to jargon and stuff. Please bear with me.

Right now (if I'm right) you've got two devices on your network that are trying to map between the inside world (your LAN) and the outside world (the internet).

You need to make one of those devices shut up so the other can get on with its job. By plugging the modem into an "internal" port instead of the "internet" socket, you're telling the Linksys box to just route packets around without trying to do all its clever map-from-inside-to-outside stuff. As long as everything else (subnet masks, fixed IP addresses, etc) is good, it should Just Work. (I'm really hoping someone is going to come along and give you clearer instructions here).
posted by Leon at 5:13 PM on April 3, 2006


Leon, if he's getting into the web configuration pages, he's obviously not THAT messed up.
posted by Malor at 5:29 PM on April 3, 2006


Malor - No I haven't though they havent updated the firmware since last May. But I will try it. Thanks for a little credit on my technical compitency. I'm pretty computer savvy, but networking is not something I have a lot of experience with. I've figured I need to have the computer on DHCP and do the PPPoE on the router, and thats how I have it now. Still it's not working.

In the morning I'll try calling linksys again and pretend I have XP, they just ticked me off on their not supporting Macs and I couldn't deal with the moron following his script on the other end. I used to work at a help desk in college, I know what the job is like but man...
posted by atom128 at 7:12 PM on April 3, 2006


Linksys does too support MacIntosh. Brother.

Let's troubleshoot from the very beginning.

Are you using OS 10? If so, this can help: go to the Apple Menu, Location, Network Preferences. Create a new location out of the drop down menu. If you're going to use ethernet, select the Show menu to reveal Built In Ethernet.

For Modem to Router communication, you want to use DHCP. So make sure your IPv4 is configured using DHCP and hit Apply Now, with no other settings. This should yield an IP address of 192.168.xx or similar.

Close the Network window.

Access your Linksys router settings via the 192.168.1.1 address (unless this has been changed, in which case use whatever domain has been provided, but that's the default). Make sure it's configured properly for PPPoE. You should only have to put in your username and password, really. Apply the settings and then check the Status to make sure you really are connected.

That SHOULD work...but I don't work for SBC (I work for a competitor), so I could be a tiny bit off.

And if I am WAY wrong and you're using OS9, let me know, and I'll drag out the steps for that, too.
posted by angeline at 10:21 PM on April 3, 2006


Sorry. I meant, for COMPUTER to router communication. Perils of the night shift.
posted by angeline at 10:22 PM on April 3, 2006


For what it's worth, a similar thread: http://ask.metafilter.com/mefi/24414

with a shorter description of what I was trying to explain. If that doesn't describe your problem then ignore everything I said, as I'm on completely the wrong track.

(Personally, leaving the modem to negotiate the connection rather than doing it on the wireless router makes a lot of sense to me).
posted by Leon at 12:21 AM on April 4, 2006


« Older In an effort to increase produ...   |  I notice that in the US condos... Newer »
This thread is closed to new comments.