Skip

Not another iPhone contacts sync question!
June 19, 2014 2:08 AM   Subscribe

A strange mismatch is going on between my Mac Contacts and my iPhone contacts. Even though I'm using a single Apple ID on both machines, certain contacts exist on the iPhone but not the Mac and vice-versa. I haven't been able to find the explanation for this.

iCloud is active on both machines, contact syncing is turned on, and Contacts on the Mac uses an iCloud-based account; and yet, the iCloud.com website shows a contact list identical to the one on my Mac, with some contacts missing. These are currently only available on my iPhone itself. Should the iPhone get stolen, I'll lose them.

iCloud shows 4.95 of 5 GB free. iTunes is currently set to "Automatically backup to this computer". If I try switching the backup option from "This computer" to "iCloud", a message comes up: "Over capacity by 8 GB." (It's a 16 GB iPhone 4.) So, obviously, I cancel sync and go back to "Backup to this computer".

So how can I get these two to sync? I'd really hate to have to go down the whole thing and enter numbers manually. Thanks.
posted by Silky Slim to Computers & Internet (4 answers total) 1 user marked this as a favorite
 
I'd bet that the contacts that are unique to your phone are being stored on your phone (e.g., SIM contacts). This can happen. Here's one way to fix it:

Go to Settings > Mail, Contacts, Calendars and scroll down until you see an option to "Import SIM Contacts." On my phone, when I do that, it asks me which account I want to import them to, because I have two different sets of contacts syncing to my phone (personal and work). If you've only got one set of contacts, it may not provide you with an option, or it may ask you to confirm -- either way, once you've confirmed/selected the account, it'll show a overlay that says "Importing SIM contacts." Once that's done, all of your SIM contacts should be imported to your iCloud account.

After you've done that, scroll up just slightly to the settings for Contacts, and check the very last item, which is "Default Account." Make sure that shows "iCloud." That way any contact you add on your phone will be added to your iCloud account and not to the phone itself.

You say that there are some contacts on your Mac that are not syncing to your phone, but then don't describe that further. If that's the case, I suspect something similar is going on in the Contacts app on your Mac. I'm not at my Mac right now so I don't know if there's a one-step import function there, too, but one way to do that would be open Contacts, make sure you're viewing "all" contacts, select them all, and then drag and drop the whole selection to "iCloud" under the list of "Accounts" on the left. (You'll probably have "iCloud" and "On My Mac." The "On My Mac" contacts are the ones that aren't getting synced.)
posted by devinemissk at 6:46 AM on June 19


Thanks, devinemissk, but that didn't do the trick. The contacts in question (that are only on the phone) aren't on the SIM. (I imported SIM contacts just in case, but no help.) iCloud was already the default account. But these contacts still don't show up on iCloud.com.
I may have been too hasty with the "vice versa" part... Right now I'm only seeing iPhone contacts that don't make it off the phone and onto iCloud.
posted by Silky Slim at 5:57 AM on June 20


Piggy backing on this question:

Devinemissk, if you had the wrong default account set up, is there a way to move a contact (or group of contacts) from one account to the other?
posted by alms at 9:26 AM on June 23


alms -- only one by one on the phone, I think. But if you're using Contacts on the Mac, you can probably drag and drop between accounts.
posted by devinemissk at 11:05 AM on June 23


« Older Should I help my daughter conn...   |  Picture the scene: you are pas... Newer »

You are not logged in, either login or create an account to post comments



Post