Skip

What have I done to Firefox?
June 12, 2014 2:29 AM   Subscribe

Unusual browser behaviour in Firefox - I can't re-open closed tabs any more. For a long time I've made use of Firefox's 're-open closed tabs' feature - (CTRL-SHIFT-T on a PC). I would shut a tab just as I realised I still needed it, hit the keys and it pinged back just as it was. However, in the last couple of months this functionality has totally vanished and that key combo simply brings up a new blank window. What have I broken? In a related development, about 50% of the time, CTRL-clicking on a browser link doesn't open the link in a new tab, it opens a blank tab instead. Any suggestions welcome.
posted by srednivashtar to Computers & Internet (7 answers total) 4 users marked this as a favorite
 
I've been grumpy about this too - for me it looks like the functionality disappeared with the last update.
posted by brilliantine at 3:08 AM on June 12


My Firefox still does that. But I have the add-on Classic Theme Restorer. Maybe that makes it still work for me? Worth a try...
posted by Too-Ticky at 3:32 AM on June 12


Brilliantine: The undo feature is not gone in the latest update. It works fine for me, with all sorts of modifications in place. Also note "last couple months" puts this problem well before the last update.

In a new tab, go to about:config, and search for browser.sessionstore.max_tabs_undo and browser.sessionstore.max_windows_undo Both of those should have a value other than zero. (10 and 3 for me, respectively) You can modify them by double-clicking on the current value, which will bring up a dialog.

You can also check if the function works independent of the keyboard. If you right-click on the tab bar, undo close tab is listed as a menu item. Same with Ctrl-clicking a link. Does it work using the right-click menu? If so, it starts suggesting your keyboard might be doing something screwy or at least an outside cause. Maybe try the other Ctrl key as an experiment? Is there some other application entirely that might be trying to control that key combination globally?

If you use extensions, it's conceivable something is highjacking it. I think core key combos shouldn't allow this, but you may as well check. Try using safe mode to launch Firefox in a default state. If it behaves normally then, you'll have to start doing process of elimination to figure out what extension or whatever is doing it.

Worst case, you can reset the browser altogether. (It's not a total wipe. A lot of your important info is still retained; refer details on that page.) But you might want to try the Portable Apps version before trashing all your prefs like that. If things behave there, then it's some more evidence your browser setup is somehow messed up/conflicted. On the other hand, if the problem is identical with the Portable copy, it suggests an outside factor.
posted by Su at 3:42 AM on June 12 [1 favorite]


Thanks for the answers. I tried safe mode and yes, that corrects the behaviour. The about: config files show that all is as it should be. Re-launching as normal brought the problem straight back, although interestingly you can see the URL of the recently closed tab in the address bar for a fraction of a section before it defaults to the default new tab address.
posted by srednivashtar at 3:54 AM on June 12


Ah, it looks like the culprit was an add-on called NewTabURL, which I've now disabled. Bonus question; how do I get new tabs (CTRL-T) to automatically open a predefined URL, as that was what that add-on did quite effectively. Thank you all again.
posted by srednivashtar at 3:58 AM on June 12


Open about:config and find

browser.newtab.url

Edit appropriately, enjoy!
posted by quinndexter at 4:12 AM on June 12


Thank you all. Sorted.
posted by srednivashtar at 5:20 AM on June 12


« Older It has taken me two years to g...   |  There's got to be a word or ph... Newer »

You are not logged in, either login or create an account to post comments



Post