Join 3,551 readers in helping fund MetaFilter (Hide)


HDMI Cable Question (Laptop-TV with no sound)
April 21, 2014 5:03 AM   Subscribe

Help me connect a Laptop to TV with an HDMI Cable AND get sound.

At my house, I currently have my laptop connected to my Samsung Smart TV via a HDMI cable. I simply place my laptop next to my tv, connect the HDMI cable to both the laptop and the TV and whatever I am viewing on my laptop, I watch on my tv. This is great, and it works flawlessly and takes about 4 seconds to set up. Everything works perfect and the sound plays though my tv set up.

I recently tried to do the same thing at my parent's house. I have some family video's of my neice that I wanted to show from my laptop, so I tried to do the same thing with the laptop to my fathers tv (a LG smart tv). I simply connected the laptop to the tv via a HDMI cable and the video worked perfect on the tv, however, the sound only played through the laptop and NOT the TV (which was useless).

Obviously I am missing something. Can someone provide some possible solutions so I can also get the sound to play through the tv like with my set up?

Thanks!
posted by dbirchum to Technology (8 answers total) 1 user marked this as a favorite
 
2 thoughts:
HDMI may be using a different sound "card" for outputting the audio than the internal speakers use. If this isn't being chosen automatically then you may be able to adjust this through the playback devices or volume control panels accessible by right clicking on the speaker icon in windows in the system tray. osx may have a similar feature.

Or, your parents tv may be set up differently than yours for that hdmi port and expecting external audio input from another input, like optical(toslink),spdif, or regular rca cables. You'd have to dig into the config menus for their tv. Or if they use a home theater receiver, sound bar, or other assorted device for outputting audio you may need to run hdmi to that instead of direct to the tv.
posted by TheAdamist at 5:21 AM on April 21


TheAdamist's first thought is what fixes the problem for me. I don't have access to the laptop right now or I'd do a step by step. But it's in the playback settings as TheAdamist says. I'd have it all set up fine and working, then another time I'd set it up the same way, only this time the audio plays through the laptop and I'd have to go into those settings and change it.

Have something playing, and then go into those settings so that when the different devices come up, you can see (via the pulsing meter) which one the sound is going through, and choose the different one that sends it to the tv. If I remember correctly, it might even make you choose to set it as default to change devices.
posted by cashman at 6:20 AM on April 21


This happened to me on windows 7. What I had to do:

right click the speaker icon where the volume control normall is
select 'playback devices'
select 'samsung tv' instead of 'speakers'
select 'set default'

at which point the sound starts coming from my tv
posted by jaymzjulian at 6:21 AM on April 21 [3 favorites]


(I am assuming a Win system)

I have 2 TVs as aux monitors along with my regular LED monitors. Each TV shows up as a separate monitor (they are different brands). For sound, each TV shows up as a separate playback device.

Go to your Sound Control Panel and under the Playback tab, check for a new entry that would match LG Smart TV. Set that as default and the sound should play.

This is what mine looks like.
posted by lampshade at 6:25 AM on April 21


(or what jaymzjulian just said)
posted by lampshade at 6:26 AM on April 21


Sorry, I should have mentioned that my fathers laptop (which is what we were trying to hook up to his LG tv), is a Windows 7 machine.
posted by dbirchum at 6:33 AM on April 21


I'd check the Audio Source setting in your father's TV's admin.
posted by humboldt32 at 10:42 AM on April 21


If your father has an AV receiver in addition to the TV, he may well have the TV speakers turned off in the TV's settings.
posted by wierdo at 1:54 PM on April 21


« Older I find a good Let's Play to be...   |  I want to upcycle this glitter... Newer »

You are not logged in, either login or create an account to post comments