Skip

Why is my newly build computers internet not working?
January 30, 2014 7:22 PM   Subscribe

So, I just finished building a new computer and have installed windows, all the driver CDs, etc. Then I went to connect it to the internet so I could install some anti-virus software, download the rest of the drivers, etc and no dice. I feel bad having to ask for help, since I'm a computer geek, but well, it is ethernet straight into a modem; normally I just plug it in and it works.

Of course I've googled, but the vast majority of places tell me to make sure the drivers are installed (Yep, shows up in device manager. Deleted the device and searched for it, and it came back. Still no dice.

There is no router, just the modem, so I am swapping the cable back and forth between my laptop and the PC, so I know the modem is working correctly and the cable is good. When I plug in the cable the computer searches for ages and ages, finds the network but claims it isn't connected to the internet. I can ping 127.0.0.1, but not the default gateway, though I see that isn't uncommon if you are plugged straight into the router.

My only idea is that I screwed up a setting in the BIOS, as I know I changed some network settings there to turn off things I don't use (Wake on LAN), though I've no idea what would cause this.

I'll take either suggestions, or a link to a good troubleshooting guide. Really anything. My next step is (Once the second HD is done formatting, which could be a good lone while, as it has taken something like an hour to get to 49%) to reboot and go over the BIOS settings, make sure I didn't miss anything stupid there. Other then that, help?

Oh, I have a Realtek PCIe GBE Family Controller, and I got the drivers off my motherboard CD. I've tried restarting the computer, it is set to get the IP and DNS automatically.

Man, I feel like I should just give up on my geek card with all the mistakes and problems I've had building this thing.
posted by Canageek to Computers & Internet (12 answers total) 1 user marked this as a favorite
 
ipconfig /all

Does your media state for the Ethernet card show up as media disconnected? If so, reseat your card, check your drivers, and make sure things are showing up in device manager.

If it doesn't say media disconnected, post the ipconfig output for the Ethernet device. I'm curious if you're getting an APIPA address.
posted by bfranklin at 7:30 PM on January 30


I assume this is for an integrated NIC that is part of your motherboard? Might try actually resetting the BIOS settings to their defaults, just to make sure that some obscure setting didn't disable it. Might also try rebooting the cable modem in case it's remembering your laptop's MAC address or something.

Seconding sending the output of ipconfig /all. That's probably going to be the most useful thing for troubleshooting.
posted by Aleyn at 7:34 PM on January 30


Shows as connected.
I forgot to mention, the setup in this place is odd; I need to have the TV box also plugged in via a cable splitter or the internet doesn't work. Not sure if that is relevant.


Windows IP Configuration

Host Name . . . . . . . . . . . . : Mikasa
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
Physical Address. . . . . . . . . : [censored]
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::fc2f:2342:67f2:dabd%11(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.218.189(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : [censored]
DHCPv6 Client DUID. . . . . . . . : [censored]
DNS Servers . . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{censored}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
posted by Canageek at 7:47 PM on January 30


Yep, an APIPA address. That means a DHCP failure. Assuming you're running some commodity home router, a) confirm that you don't have it locked down to only lease to specific mac addresses, and b) reboot the thing. For whatever reason, home routers like to get flaky with DHCP after a number of weeks of uptime.
posted by bfranklin at 8:05 PM on January 30


There is no router, I forgot to buy one of those before setting up the second PC, so I'm swapping the cable between my laptop and the desktop.

How would I go about confirming the first one? Due to my situation (Grad apartment on campus) I don't actually have an account number or anything with Shaw, it all comes with the room. Someone suggested that I set the desktop to have the same MAC as my laptop, is that a bad idea?

The diagram of how I'm set up is on twitter if that helps.
posted by Canageek at 8:11 PM on January 30


Yeah, your cable modem isn't (for whatever reason) providing your PC with its configuration info (DHCP).

This works on your laptop, no? Plug it into your laptop, do the same ipconfig thing, and see what it says. Then you could try manually setting your desktop to the same thing -- important bits being Gateway, IP Address, Subnet Mask (typically 255.255.255.0), and DNS server (or use 8.8.8.8 and 8.8.4.4).

It's possible there's a MAC filter on the modem, but unless you gave your laptop's MAC address to them at some point this seems unlikely.

It doesn't look to me like this is a hardware/driver problem at all.
posted by neckro23 at 8:19 PM on January 30


You're just wasting your time trying to get this working without a router -- go get a cheap wifi router and connect that way.
posted by empath at 8:21 PM on January 30


Are you using a criss-cross cable? One of the weird aspects of 100-base-T (or 1000-base-T) is that there are two ways of wiring the connector and you can't tell them apart just by looking at them. They're supposed to be labeled, but sometimes they aren't.

For lack of a better term call 'em "client" and "host". Modems often have both kinds, and if you use a straight-through cable to connect two client connectors, no one will see anything because they're both talking on the same wire, and both listening on the other.

Likewise if one's a client and the other a host and you're using a criss-cross cable, same thing happens.

The modem ought to have indicator LEDs which light if the connection is correct.
posted by Chocolate Pickle at 8:40 PM on January 30


Based on some advice I got I cloned my laptop's MAC to the new PC. Boom, everything now works perfectly. I'm guessing that they just assumed I'd use a router and grabbed the MAC of the first thing I hooked up as the one to lock me to. No idea why they would do that, but it works now. Thanks all.
posted by Canageek at 8:51 PM on January 30


One of the weird aspects of 100-base-T (or 1000-base-T) is that there are two ways of wiring the connector and you can't tell them apart just by looking at them.

MDI/MDIX crossover was an issue with old 10-base-T ethernet, but auto MDI/MDIX is overwhelmingly common in 100Mbps Ethernet and is specified as required in 1Gbps transceivers. Also, only 1 device needs auto crossover for the negotiation to succeed.

If either device is gigabit then you can't have a crossover issue, and you'd be pretty unlucky to find 2 devices with 100Mbps where neither supports auto-crossover.

(but not your actual issue, as it turns out)
posted by russm at 3:37 AM on January 31


I have found a couple of times that the modem needs to be fully rebooted to connect to a new computer (that is, a new MAC address). Cloning the MAC address is another way around the problem.
posted by DarkForest at 8:09 AM on January 31 [1 favorite]


I've had a couple of cable modems that worked with just the first MAC that they were configured with. Both were provided by Comcast, so they were probably Motorola Surfboards.

If you changed routers, or plugged a PC into it directly, you had to reset the cable modem to defaults and reconfigure it with your username and password for the Internet account.

This was likely implemented as a simple way to enforce the "one modem, one device" terms of service. Dunno.

Duplicating the MAC ID of the previously-connected computer is a good workaround for now, but if you want to plug your desktop and laptop both into a switch later it will be a problem. Just file away "reset to defaults and re-log-in to Internet provider" for later.
posted by Kakkerlak at 9:00 AM on January 31 [1 favorite]


« Older Having attended a bunch of rea...   |  Bookclub filter: Nonfiction wi... Newer »

You are not logged in, either login or create an account to post comments



Post